Bug 1072708 - Installer errors: 1) Could not start Service[httpd] 2) 'ERROR: role "candlepin" already exists
Summary: Installer errors: 1) Could not start Service[httpd] 2) 'ERROR: role "candle...
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Satellite
Classification: Red Hat
Component: Installer
Version: 6.0.3
Hardware: Unspecified
OS: Unspecified
unspecified
high vote
Target Milestone: Unspecified
Assignee: Eric Helms
QA Contact: Sachin Ghai
URL: http://projects.theforeman.org/issues...
Whiteboard:
: 1077879 1099498 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-03-05 04:53 UTC by Sachin Ghai
Modified: 2019-09-26 17:42 UTC (History)
10 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-07-02 14:05:05 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Foreman Issue Tracker 5012 0 Normal Closed Candlepin role already exists 2019-12-12 09:11:58 UTC

Description Sachin Ghai 2014-03-05 04:53:28 UTC
Description of problem:
Installed satellite6 MDP3 Beta - Summit Release Snap 1 Compose 3 on rhel6.5 x86_64 box.

Katello installer throws following errors:

----
 /Stage[main]/Candlepin::Database/Postgresql::Server::Db[candlepin]/Postgresql::Server::Role[candlepin]/Postgresql_psql[CREATE ROLE "candlepin" ENCRYPTED PASSWORD 'md5580ac068a1e2d948bfec74507cf3cde2' LOGIN NOCREATEROLE NOCREATEDB NOSUPERUSER  CONNECTION LIMIT -1]: Failed to call refresh: Error executing SQL; psql returned 256: 'ERROR:  role "candlepin" already exists
 /Stage[main]/Candlepin::Database/Postgresql::Server::Db[candlepin]/Postgresql::Server::Role[candlepin]/Postgresql_psql[CREATE ROLE "candlepin" ENCRYPTED PASSWORD 'md5580ac068a1e2d948bfec74507cf3cde2' LOGIN NOCREATEROLE NOCREATEDB NOSUPERUSER  CONNECTION LIMIT -1]: Error executing SQL; psql returned 256: 'ERROR:  role "candlepin" already exists
 Could not start Service[httpd]: Execution of '/usr/share/katello-installer/modules/service_wait/bin/service-wait httpd start' returned 1: 
 /Stage[main]/Apache::Service/Service[httpd]/ensure: change from stopped to running failed: Could not start Service[httpd]: Execution of '/usr/share/katello-installer/modules/service_wait/bin/service-wait httpd start' returned 1: 
 /Stage[main]/Foreman::Database/Foreman::Rake[db:seed]/Exec[foreman-rake-db:seed]: Failed to call refresh: /usr/sbin/foreman-rake db:seed returned 1 instead of one of [0]
 /Stage[main]/Foreman::Database/Foreman::Rake[db:seed]/Exec[foreman-rake-db:seed]: /usr/sbin/foreman-rake db:seed returned 1 instead of one of [0]
Installing             Done                                               [100%] [..................................................................]
----

Version-Release number of selected component (if applicable):

rubygem-hammer_cli_katello-0.0.3-1.el6sat.noarch
katello-candlepin-cert-key-pair-1.0-1.noarch
rubygem-katello_api-0.0.8-1.el6sat.noarch
katello-1.5.0-17.el6sat.noarch
katello-repos-1.5.1-1.git.14.0868bd1.el6.noarch
katello-installer-0.0.24-1.el6sat.noarch
pulp-katello-plugins-0.2-1.el6sat.noarch
katello-certs-tools-1.5.3-1.el6sat.noarch
ruby193-rubygem-katello-1.5.0-18.el6sat.noarch
ruby193-rubygem-foreman-tasks-0.3.1-2.el6sat.noarch
foreman-postgresql-1.5.0.6-1.el6sat.noarch
rubygem-foreman_api-0.1.11-2.el6sat.noarch
foreman-1.5.0.6-1.el6sat.noarch
rubygem-hammer_cli_foreman-0.0.18-1.el6sat.noarch
foreman-release-1.5.0-0.develop.201402250936git8cf1033.el6.noarch
foreman-selinux-1.3.0-1.el6sat.noarch

How reproducible:
other QE folks faced same issue

Steps to Reproduce:
1. run katello-installer for satellite6 MDP3 Beta - Summit Release Snap 1 Compose 3
2.
3.

Actual results:


Expected results:
Installation should be error free.

Additional info:

Comment 1 RHEL Program Management 2014-03-05 04:54:16 UTC
Since this issue was entered in Red Hat Bugzilla, the release flag has been
set to ? to ensure that it is properly evaluated for this release.

Comment 3 Sachin Ghai 2014-03-05 05:08:45 UTC
on manually restarting httpd service, I got: 


[root@dhcp201-1xx ~]# service httpd restart
Stopping httpd:                                            [FAILED]
Starting httpd: [Wed Mar 05 04:57:35 2014] [warn] module passenger_module is already loaded, skipping
Syntax error on line 42 of /etc/httpd/conf.d/05-foreman-ssl.conf:
SSLCertificateChainFile: file '/var/lib/puppet/ssl/certs/ca.pem' does not exist or is empty
                                                           [FAILED]

Comment 4 Jan Hutař 2014-03-14 07:40:49 UTC
'ERROR:  role "candlepin" already exists' still an issue in Satellite-6.0.3-RHEL-6-20140313.0:

[...]
Notice: /Stage[main]/Postgresql::Server::Config/Co: 281/414, 67%, 6.2/s, elapsed: 00:02:06, ETA: 00:00:21
Debug: Executing '/sbin/chkconfig postgresql'     : 287/414, 69%, 8.4/s, elapsed: 00:02:09, ETA: 00:00:15
Info: RESOURCE Postgresql_psql[ALTER ROLE "foreman: 296/414, 71%, 8.4/s, elapsed: 00:02:10, ETA: 00:00:13
[31m /Stage[main]/Candlepin::Database/Postgresql::Server::Db[candlepin]/Postgresql::Server::Role[candlepin]/Postgresql_psql[CREATE ROLE "candlepin" ENCRYPTED PASSWORD 'md56099b371abd704860ebdf03bd054f3a1' LOGIN NOCREATEROLE NOCREATEDB NOSUPERUSER  CONNECTION LIMIT -1]: Failed to call refresh: Error executing SQL; psql returned 256: 'ERROR:  role "candlepin" already exists
[0m[31m /Stage[main]/Candlepin::Database/Postgresql::Server::Db[candlepin]/Postgresql::Server::Role[candlepin]/Postgresql_psql[CREATE ROLE "candlepin" ENCRYPTED PASSWORD 'md56099b371abd704860ebdf03bd054f3a1' LOGIN NOCREATEROLE NOCREATEDB NOSUPERUSER  CONNECTION LIMIT -1]: Error executing SQL; psql returned 256: 'ERROR:  role "candlepin" already exists
[0mInfo: RESOURCE Postgresql_psql[ALTER ROLE "candlep: 300/414, 72%, 8.4/s, elapsed: 00:02:11, ETA: 00:00:13
Notice: /Stage[main]/Candlepin::Database/Postgresq: 308/414, 74%, 9.4/s, elapsed: 00:02:12, ETA: 00:00:11
[...]

Comment 5 Jan Hutař 2014-03-19 13:28:49 UTC
Also note that exit code of the katello-installer is 6 and not 0.

Comment 6 Devan Goodwin 2014-04-30 11:43:05 UTC
Being tracked in Foreman as:

http://projects.theforeman.org/issues/5012

And seems to trace back to an actual upstream puppet-postgresql bug:

https://tickets.puppetlabs.com/browse/MODULES-775

Comment 7 Benjamin Chardi 2014-05-27 10:46:53 UTC
In sat6-beta-snap6 the problem is still there:

# katello-installer

...

 /Stage[main]/Candlepin::Database/Postgresql::Server::Db[candlepin]/Postgresql::Server::Role[candlepin]/Postgresql_psql[CREATE ROLE "candlepin" ENCRYPTED PASSWORD 'md5f1c7a15c3a9fe5c4133efc6c657ecf33' LOGIN NOCREATEROLE NOCREATEDB NOSUPERUSER  CONNECTION LIMIT -1]: Failed to call refresh: Error executing SQL; psql returned 256: 'ERROR:  role "candlepin" already exists
 /Stage[main]/Candlepin::Database/Postgresql::Server::Db[candlepin]/Postgresql::Server::Role[candlepin]/Postgresql_psql[CREATE ROLE "candlepin" ENCRYPTED PASSWORD 'md5f1c7a15c3a9fe5c4133efc6c657ecf33' LOGIN NOCREATEROLE NOCREATEDB NOSUPERUSER  CONNECTION LIMIT -1]: Error executing SQL; psql returned 256: 'ERROR:  role "candlepin" already exists
...

Any news about when this will be fixed ?

Many thanks

Comment 8 Milan Zázrivec 2014-05-28 13:23:32 UTC
Same experience with Satellite 6 nightly compose (May-28):

# katello-installer 
 /Stage[main]/Candlepin::Database/Postgresql::Server::Db[candlepin]/Postgresql::Server::Role[candlepin]/Postgresql_psql[CREATE ROLE "candlepin" ENCRYPTED PASSWORD 'md584d4b9d479e837ef3628c35a5c4c2e1f' LOGIN NOCREATEROLE NOCREATEDB NOSUPERUSER  CONNECTION LIMIT -1]: Failed to call refresh: Error executing SQL; psql returned 256: 'ERROR:  role "candlepin" already exists
 /Stage[main]/Candlepin::Database/Postgresql::Server::Db[candlepin]/Postgresql::Server::Role[candlepin]/Postgresql_psql[CREATE ROLE "candlepin" ENCRYPTED PASSWORD 'md584d4b9d479e837ef3628c35a5c4c2e1f' LOGIN NOCREATEROLE NOCREATEDB NOSUPERUSER  CONNECTION LIMIT -1]: Error executing SQL; psql returned 256: 'ERROR:  role "candlepin" already exists
Installing             --- /etc/foreman-proxy/settings.ymlttings2014-05-20 15: [99%] [..................Installing             +++ /tmp/puppet-file20140528-30255-16qh6n7-0     2014- [99%] [...................Installing             Done                                               [100%] [....................]
  Something went wrong! Check the log for ERROR-level output
  The full log is at /var/log/katello-installer/katello-installer.log

Comment 9 Eric Helms 2014-05-28 19:01:22 UTC
*** Bug 1077879 has been marked as a duplicate of this bug. ***

Comment 10 Eric Helms 2014-06-05 03:23:53 UTC
*** Bug 1099498 has been marked as a duplicate of this bug. ***

Comment 11 Bryan Kearney 2014-06-09 18:03:54 UTC
Moving to POST since upstream bug http://projects.theforeman.org/issues/5012 has been closed

Comment 13 Sachin Ghai 2014-06-12 08:05:56 UTC
Verified with sat6 beta snap9 (Satellite-6.0.3-RHEL-6-20140611.1).

The reported issue is not reproducible. I was able to run the installer successfully.

Comment 14 Bryan Kearney 2014-07-02 14:05:05 UTC
This was delivered with 6.0.3, which is the Satellite 6 Beta.


Note You need to log in before you can comment on or make changes to this bug.