Bug 110101

Summary: ssh crashes shortly after connection.
Product: [Fedora] Fedora Reporter: David Mark North <north>
Component: opensshAssignee: Tomas Mraz <tmraz>
Status: CLOSED NOTABUG QA Contact: Brian Brock <bbrock>
Severity: medium Docs Contact:
Priority: medium    
Version: 1CC: geoffhart
Target Milestone: ---   
Target Release: ---   
Hardware: i686   
OS: Linux   
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2005-02-07 09:31:45 EST Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Description David Mark North 2003-11-14 15:26:10 EST
Description of problem:
signing on to just about any system crashes ssh after a short while.
None of the suggested fixes/workarounds seems to improve the situation
(ie forcing iso-8859-1 instead of utf8 in gnome-terminal, et al)

Version-Release number of selected component (if applicable):
cdrom install version

How reproducible:
Every time.

Steps to Reproduce:
1. sign on to non-fedora system using ssh
2. do just about anything for a while. reading mail is quick.
3. watch your connection die.
Actual results:
connection dies (as does ssh process)

Expected results:

Additional info:
Comment 1 David Mark North 2003-11-27 18:16:49 EST
I've refined this quite a bit and could give a blow-by-blow but ...
What it boiled down to was getting a hostname from the primary nameserver. In other 
words, if I ssh foo to a nameserver foo (which by coincidence is what I tried each 
time) without having that "foo" in the hosts table (so that the nameserver resolved the 
hostname rather than locally) it broke.

Usually (but not always) the connection was dropped after saying 'corrupeted MAC'

If I ssh to the ip of that same nameserver, it worked. If I put the 'foo' into the host 
table, it worked. I consider this pretty weird. However, using either the IP or including 
the primary nameserver in the hosts table seems to have fixed it so far.
Comment 2 Damien Miller 2004-08-24 21:03:31 EDT
There is extensive discussion of this at
http://bugzilla.mindrot.org/show_bug.cgi?id=845  (read also the bugs
that it references)

Summation: there are various network devices, in particular Linksys
routers, that corrupt packets.
Comment 3 Tomas Mraz 2005-02-07 09:31:45 EST
See comment #2
Comment 4 Tomas Mraz 2005-02-07 09:37:55 EST
*** Bug 112846 has been marked as a duplicate of this bug. ***
Comment 5 Autoversicherung 2005-04-10 16:24:21 EDT
I dont have a linksys router and it still happens!

<a href="autoversicherung.einsurance.de/">Autoversicherung</a>
Comment 6 David Mark North 2005-04-10 17:14:03 EDT
If I hardwire bypass my router it still happens. So we're on the same page,
auto. Even more interesting, if I ssh to just about any outside computer (which
has to have remote hostname resolution and _has_ to go through my router) it
works fine.

Extensive discussion does not seem to have had much effect on reality. Not the
first time I've seen that effect: I suspect computers/software/networks are not
a faith-based process.