This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 112846 - ssh client frequently disconnects with "Corrupted MAC on input"
ssh client frequently disconnects with "Corrupted MAC on input"
Status: CLOSED DUPLICATE of bug 110101
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: openssh (Show other bugs)
3.0
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Tomas Mraz
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-01-03 18:04 EST by Geoff Hart
Modified: 2007-11-30 17:06 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-02-07 09:37:45 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Geoff Hart 2004-01-03 18:04:59 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4) Gecko/20030922

Description of problem:
When I try to connect via ssh or transfer files via sftp between a
laptop running WSE3.0 and a server running RedHat Linux 7.3 I get
disconnected frequently with the error: "Disconnecting: Corrupted MAC
on input."

When connecting via ssh, I appear to get dropped after several screens
of text have been transfered. When I connect via sftp, it usually
drops the connection (hangs forever to be precise) after 1-2 MB has
been transfered. It appears to be me that the length of time from
connection to error is random, but a strong function of the amount of
data transfered.

My initial investigation focused on looking for a bad network adaptec
somewhere, but in testing I found:
- 2 Windows machines running Putty (over ssh) were never disconnected
- I could sftp 200MB files from the server using sftp in Windows
without problems
- I could sftp 200MB files from the laptop using sftp in Windows
without problems
- When I had Red Hat 7.3 or 9.0 installed on my laptop I didn't notice
 this problem, although I didn't explcitly test for it either.
However, I think I would have noticed since I do access this server a lot.

I have tried running various things in verbose mode, but I don't see
any useful looking logging data.

Version-Release number of selected component (if applicable):
openssh-clients-3.6.1p2-18

How reproducible:
Sometimes

Steps to Reproduce:
1. Connect via ssh from a machine running WSE3.0 to a machine running
RedHat 7.3.
2. Transfer as much data as possible, for example, cat a few bigs files
3. Connection will be dropped with the following error:
Disconnecting: Corrupted MAC on input.

This can be done with sftp as well by transfering a big file from the
server to the client, but it just hangs which makes it harder to
demonstrate.
    

Actual Results:  Connection will be dropped with the following error:
Disconnecting: Corrupted MAC on input.

Expected Results:  Connection should not be dropped.

Additional info:
Comment 1 Graham Leggett 2004-07-19 10:14:20 EDT
I am getting this same error between two RHEL3 machines - both
machines fully up to date.

Both sides are using openssh-3.6.1p2-33.30.1.

Google searches reveal lots of people with this problem, though the
only advice so far has been "upgrade your SSH".

Comment 2 Tomas Mraz 2005-02-07 09:37:45 EST

*** This bug has been marked as a duplicate of 110101 ***

Note You need to log in before you can comment on or make changes to this bug.