Bug 110109

Summary: Black screen background when starting new Tab
Product: [Fedora] Fedora Reporter: Brad <bradb>
Component: gnome-terminalAssignee: Havoc Pennington <hp>
Status: CLOSED DUPLICATE QA Contact:
Severity: medium Docs Contact:
Priority: medium    
Version: 1CC: bart.martens, gelsoft, jesran
Target Milestone: ---   
Target Release: ---   
Hardware: i686   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2006-02-21 14:00:00 EST Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
Attachments:
Description Flags
Screen dump of the problem none

Description Brad 2003-11-14 16:06:37 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4.1)
Gecko/20031030 Epiphany/1.0.4

Description of problem:
When opening a new tab with File-New Tab-Default or Shift-Ctl-T the
screen background goes black. The application still works OK though.
If I Alt-Tab to another application (or select another application
from the Panel) and then go back again, the gnome-terminal screen is
white again.

I am unsure, but this may have something to do with my video card
setup. However this is exactly the same hardware that I was using with
RH9 and I had no problems with it. RH9 version of gt was 2.2.1-3.

I will attach a scrren dump to this report.

Version-Release number of selected component (if applicable):
2.4.0.1

How reproducible:
Always

Steps to Reproduce:
1. See description
2.
3.
    

Additional info:

My video card setup:

Video card: nVidia FX5600
Screen res: 1280 x 1024

XF86Config:

Section "Monitor"
        Identifier   "Monitor0"
        VendorName   "Monitor Vendor"
        ModelName    "BENQ P992"
        DisplaySize  350        260
        HorizSync    30.0 - 98.0
        VertRefresh  50.0 - 160.0
        Option      "dpms"
EndSection
 
Section "Device"
        Identifier  "Videocard0"
        Driver      "nv"
        VendorName  "Videocard vendor"
        BoardName   "NVIDIA GeForce FX (generic)"
EndSection
 
Section "Screen"
        Identifier "Screen0"
        Device     "Videocard0"
        Monitor    "Monitor0"
        DefaultDepth     24
        SubSection "Display"
                Depth     24
                Modes    "1280x1024" "1280x960" "1152x864" "1024x768"
"800x600" "640x480"
Comment 1 Brad 2003-11-14 16:09:28 EST
Created attachment 95987 [details]
Screen dump of the problem
Comment 2 Gerald Neale 2003-11-20 00:48:58 EST
Same problem here starting on third tab...
# XFree86 4 configuration created by pyxf86config
 
Section "ServerLayout"
        Identifier     "Default Layout"
        Screen      0  "Screen0" 0 0
        InputDevice    "Mouse0" "CorePointer"
        InputDevice    "Keyboard0" "CoreKeyboard"
        InputDevice    "DevInputMice" "AlwaysCore"
EndSection
 
Section "Files"
 
# RgbPath is the location of the RGB database.  Note, this is the name
of the
# file minus the extension (like ".txt" or ".db").  There is normally
# no need to change the default.
# Multiple FontPath entries are allowed (they are concatenated together)
# By default, Red Hat 6.0 and later now use a font server independent of
# the X server to render fonts.
        RgbPath      "/usr/X11R6/lib/X11/rgb"
        FontPath     "unix/:7100"
EndSection
 
Section "Module"
        Load  "dbe"
        Load  "extmod"
        Load  "fbdevhw"
        Load  "glx"
        Load  "record"
        Load  "freetype"
        Load  "type1"
        Load  "dri"
EndSection
 
Section "InputDevice"
 
# Specify which keyboard LEDs can be user-controlled (eg, with xset(1))
#       Option  "Xleds"         "1 2 3"
# To disable the XKEYBOARD extension, uncomment XkbDisable.
#       Option  "XkbDisable"
# To customise the XKB settings to suit your keyboard, modify the
# lines below (which are the defaults).  For example, for a non-U.S.
# keyboard, you will probably want to use:
#       Option  "XkbModel"      "pc102"
# If you have a US Microsoft Natural keyboard, you can use:
#       Option  "XkbModel"      "microsoft"
#
# Then to change the language, change the Layout setting.
# For example, a german layout can be obtained with:
#       Option  "XkbLayout"     "de"
# or:
#       Option  "XkbLayout"     "de"
#       Option  "XkbVariant"    "nodeadkeys"
#
# If you'd like to switch the positions of your capslock and
# control keys, use:
#       Option  "XkbOptions"    "ctrl:swapcaps"
# Or if you just want both to be control, use:
#       Option  "XkbOptions"    "ctrl:nocaps"
#
        Identifier  "Keyboard0"
        Driver      "keyboard"
        Option      "XkbRules" "xfree86"
        Option      "XkbModel" "pc105"
        Option      "XkbLayout" "us"
EndSection
 
Section "InputDevice"
        Identifier  "Mouse0"
        Driver      "mouse"
        Option      "Protocol" "IMPS/2"
        Option      "Device" "/dev/psaux"
        Option      "ZAxisMapping" "4 5"
        Option      "Emulate3Buttons" "no"
EndSection
 
Section "InputDevice"
 
# If the normal CorePointer mouse is not a USB mouse then
# this input device can be used in AlwaysCore mode to let you
# also use USB mice at the same time.
        Identifier  "DevInputMice"
        Driver      "mouse"
        Option      "Protocol" "IMPS/2"
        Option      "Device" "/dev/input/mice"
        Option      "ZAxisMapping" "4 5"
        Option      "Emulate3Buttons" "no"
EndSection
 
Section "Monitor"
        Identifier   "Monitor0"
        VendorName   "Monitor Vendor"
        ModelName    "Sony Multiscan 20se"
        HorizSync    31.5 - 85.0
        VertRefresh  50.0 - 150.0
        Option      "dpms"
EndSection
 
Section "Device"
        Identifier  "Videocard0"
        Driver      "ati"
        VendorName  "Videocard vendor"
        BoardName   "ATI Mach64 3D Rage IIC"
EndSection
 
Section "Screen"
        Identifier "Screen0"
        Device     "Videocard0"
        Monitor    "Monitor0"
        DefaultDepth     24
        SubSection "Display"
                Depth     24
                Modes    "1024x768" "800x600" "640x480"
        EndSubSection
EndSection
 
Section "DRI"
        Group        0
        Mode         0666
EndSection
Comment 3 Panu Matilainen 2004-02-10 06:03:18 EST
I'm seeing this too, on every piece of HW I've tried (including
Savage, ATI Radeon and Nvidia graphics cards) so I doubt it has much
to do with that. Occurs when launching new gnome-terminal and then
typically on second or third tab the background remains black.
Comment 4 Bart Martens 2004-02-16 16:49:05 EST
Duplicate of bug #100420.

Comment 5 Alexandre Oliva 2004-02-16 18:42:02 EST

*** This bug has been marked as a duplicate of 100420 ***
Comment 6 Red Hat Bugzilla 2006-02-21 14:00:00 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.