This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 100420 - gnome-terminal open tab twice, all black?
gnome-terminal open tab twice, all black?
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: vte (Show other bugs)
4.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Tomáš Bžatek
: Regression, Reopened
: 110109 134466 (view as bug list)
Depends On:
Blocks: CambridgeTarget
  Show dependency treegraph
 
Reported: 2003-07-22 05:18 EDT by Warren Togami
Modified: 2015-03-03 17:27 EST (History)
14 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-06-20 12:13:59 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
redraw vte screen when unobscured visibility event is caught (709 bytes, patch)
2004-10-27 15:30 EDT, Jon Nettleton
no flags Details | Diff

  None (edit)
Description Warren Togami 2003-07-22 05:18:39 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4) Gecko/20030703

Description of problem:
First noticed this minor quirk in Severn beta 9.0.93.

Version-Release number of selected component (if applicable):
gnome-terminal-2.2.1-4

How reproducible:
Always

Steps to Reproduce:
1. Open gnome-terminal with default settings.
2. CTRL-SHIFT-t once.
3. CTRL-SHIFT-t again.

Actual Results:  
Black fills the window except for the prompt.

Expected Results:  
Should be all white like the previous tab.
Comment 1 Havoc Pennington 2003-08-07 17:37:18 EDT
Predict this is a vte issue, gnome-terminal hasn't really changed.
Comment 2 George Karabin 2003-09-06 11:50:54 EDT
FWIW, I can't reproduce this on today's Rawhide. I haven't looked for the bug
before, though, so I can't say if it's been fixed, or if it's just something
that works on my machine.
Comment 3 Alexandre Oliva 2003-09-06 15:11:22 EDT
I still get the problem with gnome-terminal-2.3.2-1 and vte-0.11.10-2 (both in
rawhide and Severn updates).
Comment 4 Miloš Komarčević 2003-09-18 18:29:35 EDT
I'm still seeing this with gnome-terminal-2.4.0.1-1 and vte-0.11.10-4
Comment 5 Joe Orton 2003-10-07 09:25:12 EDT
Moi aussi. Sometimes it takes more than two Ctrl-T's to get the black screen.

vte-0.11.10-4
gnome-terminal-2.4.0.1-1
Comment 6 Bart Martens 2004-02-16 17:06:27 EST
The problem is known upstream, see:
http://bugzilla.gnome.org/show_bug.cgi?id=125364
Comment 7 Bart Martens 2004-02-16 17:14:38 EST
I suggest to mark bug #110109 as a duplicate of *this* bug.
Comment 8 Alexandre Oliva 2004-02-16 18:42:05 EST
*** Bug 110109 has been marked as a duplicate of this bug. ***
Comment 9 Albert Strasheim 2004-04-07 10:33:42 EDT
The black background is displayed when opening the third, fourth, etc.
tab, but not for the first two

Closing all but the first tab and creating a new tab (i.e. a new
second tab) still gives a white background, but opening a third tab
again gives a black background.

Switching from a tab with a black background to another tab and back
again fixes the background (i.e. makes it white).

Comment 10 Warren Togami 2004-04-14 00:02:33 EDT
gnome-terminal-2.6.0-1
vte-0.11.10-5.1
seems to be fixed for me in latest rawhide with these versions.  Can
anyone else confirm?
Comment 11 Alexandre Oliva 2004-04-14 21:40:46 EDT
I still get it with yesterday's rawhide (>= than yours):
gnome-terminal-2.6.0-2
vte-0.11.10-5.1
Comment 12 Ray Strode [halfline] 2004-10-04 12:26:34 EDT
*** Bug 134466 has been marked as a duplicate of this bug. ***
Comment 13 Jon Nettleton 2004-10-27 15:30:16 EDT
Created attachment 105863 [details]
redraw vte screen when unobscured visibility event is caught
Comment 14 Jon Nettleton 2004-10-27 15:32:44 EDT
forgot to paste my comments sorry.

This issue seems to be caused by a race condition between the
visibility event and the configure-event.  The terminal knows it is
visible, and the vte_terminal_configure_toplevel callback is attached,
but the configure-event never happens.  My most elegant solution has
been to run vte_invalidate_all on the terminal when the visibility
event is caught and it's state is UNOBSCURED.
Comment 15 Panu Matilainen 2004-10-28 07:57:02 EDT
Patch seems to have the desired effect. Thanks Jon, this has been
bugging me too for quite a while...
Comment 16 Warren Togami 2004-10-31 23:36:54 EST
Please add this patch to vte too.
Comment 18 Ray Strode [halfline] 2004-11-04 22:47:26 EST
Patch added to rawhide.
Comment 19 Adrian 2005-03-07 10:54:38 EST
The bug is still in FedoraCore3, which provides vte-0.11.11-6. There
is no standard update (in "updates-released" repository) available for
yum. So, the usual update command:

  yum update

doesn't solve the bug.

The vte version available in the "development" repository
(vte-0.11.11-15) seems to solve the problem. I've installed it with:

  rpm --import /usr/share/rhn/RPM-GPG-KEY-fedora-test
  yum --enablerepo=development update vte

It would be useful to have the solution available in the
"updates-released" repository for an easier update. Any possibility to
be donne?

[In Gnome Bugzilla, Olav recommends to upgrade to vte 0.11.12:
http://bugzilla.gnome.org/show_bug.cgi?id=169207 ]
Comment 20 Zack Cerza 2006-08-21 16:33:21 EDT
Everyone's favorite bug is back again.

On the creation of the first tab, the terminal is all white (no prompt or
anything). On the creation of the second tab, the terminal is all black. Both
new tabs are unresponsive. Switching to a different tab and back again will
force an update, but it still does not respond interactively.

vte-0.13.5-1.fc6.x86_64
Comment 21 Warren Togami 2006-08-21 17:28:00 EDT
I don't see this problem with vte-0.13.6-1.fc6.i386.
Comment 22 Zack Cerza 2006-08-21 17:30:45 EDT
Are you on i386 or x86_64? Also, try turning on accessibility. It may just
happen more often if you do.
Comment 23 Warren Togami 2006-08-21 17:38:10 EDT
i386 here.  How do I turn on accessibility?
Comment 24 Zack Cerza 2006-08-21 17:47:11 EDT
You can turn on accessibility via this super-quick menu shortcut:

System->Preferences->Accessibility->Assistive Technology Support->Enable
assistive technologies

For me, the various incarnations of this bug have always occurred far more often
on x86_64 than on i386.
Comment 25 Warren Togami 2006-08-29 00:59:32 EDT
I'm seeing this on i386 FC6 without Accessibility enabled.  I am guessing this
has some timing basis as it doesn't always happen.
Comment 26 Kyrre Ness Sjøbæk 2007-05-30 11:25:28 EDT
Hmm.. I'm not seeng this on FC5, never has (or FC6). But i see it regularly on
RHEL (WS 4? i think so).
Comment 27 petrosyan 2007-12-17 13:22:41 EST
FC5 and FC6 are not supported anymore. Can anyone reproduce this bug on F7 or F8?
Comment 28 Kyrre Ness Sjøbæk 2007-12-18 09:39:24 EST
I have never seen it on newer FC, but I do think it does occur on RHEL, as
stated in #26. Somebody should probably test that (The RHEL I have access to is
an hour away from here (to acess the console of the machines directly, without
SSH), and it is quite heavily modified...)
Comment 29 petrosyan 2008-02-28 15:10:18 EST
reassigning to RHEL 4
Comment 30 Jiri Pallich 2012-06-20 12:13:59 EDT
Thank you for submitting this issue for consideration in Red Hat Enterprise Linux. The release for which you requested us to review is now End of Life. 
Please See https://access.redhat.com/support/policy/updates/errata/

If you would like Red Hat to re-consider your feature request for an active release, please re-open the request via appropriate support channels and provide additional supporting details about the importance of this issue.

Note You need to log in before you can comment on or make changes to this bug.