Bug 11019

Summary: RFE: Use edict koi8-r fonts instead of cronyx
Product: [Retired] Red Hat Linux Reporter: gdejager
Component: XFree86Assignee: Mike A. Harris <mharris>
Status: CLOSED WONTFIX QA Contact:
Severity: medium Docs Contact:
Priority: low    
Version: 6.2CC: aleksey, d.yu.bolkhovityanov, olleg
Target Milestone: ---Keywords: FutureFeature, MoveUpstream
Target Release: ---   
Hardware: noarch   
OS: Linux   
URL: http://bugs.xfree86.org/
Whiteboard:
Fixed In Version: Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2003-05-14 09:38:26 EDT Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Description gdejager 2000-04-24 13:59:36 EDT
It's not bug, only advace. Use edict koi8-r fonts instead of cronyx. Edict
font very much better.
Comment 1 Anonymous 2000-04-25 13:40:59 EDT
Yes, I strongly advice you to do so.
Comment 2 Mike A. Harris 2000-12-05 02:50:11 EST
Is this an addon available somewhere or part of the X distribution.
I am not familiar with other charsets.
Comment 4 Mike A. Harris 2001-02-12 01:58:12 EST
Ok, I will check this out sometime and perhaps add it.  Might not be right
away though, lots of critical stuff to do..
Comment 5 Mike A. Harris 2001-07-16 03:04:38 EDT
Deferred for future consideration.
Comment 6 Aleksey Nogin 2002-05-02 10:39:16 EDT
I am not familiar with edict fonts, but yes, if would be nice to have better
cyrillic fonts. Is it time yet for this bug to wake up from its "Deferred" status?
Comment 7 Mike A. Harris 2002-07-18 23:11:39 EDT
I don't have time to investigate this currently.  Please don't change
the state of bugs from DEFERRED, as it doesn't change the speed at
which things get looked at.  I go through deferred bugs and RFE's when
I have the time to spare to look at them, and then try to implement/fix
or resolve the issues when time permits.  Re-deferring something all the
time just wastes time.

I will investigate adding these fonts in the future, but doing so is
a very low priority compared to much more critical bug fixes and whatnot
that occurs during the development cycle.  In addition to this, the
fonts copyrights must be investigated as well to have a reasonable
belief that they are indeed free to redistribute, and not based on
non-redistributable fonts produced by commercial foundries.  Many
foreign fonts have turned up which violate commercial copyrights, so
fonts are an area where much consideration must be made.
Comment 8 Aleksey Nogin 2002-07-21 17:59:23 EDT
The links sent by olleg@faki-campus.mipt.ru seem to be outdated, here are some
fresh ones:

http://xtalk.msk.su/linux/edict.fonts.tar.gz
http://xtalk.msk.su/linux/edict.fonts-bdf.tar.gz

Another alternative cyrillic fonts package I bumped into (I have no idea if it's
any good):

http://www.inp.nsk.su/~bolkhov/files/fonts/cyr-rfx/00index.en.html
Comment 9 Dmitry Bolkhovityanov 2002-07-21 23:54:26 EDT
Dear sirs!

Since 7.0 RHL already includes CYR-RFX (with all russian/ukrainian/byelorussian
present) as fonts-KOI8-R*.rpm.  These are installed by default when one of above
mentioned languages selected, and are used in Anaconda. These fonts are
"cyrillized" versions of standard X fonts, so they are 100% compatible.  AFAIK,
Cronyx fonts aren't used at all, except by some old proggies which specifically
request "-cronyx-*".

Currently Leon Kantor have reached an agreement with Markus Kuhn (XFree86
bdf-fonts maintainer) that CYR-RFX fonts will be included into upcoming
XFree86-4.3's iso10646-1 fonts.

BTW, Mike: I've heard that a similar discussion is going in bug#68531, but I "do
not have the permissions necessary to see bug 68531".  May I ask for such a
permission?

Sincerely yours,
Dmitry Bolkhovityanov,
CYR-RFX author
Comment 10 Aleksey Nogin 2002-07-22 11:23:34 EDT
According to Boris Tobotras (boris "at" xtalk.kru.to) the author of the edict
font package is Edward Televinov from Tver. Edward gave Boris permissions for
unlimited distribution of the package, although Boris is not sure whether
somebody else (e.g. Adobe) has copyright on the "ASCII" section of the fonts.

I will try to contact Edward (BTW, a Russian nickname from "Edward" is "Edic"
and "edict" in the package name apparently comes from "Edic Televinov) and get
some additional information from him.
Comment 11 Aleksey Nogin 2002-07-25 21:25:01 EDT
Edward Televinov (edict at edictsoft.msk.ru) confirms that he is the creator of
the package and would be happy to see them included in Red Hat  distribution. As
I understood him (I've asked for clarifications) the initial fonts were created
by adding Cyrillics symbols to adobe iso-8859-1 fonts included in some version
of Solaris.
Comment 12 Aleksey Nogin 2003-05-14 07:51:10 EDT
Now that XFree86 has its own Bugzilla (http://bugs.xfree86.org/), this bug
should probably be filed there instead (if anybody still cares about it).
Comment 13 Mike A. Harris 2003-05-14 09:38:26 EDT
I agree.  Please feel free to file it upstream, if you would like the fonts
in XFree86 updated to these.  I'm closing this as WONTFIX for now, as I
don't intend on updating our own font packages with these.