Bug 68531 - Packages fonts-KOI8-R and xorg-x11-cyrillic-fonts overlap
Packages fonts-KOI8-R and xorg-x11-cyrillic-fonts overlap
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: fonts-KOI8-R (Show other bugs)
rawhide
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Mike A. Harris
:
Depends On:
Blocks: 67217
  Show dependency treegraph
 
Reported: 2002-07-10 19:30 EDT by Aleksey Nogin
Modified: 2007-11-30 17:10 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-09-04 18:31:18 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Aleksey Nogin 2002-07-10 19:30:45 EDT
It appears that packages fonts-KOI8-R* and XFree-86-cyrillic-fonts provide
somewhat different versions of exactly the same fonts. For example:

% grep cronyx-courier-medium-o-normal--14-100-100-100-m-80
/usr/share/fonts/KOI8-R/100dpi/fonts.* /usr/X11R6/lib/X11/fonts/cyrillic/fonts.*
/usr/share/fonts/KOI8-R/100dpi/fonts.alias:-cronyx-courier-medium-o-normal--14-100-100-100-m-80-koi8-r
-cronyx-courier-medium-o-normal--14-100-100-100-m-80-koi8-u
/usr/share/fonts/KOI8-R/100dpi/fonts.dir:crox1co.pcf.gz
-cronyx-courier-medium-o-normal--14-100-100-100-m-80-koi8-u
/usr/X11R6/lib/X11/fonts/cyrillic/fonts.dir:crox1co.pcf.gz
-cronyx-courier-medium-o-normal--14-100-100-100-m-80-koi8-r

% ls -l
{/usr/X11R6/lib/X11/fonts/cyrillic/,/usr/share/fonts/KOI8-R/100dpi/}crox1co.pcf.gz
-r--r--r--    1 root     root         3635 06-23 11:29
/usr/share/fonts/KOI8-R/100dpi/crox1co.pcf.gz
-r--r--r--    1 root     root         4778 06-25 15:13
/usr/X11R6/lib/X11/fonts/cyrillic/crox1co.pcf.gz

This wastes disk space and makes things more confusing than it has to be (and
font stuff is sufficiently confusing on its own).
Comment 1 Aleksey Nogin 2002-07-21 17:38:31 EDT
One possible fix may be to follow the bug 11019 RFE and switch to using edict
font package instead of cronyx in fonts-KOI8-R while keeping whatever XFree86
comes with in XFree-86-cyrillic-fonts.
Comment 2 Aleksey Nogin 2002-07-22 11:04:48 EDT
Some other duplicates:

/usr/X11R6/lib/X11/fonts/misc/6x13-KOI8-R.pcf.gz from XFree86-base-fonts is 
-misc-fixed-medium-r-semicondensed--13-120-75-75-c-60-koi8-r

At the same time
/usr/share/fonts/KOI8-R/misc/6x13s.pcf.gz from fonts-KOI8-R is
-misc-fixed-medium-r-semicondensed--13-120-75-75-c-60-koi8-ub and is aliased to
the same
-misc-fixed-medium-r-semicondensed--13-120-75-75-c-60-koi8-r

Meanwhile, the files appear to be different...
Comment 3 Ngo Than 2002-07-24 05:57:10 EDT
Mikes, we should remove the duplicate fonts. Should i remove it in fonts-KOI8-R?
Comment 4 Mike A. Harris 2002-07-24 08:30:31 EDT
If they are indeed identical duplicates, yes.   The XFree86 supplied fonts
are considered the baseline.

Also, if some other font package out there contains fonts which are updated
versions of those supplied in XFree86, the new fonts should be submitted
back to the XFree86 project.  In general, I wont update fonts inside
XFree86 until those fonts are integrated into XFree86 upstream, as it makes
package maintenance a big mess.  I also am quite skeptical about killing
fonts that come with XFree86 and replacing them with some other fonts.
Same reason - if they are open/free fonts, and are legal, they should be
submitted to XFree86.org for the font experts there to determine what the
best thing to do is.

Hope this helps.
Comment 5 Leonid Kanter 2002-07-24 10:49:34 EDT
cronyx fonts from XFree do not have Ukrainian characters, the same fonts from
fonts-KOI8-R-100dpi have - that's the difference. please do not remove
fonts-KOI8-R because it will kill Ukrainian.

There is drop-in replacement for XFree86 bdf fonts (75dpi only) with cyrillic
glyphs from cyr_rfx added (package is on ftp://ftp.asplinux.ru/pub/fonts). I
explained the problem of cyrillic fonts to Marcus Kuhn and he promiced to use
them in next XFree release.

...
Leon Kanter wrote on 2002-01-26 12:22 UTC:
> ftp://ftp.asplinux.ru/pub/fonts/XFree86-iso10646cyr-fonts.tar.bz2

Thanks! I have recently received a lot of suggestions to extend the
ISO10646-1 fonts with cyrillic glyphs, and I'll look into that in a few
weeks. I'll have a look at your fonts as well then.

Markus

next message from Marcus:

From: Markus Kuhn <Markus.Kuhn@cl.cam.ac.uk>
To: Leon Kanter <leon@blackcatlinux.com>
Date: Sat, 26 Jan 2002 19:57:54 +0000

Thanks, that sounds very promising indeed. I expect that the next
XFree86 release will come out on around 3-4 months and I'll submit a new
version of the ucs-fonts to the XFree86 CVS tree before that.

Markus

-- 
Markus G. Kuhn, Computer Laboratory, University of Cambridge, UK
Email: mkuhn at acm.org,  WWW: <http://www.cl.cam.ac.uk/~mgk25/>

Comment 6 Ngo Than 2002-07-25 18:12:05 EDT
i assigned it to XFree86.
Comment 7 Mike A. Harris 2002-08-05 20:28:17 EDT
Since we have now released 2 public betas, and since font related problems
are generally very problematic, it is too late at this point in time to
make any large changes like this to the distribution at this time.

It appears from above that XFree86.org has been notified of the new
fonts, and plans on adding them to XFree86 4.3.0 in the future.  As such,
we will be better off waiting for upstream to make these changes, and then
dropping any extra and unnecessary font packages or font files which
we are currently now shipping.

This is then something which we will have ample time to test properly
and work out any bugs that are reported and get things into public
beta's for proper testing.

I'm defering this issue for our next release after XFree86 is integrated
into the distribution.

Once 4.3.0 is out, please feel free to REOPEN this deferred bug, so it
can be managed with plenty of testing time.
Comment 8 Mike A. Harris 2002-11-03 05:15:19 EST
I'm assuming that XFree86.org will include the updated fonts in 4.3.0.
If it hasn't been done already (I haven't checked), I expect that those
who are concerned about these fonts will bring the issue up with XFree86.org
again and prod them to ensure the fonts are present in 4.3.0.  Now might
be a good time for one of you to contact XFree86.org to ensure they update
the fonts if they haven't already.  Our XFree86 packaging will contain
whatever fonts XFree86.org ships, so if they don't update them, we'll either
not ship them, or someone here at Red Hat will have to create separate
font packages for them.
Comment 9 Mike A. Harris 2002-11-03 05:18:51 EST
Closing WONTFIX, as this isn't something that will be manually added to
our XFree86 packaging.  It'll either get included when XFree86.org adds
them, or it'll get included when someone adds a separate package for these
fonts as mentioned above.
Comment 10 Aleksey Nogin 2002-11-03 05:31:34 EST
> Closing WONTFIX, as this isn't something that will be manually added to
> our XFree86 packaging.

The original report was not about *adding*, it was about *removing* (or
otherwise resolving) the duplicates that are *already* added in the fonts-KOI8-R
package.
Comment 11 Mike A. Harris 2002-11-03 05:44:15 EST
That's fine.  My point, is that I'm not going to randomly remove fonts
from XFree86 packaging, and then add them back one release later.  If
people want their fonts updated properly, then the maintainers of those
fonts will go out of their way to make sure XFree86.org has updated
copies of those fonts.  Otherwise it is a package maintainers nightmare.
If nobody cares to keep the fonts updated upstream, then I don't care
either.  The work has to be done at the correct level, and that is
at XFree86.org.

I hope I've made this quite clear now.  Time to go knock on the door
of the font authors, and XFree86.org if you want these changes made.
Comment 12 Aleksey Nogin 2003-01-05 01:59:14 EST
The packages fonts-KOI8-R-1.0-4 and XFree86-cyrillic-fonts-4.2.99.2-0.20021217.0
still intersect. 

You seem to have misunderstood my comment #10. I am not advocating dropping
things from XFree86. This is really about fonts-KOI8-R including fonts with the
same names as those that already exist in XFree86. As you said yourself in
comment #4, if the fonts-KOI8-R fonts are better and the XFree86 ones ought to
be replaced, this should be happening upstream. Otherwise we get a mess.
Comment 13 Mike A. Harris 2003-05-14 07:30:29 EDT
Sure, by all means, feel free to file a bug report upstream at
http://bugs.xfree86.org and let them know where they can obtain the updated
fonts for inclusion in a future XFree86 release.

The only thing I'm willing to do here, is remove font files from the
fonts-KOI8-R package which are identical to ones in XFree86, or which
cause a conflict.  I will not remove fonts or files from XFree86 packages
as it just makes maintaining these font packages a huge mess.

There ultimately should be one source of these fonts, if that is XFree86,
then we should not be shipping other fonts that are identically named but
different, and I don't mind removing them from this package.
Comment 14 Aleksey Nogin 2004-04-07 23:38:37 EDT
I see that in Raw Hide fonts-KOI8-R provides only koi8-ub fonts, while
xorg-x11-cyrillic-fonts only provides koi8-r fonts. This is still
weird (among other things, it's bad that a package named fonts-KOI8-R
provides koi8-ub, but _not_ koi8-r ones), but may be not as bad.

Anyway, I was just hoping that this could be finally solved in some
reasonable manner in the new xorg world.
Comment 15 Mike A. Harris 2004-09-01 13:10:58 EDT
Hi Aleskey,

Can you suggest a suitable solution for consideration?  I'd like
to resolve this issue for FC3 if we can come up with an amiable
solution.

Thanks in advance.
Comment 16 Aleksey Nogin 2004-09-01 16:49:25 EDT
I do not really know the difference between all these fonts and their
state in xorg (Leonid, can you comment, please?). I am just saying -
_if_ the fonts-KOI8-R package provides better koi fonts (again, all I
know about the difference is comment #5), then these better fonts
ought to be a part of the xorg...
Comment 17 Leonid Kanter 2004-09-02 13:17:11 EDT
xorg build system generates most 8bit fonts from 10641 at build time.
If xorg includes Cyrillic glyphs in iso10641-1 then no stand along
Cyrillic fonts are needed. if you like to resolve this issue you
should include my cyrillic in 10641 and adjust build system. 
Comment 18 Dmitry Bolkhovityanov 2004-09-03 02:51:30 EDT
Well, as an author of CYR-RFX (cyrillics in fonts-KOI8-R/75dpi) and
the inventor of koi8-ub encoding, hope I can be of some help...

So, pure facts:

I. Regarding fonts' presence:

- XFree86 does NOT include anything but old ugly Cronyx fonts.

- X.org fonts are the same as XFree86's ones -- Cronyx only.

- In both cases 8-bit fonts are generated from iso10646-1 fonts
(8859-1 are pre-generated and files have "-L1" suffix).

- So, adding cyrillics directly to appropriate 10646-1 fonts in
X.org/XFree86 will be 100% sufficient.

- Several attempts were made to persuade XFree86 people to include
cyrillics (see comment #5), but nothing have happened -- probably, due
to legal uncertainty.  (Distributing those cyrillics as "CYR-RFX" *is*
legal (I contacted Chuck Bigelow, copyright holder of Lucida, and he
said it is okay as long as I don't use "B&H" name; and everything is
clear with Adobe-based fonts), but adding glyphs directly is
questionable...)

II. Regarding encodings:

- koi8-ub (Ukrainian+Byelorussian) encoding was invented to be a
variant of koi8-1 with ukrainian and byelorussian letters added.

- koi8-1, mentioned above, is a "clever" mix of koi8-r (letters, which
are ONLY characters really used in koi8-r), iso8859 (various
characters mainly in 0xA0-0xBF) and windows-1251 (punctuation in C1
range -- 0x80-0x9F).  Thus, pseudographics from koi8-r was replaced
with much more useful (and used) things in koi8-1/ub.

- so, koi8-ub is the most useful 8-bit encoding for russian, ukrainian
and byelorussian in Unix.

III. Regarding fonts and glyphs:

- Cronyx fonts (bdf/cyrillic) are used EXTREMELY rare, so in fact
almost nobody cares about their variants.

- Both 75dpi/ and misc/ fonts in KOI8-R package DO contain all
required russian/ukrainian/byelorussian glyphs (but not 100dpi, shame
on me...).

P.S. I'm afraid I presented too much info -- enough to make the
problem completely confusing :-)
Comment 19 Dmitry Bolkhovityanov 2004-09-03 03:07:56 EDT
P.S. Mike, may I ask for permission to view bug #67217, which is
blocked by this one?
Comment 20 Aleksey Nogin 2004-09-03 03:59:20 EDT
Dmitry, thanks a lot for your "pure facts". Do you have a suggestion
of what would be the best way to get rid of the unnecessary
duplication? Thank you!
Comment 21 Dmitry Bolkhovityanov 2004-09-03 05:35:10 EDT
The best way is to integrate all necessary fonts into XFree86/X.org
packages.  This includes:

- Replacing files in xc/fonts/bdf/cyrillic/ with ones from KOI8-R
package (Leonid, am I right?  AFAIR, KOI8-R/100dpi/ are "ukrainified"
and "byelorussified" files from cyrillic/, correct?).

- Adding cyrillics (plus "numero" sign) from KOI8-R/75dpi/ to
xc/fonts/bdf/75dpi/ 10646-1 fonts.

- misc/ files present a more interesting question: their cyrillic
glyphs are COMPLETELY different.  XFree86/X.org fonts contain [a bit
ugly] glyphs from appropriate Cronyx fonts, while KOI8-R includes my
versions, specifically designed to be compatible with their
"receiving" fonts.

So, unfortunately, it is NOT possible to just remove KOI8-R package --
it contains more up-to-date fonts. The "simple" way is to leave
everything as it is now.  The right way -- is to put fonts from KOI8-R
package into official xc/fonts/bdf/.

The latter is technicaly simple, albeit boring task.

Mike, are you aware, who is "official fonts maintainer" in X.org
repository?  It seems to be the best solution to contact him and to
eliminate the very roots of the problem.
Comment 22 Leonid Kanter 2004-09-03 06:00:00 EDT
I think the best way is to add cyrillic glyphs from cyr-rfx to ucs
fonts (xc/fonts/bdf/75dpi/). 8-bit encodings are not supported by Red
Hat for a long time and I'm not sure that anybody needs koi8-r fonts.
But if yes it's possible to generate 8-bit fonts (koi8-r, koi8-u etc)
from ucs fonts by the same script that produses 8859-1, 8859-2 etc.

As for KOI8-R/100dpi/, I don't like them because they are based on
Cronyx and they are not compatible in metrics with other 100dpi fonts
(Adobe etc.)

As for me, I'm ready to spent some time and help to carefully add
cyrillic glyphs to existing x.org fonts.
Comment 23 Mike A. Harris 2004-09-04 18:31:18 EDT
After re-reading all comments since this was filed, including and
in particular Dimitry's comments, I think it is quite clear now
that this isn't a Red Hat specific problem with which fonts we
include/exclude, but rather a problem with the fonts as a whole,
both the ones included in X.Org and XFree86, as well as the
other KOI8 font packages also, with there currently being no
"correct" _existing_ solution to the problem that we could go with.


> So, unfortunately, it is NOT possible to just remove KOI8-R package
> it contains more up-to-date fonts. The "simple" way is to leave
> everything as it is now.

This is the exact dilemna that I am faced with when reviewing a 
bug report such as this.  The problem being that removing either
package someone claims is conflicting, causes someone else to
be inconvenienced.  Removing the opposite package causes the same
in reverse.  This is compounded by the fact none of the fonts
are under open source licenses, which ultimately means any problem
with the fonts must be resolved by the copyright owners of the
problematic fonts.  We don't have the legal right to modify and
redistribute the fonts, and do not have fontographers on staff if
the fonts were under open source licenses (which they're not).


>Mike, are you aware, who is "official fonts maintainer" in X.org
>repository?  It seems to be the best solution to contact him and to
>eliminate the very roots of the problem.

I'm not sure if there is anyone at all with the title "official
fonts maintainer" in X.Org or not per se.  I would suggest that
using the xorg@freedesktop.org mailing list would be an
appropriate way to discuss this problem and potential future
resolutions.  It'd be a good idea to put a bug tracker in X.Org
bugzilla as well, so the issue will receive attention by upstream
(whatever attention that may be however, I can't speculate).

We consider this entirely to be an external issue at this point,
and hope that it can be resolved by the font's copyright owners
working in conjunction with the affected parties, to ensure that
an amiable solution is made available to X.Org in a future release
of X.Org X11, or alternatively as a separately available set of fonts
which replace both the X.Org included fonts, and the KOI8-R font
package.  Until such external resolve has occured however, there
is nothing we can do about this problem other than removing the
problematic fonts entirely, which would seem to cause more problems
for everyone than to leave them present in the OS.

As such, I'm setting the status of this issue to "WONTFIX" pending
an official solution from upstream (X.Org or the copyright owners),
at which time we may re-review the issue.  In the mean time,
if you file an upstream X.Org bug report to track this issue, and
paste the URL of the upstream report here, we will review it from
time to time to see how things are progressing.

Setting bug status to "WONTFIX"
Comment 24 Dmitry Bolkhovityanov 2004-09-05 02:53:15 EDT
Just a little comment:

> This is compounded by the fact none of the fonts are under
> open source licenses, which ultimately means any problem with
> the fonts must be resolved by the copyright owners of the
> problematic fonts.  We don't have the legal right to modify 
> and redistribute the fonts, and do not have fontographers on
> staff if the fonts were under open source licenses (which
> they're not).

While I can't authoritatively speak about X.org/XFree86 fonts'
licenses, all fonts in KOI8-R package are open-source.

Cronyx fonts (after serious modifications they should be probably
called ex-Cronyx) are in public domain. And for CYR-RFX fonts I chose
the X license (and can change it to anything-we-need anyway).

And regarding fontographers: Leonid has already expressed his ability
to help, and I'm also ready to help in case of any problems/questions.
Comment 25 Dmitry Bolkhovityanov 2004-09-17 01:44:51 EDT
I've just filed this bug to X.org bugzilla --
https://freedesktop.org/bugzilla/show_bug.cgi?id=1401

Please correct me if I forgot anything.
Comment 26 Dmitry Bolkhovityanov 2004-09-22 02:22:57 EDT
Since there was no response to bugreport#1401 from X.org people yet, I
wrote a short message to xorg@freedesktop.org --
http://freedesktop.org/pipermail/xorg/2004-September/003389.html
Comment 27 Dmitry Bolkhovityanov 2004-12-07 02:23:21 EST
Just a note: while FC3 contains both packages, when "Russian" is
requested, it forgets to install both -- see bug #142085

Strange, strange behaviour...

Mike, I hope this anomaly wasn't caused by uncertainties of this bug? :-)

Note You need to log in before you can comment on or make changes to this bug.