Bug 1108103

Summary: FTBFS: several unit tests fail on ppc64
Product: [Fedora] Fedora Reporter: Karsten Hopp <karsten>
Component: openbabelAssignee: Dominik 'Rathann' Mierzejewski <dominik>
Status: CLOSED ERRATA QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: high Docs Contact:
Priority: medium    
Version: rawhideCC: dominik, itamar, mjuszkie, normand, paul, susi.lehtola
Target Milestone: ---   
Target Release: ---   
Hardware: ppc64   
OS: Linux   
Whiteboard:
Fixed In Version: openbabel-2.3.2-11.fc21 Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2015-02-23 08:03:29 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
Bug Depends On:    
Bug Blocks: 1071880    
Attachments:
Description Flags
patch + spec changeset none

Description Karsten Hopp 2014-06-11 12:55:34 UTC
Description of problem:
10/60 Test #10: rotor_Test .......................***Failed  Error regular expression found in output. Regex=[FAIL]  0.10 sec
/builddir/build/BUILD/openbabel-2.3.2/test/rotortest.cpp:123: IsNear(RAD_TO_DEG * rotor.CalcTorsion(mol->GetCoordinates()), 180.0, 1.0) (FAIL)


      Start 23: inchiSteffen_PubChem.smi_Test
23/60 Test #23: inchiSteffen_PubChem.smi_Test ....***Timeout 1500.01 sec
==============================
*** Open Babel Warning  in InChI code
  #8 :Salt was disconnected;
==============================
*** Open Babel Warning  in InChI code
  #30 :Salt was disconnected;

      Start 54: pytest_sym
54/60 Test #54: pytest_sym .......................***Timeout 1500.03 sec
/builddir/build/BUILD/openbabel-2.3.2/scripts/python:/builddir/build/BUILD/openbabel-2.3.2/lib64

95% tests passed, 3 tests failed out of 60
Total Test time (real) = 3065.64 sec
The following tests FAILED:
	 10 - rotor_Test (Failed)
	 23 - inchiSteffen_PubChem.smi_Test (Timeout)
	 54 - pytest_sym (Timeout)
Errors while running CTest
make: *** [test] Error 8

Version-Release number of selected component (if applicable):
openbabel-2.3.2-4.fc21

How reproducible:
always

Steps to Reproduce:
1. ppc-koji build --scratch f21 openbabel-2.3.2-4.fc21.src.rpm
2.
3.

Actual results:
http://ppc.koji.fedoraproject.org/koji/taskinfo?taskID=1883226

Expected results:


Additional info:

Comment 1 Michel Normand 2014-08-27 11:37:23 UTC
this bug 1108103  (on rawhide) seems to be a duplicate of 1094513 (epel7)
I do not know if we really want to set as duplicate.

Comment 2 Karsten Hopp 2014-09-11 13:48:05 UTC
rotor_test fails with
/builddir/build/BUILD/openbabel-2.3.2/test/rotortest.cpp:126: IsNear(RAD_TO_DEG * rotor.CalcTorsion(mol->GetCoordinates()), 180.0, 1.0) (FAIL)

RAD_TO_DEG * rotor.CalcTorsion(mol->GetCoordinates())  is -179.974 on ppc64 which hints at a sign error somewhere.

Comment 3 Susi Lehtola 2014-09-11 18:28:54 UTC
To me it just looks like the test is broken. -179.974 degrees is equivalent to 180.026 degrees, which is within the given tolerance (which is presumably 1.0 degrees).

Comment 4 Susi Lehtola 2014-09-11 18:47:14 UTC
Filed https://sourceforge.net/p/openbabel/bugs/945/

Comment 5 Marcin Juszkiewicz 2015-01-27 09:28:09 UTC
https://sourceforge.net/p/openbabel/bugs/927/ was filed for AArch64

#1094513 is same bug

Comment 6 Marcin Juszkiewicz 2015-01-27 10:12:50 UTC
Created attachment 984583 [details]
patch + spec changeset

This patch merges arm and ppc64/s390 patches which disable failing tests and then enables it also for aarch64.

Comment 7 Dominik 'Rathann' Mierzejewski 2015-01-27 14:28:56 UTC
Thanks, Marcin. Fix applied to rawhide and built.

Comment 8 Fedora Update System 2015-02-05 08:44:19 UTC
openbabel-2.3.2-11.fc21 has been submitted as an update for Fedora 21.
https://admin.fedoraproject.org/updates/openbabel-2.3.2-11.fc21

Comment 9 Fedora Update System 2015-02-06 04:00:54 UTC
Package openbabel-2.3.2-11.fc21:
* should fix your issue,
* was pushed to the Fedora 21 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing openbabel-2.3.2-11.fc21'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2015-1735/openbabel-2.3.2-11.fc21
then log in and leave karma (feedback).

Comment 10 Fedora Update System 2015-02-23 08:03:29 UTC
openbabel-2.3.2-11.fc21 has been pushed to the Fedora 21 stable repository.  If problems still persist, please make note of it in this bug report.