Bug 1109925

Summary: Live Merge: Expose capability in getVdsCaps API
Product: [Retired] oVirt Reporter: Adam Litke <alitke>
Component: vdsmAssignee: Adam Litke <alitke>
Status: CLOSED CURRENTRELEASE QA Contact: Kevin Alon Goldblatt <kgoldbla>
Severity: high Docs Contact:
Priority: unspecified    
Version: 3.5CC: acanan, alitke, amureini, bazulay, bugs, fsimonce, gklein, iheim, mgoldboi, rbalakri, scohen, yeylon
Target Milestone: ---   
Target Release: 3.5.0   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard: storage
Fixed In Version: ovirt-engine-3.5.0_beta1 Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2014-10-17 12:31:20 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: Storage RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Bug Depends On:    
Bug Blocks: 1124099    

Description Adam Litke 2014-06-16 15:53:28 UTC
oVirt engine would like to know whether the Live Merge feature is supported by a particular host so that it can decide whether to offer the option to users in the GUI.  Add a capability flag to the getVdsCaps API which, when present, will communicate the presence of the feature.

Comment 1 Adam Litke 2014-06-16 18:18:56 UTC
implementation in progress

Comment 2 Allon Mureinik 2014-07-17 06:53:45 UTC
Adam, can this be moved to ON_QA, or are we waiting for a corresponding engine patch?

Comment 3 Adam Litke 2014-07-17 13:11:19 UTC
Still waiting on the patch from Greg to be merged on the engine side.

Comment 4 Allon Mureinik 2014-07-29 05:48:02 UTC
Since we're tracking the engine patch on bug 1124099, lets move forward with this to allow early engagement in the QA.

Adam - can you please add some info for the QA on how to test this using vdsClinet's getCaps?

Comment 5 Adam Litke 2014-07-29 12:52:04 UTC
Steps to verify this in vdsm:

1. On stock Fedora 20 system, install the vdsm you would like to test
2. On the host execute: vdsClient 0 getVdsCaps | grep liveMerge
3. Today on stock Fedora 20 you will see:
   liveMerge = 'false'
4. Download the following files into an empty directory on your vdsm host
   http://files.pipo.sk/qemu+libvirt-gluster-block-jobs-v6.tar
   http://files.pipo.sk/libvirt-python-fixed.tar
5. Extract qemu+libvirt-gluster-block-jobs-v6.tar
6. Extract libvirt-python-fixed.tar (This file will overwrite a few rpms from the first tarball)
7. Install all extracted RPMs: yum upgrade *.rpm
8. Restart libvirt: service libvirtd restart
9. Restart vdsm: service vdsmd restart
10. vdsClient 0 getVdsCaps | grep liveMerge
11. Verify that you see:
    liveMerge = 'true'

Comment 6 Sandro Bonazzola 2014-10-17 12:31:20 UTC
oVirt 3.5 has been released and should include the fix for this issue.