Bug 1111569

Summary: make "Transaction couldn't start (no root?)" error more clear
Product: [Fedora] Fedora Reporter: Matthew Miller <mattdm>
Component: dnfAssignee: Packaging Maintenance Team <packaging-team-maint>
Status: CLOSED ERRATA QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: unspecified Docs Contact:
Priority: unspecified    
Version: rawhideCC: akozumpl, mattdm, packaging-team-maint, pnemade, rholy, tla
Target Milestone: ---   
Target Release: ---   
Hardware: Unspecified   
OS: Unspecified   
Fixed In Version: dnf-plugins-core-0.1.1-2.fc20 Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2014-07-09 02:29:56 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
Description Flags
dnf output showing problem none

Description Matthew Miller 2014-06-20 11:45:44 UTC
Created attachment 910763 [details]
dnf output showing problem

I initially thought this was a repo problem that DNF wasn't responding to helpfully:

With yum:


---> Package texlive-kpathsea-lib.x86_64 3:2013-12.20140512_r33995.fc21 will be updated
--> Processing Dependency: texlive-kpathsea-lib = 3:2013-12.20140512_r33995.fc21 for package: 3:texlive-kpathsea-bin-svn30088.0-12.20140512_r33995.fc21.x86_64
---> Package texlive-kpathsea-lib.x86_64 3:2014-0.1.20140525_r34255.fc21 will be an update


Error: Package: 3:texlive-kpathsea-bin-svn30088.0-12.20140512_r33995.fc21.x86_64 (@rawhide)
           Requires: texlive-kpathsea-lib = 3:2013-12.20140512_r33995.fc21
           Removing: 3:texlive-kpathsea-lib-2013-12.20140512_r33995.fc21.x86_64 (@rawhide)
               texlive-kpathsea-lib = 3:2013-12.20140512_r33995.fc21
           Updated By: 3:texlive-kpathsea-lib-2014-0.1.20140525_r34255.fc21.x86_64 (rawhide)
               texlive-kpathsea-lib = 3:2014-0.1.20140525_r34255.fc21
 You could try using --skip-broken to work around the problem
 You could try running: rpm -Va --nofiles --nodigest


But with DNF:


Running transaction check
Transaction check succeeded.
Running transaction test
Transaction test succeeded.
Running transaction
Transaction couldn't start (no root?)
Error: Could not run transaction.


(See full output in attachment)

But then I removed texlive-kpathsea-lib and dependencies, dnf still gives the same error. So, I did it with yum and everything was fine.


$ rpm -q dnf hawkey

Comment 1 Ales Kozumplik 2014-06-23 09:13:13 UTC
Matthew, it looks like you ran dnf under a regular user, without the noroot plugin (from dnf-core-plugins) installed. Is that the case?

Comment 2 Matthew Miller 2014-06-23 13:58:51 UTC
I'm pretty sure I ran it from my user account via sudo. 

In testing, the error sure does seem consistent with what would happen if I had forgotten the sudo. I don't *think* I'm that absent-minded, but I guess I'm getting older and that must be it.

Does "Transaction couldn't start (no root?)" mean "not running as root"? That didn't even occur to me, as it seems to be saying that the _transaction_ has no root, whatever that might be. (An unfortunate effect of "root" having multiple meanings.)

How about "Transaction couldn't start (required root privileges not available)" or something?

It would also be nice to have the error _before_ the packages are all downloaded.

Comment 3 Ales Kozumplik 2014-06-24 07:40:15 UTC
Improved the error message in 963bbe6, it is now going to say:

Failed to obtain the transaction lock (logged in as: akozumpl).

The 'noroot' plugin does exactly what you suggest, i.e. it stops DNF before any download happens and explains it nicely. 'dnf install dnf-plugins-core' should get you set.

Comment 4 Ales Kozumplik 2014-06-24 07:42:00 UTC
Also see the related discussion at bug 910133.

Comment 5 Fedora Update System 2014-07-07 09:11:43 UTC
dnf-plugins-core-0.1.1-2.fc20, dnf-0.5.3-1.fc20, hawkey-0.4.17-1.fc20 has been submitted as an update for Fedora 20.

Comment 6 Fedora Update System 2014-07-08 01:04:02 UTC
Package dnf-plugins-core-0.1.1-2.fc20, dnf-0.5.3-1.fc20, hawkey-0.4.17-1.fc20:
* should fix your issue,
* was pushed to the Fedora 20 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing dnf-plugins-core-0.1.1-2.fc20 dnf-0.5.3-1.fc20 hawkey-0.4.17-1.fc20'
as soon as you are able to.
Please go to the following url:
then log in and leave karma (feedback).

Comment 7 Fedora Update System 2014-07-09 02:29:56 UTC
dnf-plugins-core-0.1.1-2.fc20, dnf-0.5.3-1.fc20, hawkey-0.4.17-1.fc20 has been pushed to the Fedora 20 stable repository.  If problems still persist, please make note of it in this bug report.