Bug 1111569 - make "Transaction couldn't start (no root?)" error more clear
make "Transaction couldn't start (no root?)" error more clear
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: dnf (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: packaging-team-maint
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2014-06-20 07:45 EDT by Matthew Miller
Modified: 2014-07-08 22:29 EDT (History)
6 users (show)

See Also:
Fixed In Version: dnf-plugins-core-0.1.1-2.fc20
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-07-08 22:29:56 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
dnf output showing problem (7.44 KB, text/plain)
2014-06-20 07:45 EDT, Matthew Miller
no flags Details

  None (edit)
Description Matthew Miller 2014-06-20 07:45:44 EDT
Created attachment 910763 [details]
dnf output showing problem

I initially thought this was a repo problem that DNF wasn't responding to helpfully:

With yum:

----

---> Package texlive-kpathsea-lib.x86_64 3:2013-12.20140512_r33995.fc21 will be updated
--> Processing Dependency: texlive-kpathsea-lib = 3:2013-12.20140512_r33995.fc21 for package: 3:texlive-kpathsea-bin-svn30088.0-12.20140512_r33995.fc21.x86_64
---> Package texlive-kpathsea-lib.x86_64 3:2014-0.1.20140525_r34255.fc21 will be an update

...

Error: Package: 3:texlive-kpathsea-bin-svn30088.0-12.20140512_r33995.fc21.x86_64 (@rawhide)
           Requires: texlive-kpathsea-lib = 3:2013-12.20140512_r33995.fc21
           Removing: 3:texlive-kpathsea-lib-2013-12.20140512_r33995.fc21.x86_64 (@rawhide)
               texlive-kpathsea-lib = 3:2013-12.20140512_r33995.fc21
           Updated By: 3:texlive-kpathsea-lib-2014-0.1.20140525_r34255.fc21.x86_64 (rawhide)
               texlive-kpathsea-lib = 3:2014-0.1.20140525_r34255.fc21
 You could try using --skip-broken to work around the problem
 You could try running: rpm -Va --nofiles --nodigest

----

But with DNF:

----

Running transaction check
Transaction check succeeded.
Running transaction test
Transaction test succeeded.
Running transaction
Transaction couldn't start (no root?)
Error: Could not run transaction.

----

(See full output in attachment)

But then I removed texlive-kpathsea-lib and dependencies, dnf still gives the same error. So, I did it with yum and everything was fine.

----

$ rpm -q dnf hawkey
dnf-0.5.2-2.fc21.noarch
hawkey-0.4.16-2.fc21.x86_64
Comment 1 Ales Kozumplik 2014-06-23 05:13:13 EDT
Matthew, it looks like you ran dnf under a regular user, without the noroot plugin (from dnf-core-plugins) installed. Is that the case?
Comment 2 Matthew Miller 2014-06-23 09:58:51 EDT
I'm pretty sure I ran it from my user account via sudo. 

In testing, the error sure does seem consistent with what would happen if I had forgotten the sudo. I don't *think* I'm that absent-minded, but I guess I'm getting older and that must be it.

Does "Transaction couldn't start (no root?)" mean "not running as root"? That didn't even occur to me, as it seems to be saying that the _transaction_ has no root, whatever that might be. (An unfortunate effect of "root" having multiple meanings.)

How about "Transaction couldn't start (required root privileges not available)" or something?

It would also be nice to have the error _before_ the packages are all downloaded.
Comment 3 Ales Kozumplik 2014-06-24 03:40:15 EDT
Improved the error message in 963bbe6, it is now going to say:

Failed to obtain the transaction lock (logged in as: akozumpl).

The 'noroot' plugin does exactly what you suggest, i.e. it stops DNF before any download happens and explains it nicely. 'dnf install dnf-plugins-core' should get you set.
Comment 4 Ales Kozumplik 2014-06-24 03:42:00 EDT
Also see the related discussion at bug 910133.
Comment 5 Fedora Update System 2014-07-07 05:11:43 EDT
dnf-plugins-core-0.1.1-2.fc20, dnf-0.5.3-1.fc20, hawkey-0.4.17-1.fc20 has been submitted as an update for Fedora 20.
https://admin.fedoraproject.org/updates/dnf-0.5.3-1.fc20,hawkey-0.4.17-1.fc20,dnf-plugins-core-0.1.1-2.fc20
Comment 6 Fedora Update System 2014-07-07 21:04:02 EDT
Package dnf-plugins-core-0.1.1-2.fc20, dnf-0.5.3-1.fc20, hawkey-0.4.17-1.fc20:
* should fix your issue,
* was pushed to the Fedora 20 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing dnf-plugins-core-0.1.1-2.fc20 dnf-0.5.3-1.fc20 hawkey-0.4.17-1.fc20'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2014-8167/dnf-0.5.3-1.fc20,hawkey-0.4.17-1.fc20,dnf-plugins-core-0.1.1-2.fc20
then log in and leave karma (feedback).
Comment 7 Fedora Update System 2014-07-08 22:29:56 EDT
dnf-plugins-core-0.1.1-2.fc20, dnf-0.5.3-1.fc20, hawkey-0.4.17-1.fc20 has been pushed to the Fedora 20 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.