Bug 1117489

Summary: [RFE] Implement Image Metadata to complete final steps of Template Versions/Instance Types functionality
Product: Red Hat Enterprise Virtualization Manager Reporter: Scott Herold <sherold>
Component: RFEsAssignee: Tomas Jelinek <tjelinek>
Status: CLOSED ERRATA QA Contact: Elad <ebenahar>
Severity: medium Docs Contact:
Priority: high    
Version: 3.5.0CC: aburden, acanan, gklein, iheim, istein, lpeer, michal.skrivanek, rbalakri, tnisan, yeylon
Target Milestone: ovirt-3.6.0-rcKeywords: FutureFeature
Target Release: 3.6.0Flags: sherold: Triaged+
Hardware: Unspecified   
OS: Unspecified   
URL: http://www.ovirt.org/Features/Instance_Types
Whiteboard:
Fixed In Version: ovirt-3-6-0-2 Doc Type: Enhancement
Doc Text:
Previously, creating a new virtual machine would open the 'Guide Me' window, which offered a link to 'Configure Virtual Disks'. Now, this functionality is integrated in the 'New Virtual Machine' and 'Edit Virtual Machine' windows, and the 'Guide Me' window no longer opens in a virtual machine context.
Story Points: ---
Clone Of: Environment:
Last Closed: 2016-03-09 20:35:10 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: Virt RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Bug Depends On: 1106370, 1200736, 1200741    
Bug Blocks: 1117478, 1302691    

Description Scott Herold 2014-07-08 19:25:49 UTC
Finalize implementation of Instance Types by implementing image metadata for configuration settings of the VM surrounding the virtual disk image ie. Display Protocol, HA Settings, Number of Monitors, etc.  This is information that exists in the current construct of a Template, but currently does not exist within the constructs of a Template Version or Instance Type.

Comment 1 Tomas Jelinek 2015-03-11 10:06:41 UTC
ok, I was too excited to close this BZ - opening it again and adding new BZs on which this depends.

Comment 2 Michal Skrivanek 2015-05-27 08:11:54 UTC
ok, finally decided to track that separately within storage team

Comment 3 Tomas Jelinek 2015-08-13 11:42:01 UTC
This BZ tracks only the part which adds the add/edit/attach disks to the new/edit VM dialogs.

Comment 4 Elad 2015-08-19 06:57:56 UTC
Apart from the Webadmin change, no further test cases are needed here. 

Create/attach/edit disk done from the VM creation/edit prompt works as expected.

Tested using rhevm-3.6.0-0.11.master.el6.noarch

Comment 6 errata-xmlrpc 2016-03-09 20:35:10 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHEA-2016-0376.html