Bug 1118402

Summary: external display resolution degraded with kernel 3.15.3-200.fc20.x86_64
Product: [Fedora] Fedora Reporter: andrew <alemay>
Component: kernelAssignee: Dave Airlie <airlied>
Status: CLOSED DUPLICATE QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: unspecified Docs Contact:
Priority: unspecified    
Version: 20CC: gansalmon, itamar, jonathan, kernel-maint, luvilla, madhu.chinakonda, marcel, mchehab
Target Milestone: ---   
Target Release: ---   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2014-07-14 01:07:45 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Description andrew 2014-07-10 15:32:57 UTC
Description of problem:
boot 3.15.3-200.fc20.x86_64 kernel on Lenovo ThinkPad T540p and any external display on the dock will not exceed 1024x768

Version-Release number of selected component (if applicable):


How reproducible: 100%


Steps to Reproduce:
1.boot 3.15.3-200.fc20.x86_64 kernel
2. run xrandr
3.

Actual results:
DP2 connected 1024x768+0+0 (normal left inverted right x axis y axis) 521mm x 293mm
   1024x768      60.00* 
   800x600       60.32    56.25  
   848x480       60.00  
   640x480       59.94  

Expected results:
on 
3.15.3-200.fc20.x86_64 kernel

DP2 connected 1920x1080+0+0 (normal left inverted right x axis y axis) 521mm x 293mm
   1920x1080     60.00*+
   1680x1050     59.95  
   1280x1024     75.02    60.02  
   1440x900      59.89  
   1280x960      60.00  
   1280x800      59.81  
   1152x864      75.00  
   1280x720      59.97  
   1024x768      75.08    70.07    60.00  
   832x624       74.55  
   800x600       72.19    75.00    60.32    56.25  
   640x480       75.00    66.67    60.00  
   720x400       70.08  


Additional info:
[alemay@WOPR2 ~]$ lspci  | grep Graphics
00:02.0 VGA compatible controller: Intel Corporation 4th Gen Core Processor Integrated Graphics Controller (rev 06)

Comment 1 Josh Boyer 2014-07-10 15:37:32 UTC
Dave, I think you were looking at this recently?

Comment 2 Marcel Ziswiler 2014-07-11 13:11:07 UTC
Looks like a duplicate of https://bugzilla.redhat.com/show_bug.cgi?id=1117008.

Comment 3 Dave Airlie 2014-07-14 01:07:45 UTC

*** This bug has been marked as a duplicate of bug 1117008 ***