Bug 1117008 - External monitor resolution regression between 3.14.9-200 and 3.15.3-200
Summary: External monitor resolution regression between 3.14.9-200 and 3.15.3-200
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-intel
Version: 20
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Dave Airlie
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 1118402 1118950 1119021 1119864 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-07-07 19:39 UTC by Luke Macken
Modified: 2016-09-20 02:46 UTC (History)
22 users (show)

Fixed In Version: kernel-3.15.5-200.fc20
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-07-17 04:29:41 UTC


Attachments (Terms of Use)
dmesg.diff (41.33 KB, patch)
2014-07-07 19:42 UTC, Luke Macken
no flags Details | Diff
Xorg.0.log.diff (14.35 KB, patch)
2014-07-07 19:42 UTC, Luke Macken
no flags Details | Diff
dmesg-3.14.9-200.fc20.x86_64 (123.19 KB, text/plain)
2014-07-07 21:50 UTC, Luke Macken
no flags Details
dmesg-3.15.3-200.fc20.x86_64 (138.47 KB, text/plain)
2014-07-07 21:51 UTC, Luke Macken
no flags Details
Xorg.0.log.3-14.9-200.fc20.x86_64 (35.10 KB, text/plain)
2014-07-07 21:52 UTC, Luke Macken
no flags Details
Xorg.0.log.3.15.3-200.fc20.x86_64 (40.39 KB, text/plain)
2014-07-07 21:53 UTC, Luke Macken
no flags Details
Kernel log with working 3.14.9 kernel (80.86 KB, text/plain)
2014-07-11 13:33 UTC, Marcel Ziswiler
no flags Details
Kernel log with failing 3.15.4 kernel (77.95 KB, text/plain)
2014-07-11 13:33 UTC, Marcel Ziswiler
no flags Details
Xorg log with working 3.14.9 kernel (52.34 KB, text/plain)
2014-07-11 13:34 UTC, Marcel Ziswiler
no flags Details
Xorg log with failing 3.15.4 kernel (56.46 KB, text/plain)
2014-07-11 13:35 UTC, Marcel Ziswiler
no flags Details
revert upstream commit (1.53 KB, patch)
2014-07-14 01:05 UTC, Dave Airlie
no flags Details | Diff

Description Luke Macken 2014-07-07 19:39:41 UTC
Description of problem:

With 3.14.9-200 I am able to dock my Thinkpad T540p and use an external Dell monitor at 1920x1200. Since 3.15.3-200, I am only able to select 1024x768


Version-Release number of selected component (if applicable):
kernel-3.15.3-200.fc20

How reproducible:
Always

Steps to Reproduce:
1. Boot into 3.15.3-200
2. Dock laptop and use external monitor over HDMI
3. Attempt to change resolution via GNOME Display properties, or arandr.

Comment 1 Luke Macken 2014-07-07 19:42:05 UTC
Created attachment 916173 [details]
dmesg.diff

dmesg diff of 3.14.9-200 and 3.15.3-200

Comment 2 Luke Macken 2014-07-07 19:42:36 UTC
Created attachment 916174 [details]
Xorg.0.log.diff

Xorg log diff

Comment 3 Luke Macken 2014-07-07 21:50:58 UTC
Created attachment 916199 [details]
dmesg-3.14.9-200.fc20.x86_64

drm.debug=6 dmesg output of the working kernel

Comment 4 Luke Macken 2014-07-07 21:51:40 UTC
Created attachment 916200 [details]
dmesg-3.15.3-200.fc20.x86_64

drm.debug=6 dmesg output of the latest kernel

Comment 5 Luke Macken 2014-07-07 21:52:38 UTC
Created attachment 916201 [details]
Xorg.0.log.3-14.9-200.fc20.x86_64

Comment 6 Luke Macken 2014-07-07 21:53:02 UTC
Created attachment 916202 [details]
Xorg.0.log.3.15.3-200.fc20.x86_64

Comment 7 Peter Ludikovsky 2014-07-09 13:32:05 UTC
Same issue on Thinkpad T440s' when using the docking station.
No issue without the docking station.

Comment 8 Marcel Ziswiler 2014-07-11 13:33:13 UTC
Created attachment 917308 [details]
Kernel log with working 3.14.9 kernel

Comment 9 Marcel Ziswiler 2014-07-11 13:33:57 UTC
Created attachment 917309 [details]
Kernel log with failing 3.15.4 kernel

Comment 10 Marcel Ziswiler 2014-07-11 13:34:35 UTC
Created attachment 917310 [details]
Xorg log with working 3.14.9 kernel

Comment 11 Marcel Ziswiler 2014-07-11 13:35:13 UTC
Created attachment 917311 [details]
Xorg log with failing 3.15.4 kernel

Comment 12 Marcel Ziswiler 2014-07-11 13:35:57 UTC
Same issue on my Thinkpad T440s with Ultra Dock 3. Upgrading to 3.15.4-200.fc20.x86_64 also did not help. Log files attached. Some maybe relevant excerpts as follows:

dmesg:
[    0.000000] Reserving Intel graphics stolen memory at 0xbda00000-0xbf9fffff

[    1.790036] fb: conflicting fb hw usage inteldrmfb vs EFI VGA - removing generic driver
vs.
[    1.292979] fb: switching to inteldrmfb from EFI VGA

[   15.475616] SELinux: initialized (dev drm, type drm), not configured for labeling

Xorg.log.0:
[    14.991] (II) intel(0): Modeline "2560x1440"x60.0  241.50  2560 2608 2640 2720  1440 1443 1448 1481 +hsync +vsync (88.8 kHz eP)
vs.
[    18.639] (II) intel(0): Modeline "1024x768"x60.0   65.00  1024 1048 1184 1344  768 771 777 806 -hsync -vsync (48.4 kHz e)

[    14.992] (II) intel(0): Using spanning desktop for initial modes
vs.
[    18.639] (II) intel(0): Using fuzzy aspect match for initial modes

[    14.992] (II) intel(0): Output DP2 using initial mode 2560x1440 +1920+0
vs.
[    18.639] (II) intel(0): Output DP2 using initial mode 1024x768 +0+0

[    14.993] (II) intel(0): Allocated new frame buffer 4480x1440 stride 17920, tiled
vs.
[    18.641] (II) intel(0): Allocated new frame buffer 1024x768 stride 4096, tiled

[    15.055] (II) intel(0): Setting screen physical size to 1185 x 381
vs.
[    19.809] (II) intel(0): Setting screen physical size to 270 x 203

missing
[    15.821] (II) intel(0): EDID vendor "LGD", prod id 1034
[    15.821] (II) intel(0): Printing DDC gathered Modelines:
[    15.821] (II) intel(0): Modeline "1920x1080"x0.0  140.10  1920 1980 2016 2092  1080 1083 1088 1116 +hsync -vsync (67.0 kHz eP)
[    16.043] (II) intel(0): Allocated new frame buffer 2560x1440 stride 10240, tiled
[    17.595] (II) intel(0): EDID vendor "LGD", prod id 1034
[    17.595] (II) intel(0): Printing DDC gathered Modelines:
[    17.595] (II) intel(0): Modeline "1920x1080"x0.0  140.10  1920 1980 2016 2092  1080 1083 1088 1116 +hsync -vsync (67.0 kHz eP)

[    27.653] (II) intel(0): Using hsync ranges from config file
[    27.653] (II) intel(0): Using vrefresh ranges from config file
vs.
[    20.628] (II) intel(0): Using EDID range info for horizontal sync
[    20.628] (II) intel(0): Using EDID range info for vertical refresh

Also quite stunning that booting takes almost 4 seconds longer!

Comment 13 Richard Körber 2014-07-12 10:30:28 UTC
Same issue on a ThinkPad X240 with UltraDock on an EIZO monitor. Works again after downgrading to kernel-3.14.8-200.

Bug 1118402 and Bug 1118950 seem to be duplicates.

Comment 14 Jiri Pirko 2014-07-13 09:00:41 UTC
*** Bug 1118950 has been marked as a duplicate of this bug. ***

Comment 15 Jiri Pirko 2014-07-13 09:07:04 UTC
I am also hitting this bug on my docked t440s. I tested following kernel:

kernel-3.14.9-200.fc20.x86_64           - ok
kernel-3.15.2-200.fc20.x86_64           - not ok
kernel-3.15.3-200.fc20.x86_64           - not ok
kernel-3.15.4-200.fc20.x86_64           - not ok
kernel-3.16.0-0.rc4.git3.1.fc20.x86_64  - not ok

Note that the last kernel is custom built.

So it looks like this regression appeared in 3.15 and it is still in upstream kernel.

Comment 16 Dave Airlie 2014-07-14 01:05:24 UTC
Created attachment 917655 [details]
revert upstream commit

patch just sent upstream.

Comment 17 Dave Airlie 2014-07-14 01:07:30 UTC
please apply that fix to Fedora 3.15 or newer kernels.

Comment 18 Dave Airlie 2014-07-14 01:07:45 UTC
*** Bug 1118402 has been marked as a duplicate of this bug. ***

Comment 19 Jiri Pirko 2014-07-14 06:19:07 UTC
Dave, can you give us link to mailing list or patchwork? I cannot find your post. Thanks.

Comment 20 Josh Boyer 2014-07-14 12:06:41 UTC
(In reply to Jiri Pirko from comment #19)
> Dave, can you give us link to mailing list or patchwork? I cannot find your
> post. Thanks.

http://www.spinics.net/lists/intel-gfx/msg49145.html

Comment 21 Josh Boyer 2014-07-14 12:11:08 UTC
*** Bug 1119021 has been marked as a duplicate of this bug. ***

Comment 22 Josh Boyer 2014-07-14 15:09:03 UTC
Added to F20-rawhide.  Thanks.

Comment 23 Jiri Pirko 2014-07-14 21:28:10 UTC
Just tested 3.15.5-200.fc20.x86_64. Works fine. Thanks!

Comment 24 Fedora Update System 2014-07-15 01:45:52 UTC
kernel-3.15.5-200.fc20 has been submitted as an update for Fedora 20.
https://admin.fedoraproject.org/updates/kernel-3.15.5-200.fc20

Comment 25 Dave Airlie 2014-07-15 22:33:29 UTC
*** Bug 1119864 has been marked as a duplicate of this bug. ***

Comment 26 Fedora Update System 2014-07-17 04:29:41 UTC
kernel-3.15.5-200.fc20 has been pushed to the Fedora 20 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 27 Ted Ross 2014-07-17 12:20:42 UTC
The updated kernel does _not_ fix this problem on my T540p.  Should I re-open the issue?

Comment 28 Luke Macken 2014-07-17 20:57:08 UTC
The update fixes the issue for me with my T540p + Dell monitor over HDMI from the dock.

Comment 29 Richard Körber 2014-07-17 21:17:55 UTC
kernel-3.15.5-200.fc20 also fixes the issue on my ThinkPad X240. Thank you for the quick fix.

Comment 30 Lukas Zachar 2014-08-01 11:06:01 UTC
Does it work for you with kernel-3.15.7-200.fc20?

On the same setup (T440s + UltraDock + NEC monitor + Samsung monitor)

When I use kernel-3.15.5-200.mst.fc20 I see in xrandr:

Screen 0: minimum 320 x 200, current 3840 x 1080, maximum 8192 x 8192
eDP1 connected (normal left inverted right x axis y axis)
   1920x1080     60.01 +
   ...
DP1 disconnected (normal left inverted right x axis y axis)
HDMI1 disconnected (normal left inverted right x axis y axis)
DP2 disconnected (normal left inverted right x axis y axis)
HDMI2 disconnected (normal left inverted right x axis y axis)
DP3 disconnected (normal left inverted right x axis y axis)
DP4 connected primary 1920x1080+0+0 (normal left inverted right x axis y axis) 510mm x 287mm
   1920x1080     60.00*+  50.00    59.94  
   ...
DP5 connected 1920x1080+1920+0 (normal left inverted right x axis y axis) 477mm x 268mm
   1920x1080     60.00*+
   ...

And all works as expected. 
However if I update to kernel-3.15.7-200.fc20 I'm getting mirrored/one huge screen again.
xrandr there:

Screen 0: minimum 320 x 200, current 3840 x 1080, maximum 8192 x 8192
eDP1 connected (normal left inverted right x axis y axis)
   1920x1080     60.01 +
   ...
DP1 disconnected (normal left inverted right x axis y axis)
HDMI1 disconnected (normal left inverted right x axis y axis)
DP2 connected 3840x1080+0+0 (normal left inverted right x axis y axis) 510mm x 287mm
   1920x1080     60.00 +
   3840x1080     60.00* 
   ...
HDMI2 disconnected (normal left inverted right x axis y axis)

Comment 31 Ted Ross 2014-08-01 13:04:21 UTC
For what it's worth, this did not fix the problem on my T540p.  I've worked around it by attaching my external screen directly to the laptop and not the docking station.

Comment 32 andrew 2014-08-01 13:19:39 UTC
(In reply to Ted Ross from comment #31)
> For what it's worth, this did not fix the problem on my T540p.  I've worked
> around it by attaching my external screen directly to the laptop and not the
> docking station.

This bug is not about that, its about the connections external connections on the laptops not docks resolutions being dropped down to xvga res. The dock problem is something else. Which I see with my t540p as well.


This kernel works for me.


 xrandr | grep 1080
Screen 0: minimum 320 x 200, current 3840 x 1080, maximum 8192 x 8192
   1920x1080     60.01 +
HDMI1 connected 1920x1080+1920+0 (normal left inverted right x axis y axis) 521mm x 293mm
   1920x1080     60.00*+  50.00    59.94  
   1920x1080i    60.00    50.00    59.94  
DP2 connected 1920x1080+0+0 (normal left inverted right x axis y axis) 521mm x 293mm
   1920x1080     60.00*+


~]$ uname -a
Linux WOPR2 3.15.6-200.fc20.x86_64 #1 SMP Fri Jul 18 02:36:27 UTC 2014 x86_64 x86_64 x86_64 GNU/Linux


Note You need to log in before you can comment on or make changes to this bug.