Bug 1118496

Summary: Rebase openstack-ceilometer to 2014.1.1
Product: Red Hat OpenStack Reporter: Scott Lewis <sclewis>
Component: openstack-ceilometerAssignee: Eoghan Glynn <eglynn>
Status: CLOSED ERRATA QA Contact: Eoghan Glynn <eglynn>
Severity: unspecified Docs Contact:
Priority: high    
Version: 5.0 (RHEL 6)CC: ajeain, breeler, eglynn, jruzicka, lhh, pbrady, srevivo, yeylon
Target Milestone: rcKeywords: OtherQA, Rebase
Target Release: 5.0 (RHEL 6)   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: openstack-ceilometer-2014.1.1-1.el6ost Doc Type: Rebase: Bug Fixes Only
Doc Text:
Rebase package(s) to version: 2014.1.1 Highlights and important bug fixes: * Launchpad #1315926: A bugfix in WSME (Web Service Made Easy) for correcting the default values created another bug causing a test failure in _validate_query. This has been fixed. * Launchpad #856764: RabbitMQ connections lacked heartbeat or TCP keepalives. As a result, placing a stateful firewall between the connection resulted in idle connections being terminated without either endpoint being aware. RabbitMQ's heartbeat and TCP keepalives have been provided so this no longer occurs. * Launchpad #1317900: network notifications throwing keyerror: When bulk creating ports, networks, subnets in neutron, the ceilometer-notification-agent will be broken and raise a KeyError. This has been fixed and now errors are not raised. * Launchpad #1304419: update alarm combination can specify alarm_id of itself as the value of "--alarm_ids": Previously, update combination alarm could specify itself in alarm_ids, which caused an endless loop when evaluating this alarm. This has been fixed and now an alarm cannot specify itself in the combination rule.
Story Points: ---
Clone Of: 1117902 Environment:
Last Closed: 2014-07-28 18:58:00 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
Bug Depends On: 1117902    
Bug Blocks:    

Comment 3 Eoghan Glynn 2014-07-21 17:16:30 UTC
OtherQA
=======

0. Install rhos5 from puddle:

   5.0-RHEL-6/2014-07-18.1

1. Deploy using packstack --allinone

2. Down tarball from upstream

   wget https://launchpad.net/ceilometer/icehouse/2014.1.1/+download/ceilometer-2014.1.1.tar.gz

3. Confirm md5sum:

   $ md5sum ceilometer-2014.1.1.tar.gz 
6311c8054f781fd2c23bc737c6ef8898  ceilometer-2014.1.1.tar.gz

   compared to:

   https://launchpad.net/ceilometer/icehouse/2014.1.1/+download/ceilometer-2014.1.1.tar.gz/+md5

4. Explode tarball and compare python files therein to those installed by packstack:

   $ tar xvf ceilometer-2014.1.1.tar.gz ; cd ceilometer-2014.1.1
   $ for f in `find . -name "*.py"` ; do diff $f /usr/lib/python2.6/site-packages/$f ; done

5. Ensure all deltas can be accounted for by additional patches carried:

   http://pkgs.devel.redhat.com/cgit/rpms/openstack-ceilometer/tree/0001-Ensure-routing-key-is-specified-in-the-address-for-a.patch?h=rhos-5.0-rhel-6
   http://pkgs.devel.redhat.com/cgit/rpms/openstack-ceilometer/tree/0002-remove-token-from-notifier-middleware.patch?h=rhos-5.0-rhel-6

Given the above sanity checks, the rebase is verified for OtherQA.

Comment 5 errata-xmlrpc 2014-07-28 18:58:00 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHEA-2014-0954.html