Bug 1120682

Summary: Rebase of fence agents
Product: Red Hat Enterprise Linux 7 Reporter: Marek Grac <mgrac>
Component: fence-agentsAssignee: Marek Grac <mgrac>
Status: CLOSED ERRATA QA Contact: Cluster QE <mspqa-list>
Severity: medium Docs Contact:
Priority: medium    
Version: 7.1CC: anprice, cluster-maint, lilu, mjuricek
Target Milestone: rcKeywords: Rebase
Target Release: ---   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: fence-agents-4.0.11-1.el7 Doc Type: Rebase: Bug Fixes and Enhancements
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2015-03-05 09:07:15 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Description Marek Grac 2014-07-17 12:32:42 UTC
Version in RHEL7.0 is based on 4.0.2, currently we are on 4.0.10; rebase is target to 4.0.11/12

* a lot of code clean-up 
* there are already 36 additional patches in 7.0 (in order to not do rebase after deadline but fix all bugs)
* fence_scsi/fence_ipmi are ported to fencing library
* improved testing utilities

Comment 1 Marek Grac 2014-07-17 12:34:29 UTC
Also add fence agent fence_zvm for s390

Comment 2 Marek Grac 2014-09-03 11:29:45 UTC
Rebased to fence-agents-4.0.11 
* added options --ssl-secure and ssl-insecure which were not in upstream
* fence_scsi_check.pl is not a python script what is misleading but it is required for backward compatibility

Comment 6 errata-xmlrpc 2015-03-05 09:07:15 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2015-0393.html