Bug 1122833

Summary: [RFE] Slow usability when adding many Puppet modules to a CV
Product: Red Hat Satellite 6 Reporter: Dominic Cleal <dcleal>
Component: Content ManagementAssignee: Katello Bug Bin <katello-bugs>
Status: CLOSED DUPLICATE QA Contact: Katello QA List <katello-qa-list>
Severity: low Docs Contact:
Priority: medium    
Version: 6.0.3CC: abradshaw, bbuckingham
Target Milestone: UnspecifiedKeywords: FutureFeature, Triaged
Target Release: Unused   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2015-10-16 14:15:04 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Bug Depends On:    
Bug Blocks: 1122832    

Description Dominic Cleal 2014-07-24 07:57:30 UTC
Description of problem:
When adding many (> 40) Puppet modules to a content view, the user interface is too slow due to the need to select them individually and specify the version to use.

It should be possible to bulk add (checkboxes?) and only specify the version if needed, else take the latest.

Version-Release number of selected component (if applicable):
6.0.3

How reproducible:
Always

Steps to Reproduce:
1. Add many Puppet modules to a content view

Actual results:
Have to click/select multiple times the number of modules

Expected results:
Only a few clicks

Comment 2 RHEL Program Management 2014-07-24 08:14:26 UTC
Since this issue was entered in Red Hat Bugzilla, the release flag has been
set to ? to ensure that it is properly evaluated for this release.

Comment 4 Brad Buckingham 2015-10-16 14:15:04 UTC

*** This bug has been marked as a duplicate of bug 1154400 ***