Bug 1127734

Summary: Can't create a content host: undefined method `default_environment' for #<User:0x007f9855c0fe78>
Product: Red Hat Satellite 6 Reporter: David Davis <daviddavis>
Component: APIAssignee: Adam Price <adprice>
Status: CLOSED DUPLICATE QA Contact: Katello QA List <katello-qa-list>
Severity: high Docs Contact:
Priority: unspecified    
Version: 6.0.4CC: adujicek, bbuckingham, sthirugn
Target Milestone: UnspecifiedKeywords: Triaged
Target Release: Unused   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2014-08-11 20:43:39 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Description David Davis 2014-08-07 12:42:52 UTC
Description of problem:

When I try to create a system from the CLI, I get "undefined method `default_environment' for #<User:0x007f9855c0fe78>" if I have more than 1 environment in my org.

Version-Release number of selected component (if applicable):

6.0.4

How reproducible:

Always

Steps to Reproduce:
1. Create multiple environments for an org
2. Try to create a system for that org from the CLI
3. 

Actual results:

Can't create a content host: undefined method `default_environment' for #<User:0x007f9855c0fe78>

Expected results:

Success

Additional info:

Comment 2 RHEL Product and Program Management 2014-08-07 12:44:31 UTC
Since this issue was entered in Red Hat Bugzilla, the release flag has been
set to ? to ensure that it is properly evaluated for this release.

Comment 4 Brad Buckingham 2014-08-11 12:49:42 UTC
*** Bug 1127629 has been marked as a duplicate of this bug. ***

Comment 5 Adam Price 2014-08-11 20:43:39 UTC

*** This bug has been marked as a duplicate of bug 1092712 ***