Bug 1127734 - Can't create a content host: undefined method `default_environment' for #<User:0x007f9855c0fe78>
Summary: Can't create a content host: undefined method `default_environment' for #<Use...
Keywords:
Status: CLOSED DUPLICATE of bug 1092712
Alias: None
Product: Red Hat Satellite 6
Classification: Red Hat
Component: API
Version: 6.0.4
Hardware: Unspecified
OS: Unspecified
unspecified
high vote
Target Milestone: Unspecified
Assignee: Adam Price
QA Contact: Katello QA List
URL:
Whiteboard:
: 1127629 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-08-07 12:42 UTC by David Davis
Modified: 2014-08-11 20:43 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-08-11 20:43:39 UTC


Attachments (Terms of Use)

Description David Davis 2014-08-07 12:42:52 UTC
Description of problem:

When I try to create a system from the CLI, I get "undefined method `default_environment' for #<User:0x007f9855c0fe78>" if I have more than 1 environment in my org.

Version-Release number of selected component (if applicable):

6.0.4

How reproducible:

Always

Steps to Reproduce:
1. Create multiple environments for an org
2. Try to create a system for that org from the CLI
3. 

Actual results:

Can't create a content host: undefined method `default_environment' for #<User:0x007f9855c0fe78>

Expected results:

Success

Additional info:

Comment 2 RHEL Product and Program Management 2014-08-07 12:44:31 UTC
Since this issue was entered in Red Hat Bugzilla, the release flag has been
set to ? to ensure that it is properly evaluated for this release.

Comment 4 Brad Buckingham 2014-08-11 12:49:42 UTC
*** Bug 1127629 has been marked as a duplicate of this bug. ***

Comment 5 Adam Price 2014-08-11 20:43:39 UTC

*** This bug has been marked as a duplicate of bug 1092712 ***


Note You need to log in before you can comment on or make changes to this bug.