Bug 1128606

Summary: EL5 repos should create repodata with md5 checksum
Product: [Community] Copr Reporter: Miroslav Suchý <msuchy>
Component: backendAssignee: Valentin Gologuzov <vgologuz>
Status: CLOSED CURRENTRELEASE QA Contact:
Severity: unspecified Docs Contact:
Priority: high    
Version: unspecifiedCC: asamalik, jberan
Target Milestone: ---   
Target Release: ---   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2014-08-25 07:30:56 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Description Miroslav Suchý 2014-08-11 08:04:06 UTC
Description of problem:

I got a complant about a el5 repo: 

>
> kevin-spamassassin-el/primary_db
> | 8.0 kB     00:00
> http://copr-be.cloud.fedoraproject.org/results/kevin/spamassassin-el/epel-5-i386/repodata/f4e8852a350249d7c87d91cf2bd40a839feed7e341436339e6c2f9e03dfb0fca-primary.sqlite.bz2:
> [Errno -3] Error performing checksum Trying other mirror. Error:
> failure:
> repodata/f4e8852a350249d7c87d91cf2bd40a839feed7e341436339e6c2f9e03dfb0
> fca-primary.sqlite.bz2 from kevin-spamassassin-el: [Errno 256] No
> more mirrors to try.

This is due to el5 having a really old yum and python-hashlib being
optional. If they have it installed, it works, if not it does not.
Perhaps copr could pass 'md5' for those repos? Or say people need
python-hashlib... 


We want to pass 
 "--checksum md5" to createrepo_c if target platform is el5.

Comment 1 Valentin Gologuzov 2014-08-22 10:39:50 UTC
Fixed, deploed on copr-be-dev.cloud.fedoraproject.org