Bug 1129281

Summary: `go tools cover` is not resolved
Product: [Fedora] Fedora Reporter: Vincent Batts <vbatts>
Component: golang-googlecode-toolsAssignee: Vincent Batts <vbatts>
Status: CLOSED ERRATA QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: unspecified Docs Contact:
Priority: unspecified    
Version: rawhideCC: bugzilla.blk, eparis, vbatts
Target Milestone: ---   
Target Release: ---   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: golang-googlecode-tools-0-1.0.hgd32b5854c941.el6 Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2014-09-25 10:35:41 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description Vincent Batts 2014-08-12 13:39:03 UTC
Description of problem:
The golang-cover rpm only lands /usr/bin/cover, but the `go` tool expects it in it's path as well, such that `go tool cover` resolves.

Version-Release number of selected component (if applicable):
golang-cover-0-0.3.hg17c8fe23290a.fc20.x86_64

How reproducible:
consistent

Steps to Reproduce:
1. run a golang unit test that includes coverage testing `go test -race -timeout 30s -cover ...`
2.
3.

Actual results:
go tool: no such tool "cover"; to install: go get code.google.com/p/go.tools/cmd/cover

Expected results:
no failure

Additional info:

Comment 1 Eric Paris 2014-08-12 13:40:41 UTC
ln -s /usr/bin/cover /usr/lib/golang/pkg/tool/linux_amd64/cover

resolves the problem

Comment 2 Fedora Update System 2014-08-12 16:33:56 UTC
golang-googlecode-tools-0-0.7.hg17c8fe23290a.fc20 has been submitted as an update for Fedora 20.
https://admin.fedoraproject.org/updates/golang-googlecode-tools-0-0.7.hg17c8fe23290a.fc20

Comment 3 Fedora Update System 2014-08-12 16:35:07 UTC
golang-googlecode-tools-0-0.7.hg17c8fe23290a.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/golang-googlecode-tools-0-0.7.hg17c8fe23290a.fc19

Comment 4 Fedora Update System 2014-08-12 16:35:50 UTC
golang-googlecode-tools-0-0.7.hg17c8fe23290a.el6 has been submitted as an update for Fedora EPEL 6.
https://admin.fedoraproject.org/updates/golang-googlecode-tools-0-0.7.hg17c8fe23290a.el6

Comment 5 Fedora Update System 2014-08-13 00:39:12 UTC
Package golang-googlecode-tools-0-0.7.hg17c8fe23290a.el6:
* should fix your issue,
* was pushed to the Fedora EPEL 6 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=epel-testing golang-googlecode-tools-0-0.7.hg17c8fe23290a.el6'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-EPEL-2014-2188/golang-googlecode-tools-0-0.7.hg17c8fe23290a.el6
then log in and leave karma (feedback).

Comment 6 Vincent Batts 2014-08-15 15:54:00 UTC
*** Bug 1117070 has been marked as a duplicate of this bug. ***

Comment 7 Fedora Update System 2014-09-11 21:17:10 UTC
golang-googlecode-tools-0-1.0.hgd32b5854c941.fc20 has been submitted as an update for Fedora 20.
https://admin.fedoraproject.org/updates/golang-googlecode-tools-0-1.0.hgd32b5854c941.fc20

Comment 8 Fedora Update System 2014-09-11 21:19:39 UTC
golang-googlecode-tools-0-1.0.hgd32b5854c941.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/golang-googlecode-tools-0-1.0.hgd32b5854c941.fc19

Comment 9 Fedora Update System 2014-09-11 21:20:44 UTC
golang-googlecode-tools-0-1.0.hgd32b5854c941.el6 has been submitted as an update for Fedora EPEL 6.
https://admin.fedoraproject.org/updates/golang-googlecode-tools-0-1.0.hgd32b5854c941.el6

Comment 10 Fedora Update System 2014-09-25 10:35:41 UTC
golang-googlecode-tools-0-1.0.hgd32b5854c941.fc20 has been pushed to the Fedora 20 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 11 Fedora Update System 2014-09-25 10:35:54 UTC
golang-googlecode-tools-0-1.0.hgd32b5854c941.fc19 has been pushed to the Fedora 19 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 12 Fedora Update System 2014-09-27 18:45:44 UTC
golang-googlecode-tools-0-1.0.hgd32b5854c941.el6 has been pushed to the Fedora EPEL 6 stable repository.  If problems still persist, please make note of it in this bug report.