Bug 1117070 - golang cover: wrong path
Summary: golang cover: wrong path
Keywords:
Status: CLOSED DUPLICATE of bug 1129281
Alias: None
Product: Fedora
Classification: Fedora
Component: golang-googlecode-tools
Version: 20
Hardware: x86_64
OS: Linux
unspecified
unspecified
Target Milestone: ---
Assignee: Vincent Batts
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-07-08 00:38 UTC by IanB
Modified: 2014-08-15 15:54 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-08-15 15:54:00 UTC


Attachments (Terms of Use)

Description IanB 2014-07-08 00:38:56 UTC
golang-cover.x86_64 0:0-0.3.hg17c8fe23290a.fc20 puts the 'cover' utility into /usr/bin/cover however the gotest tool looks for it in /usr/lib/golang/pkg/tool/linux_amd64/cover


Attempting to create a coverage profile results in error e.g:

$ go test -coverprofile c.out <pkg name>
go tool: no such tool "cover"; to install:
	go get code.google.com/p/go.tools/cmd/cover


Creating a symbolic link from /usr/bin/cover to /usr/lib/golang/pkg/tool/linux_amd64/cover and running the command again produces the expected result:

$ go test -coverprofile c.out <pkg name>
ok  	<pkg name>	0.141s	coverage: 12.8% of statements

Comment 1 Vincent Batts 2014-08-15 15:54:00 UTC
0-0.7.hg17c8fe23290a.fc20 fixes this, and should be in updates shortly.

http://koji.fedoraproject.org/koji/buildinfo?buildID=552410

*** This bug has been marked as a duplicate of bug 1129281 ***


Note You need to log in before you can comment on or make changes to this bug.