Bug 1134861

Summary: sanlock missing on i668 and armv7 architectures
Product: [Fedora] Fedora Reporter: Daniel Berrangé <berrange>
Component: sanlockAssignee: David Teigland <teigland>
Status: CLOSED ERRATA QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: urgent Docs Contact:
Priority: unspecified    
Version: 21CC: awilliam, cfeist, crobinso, dan, eblake, fsimonce, pbrobinson, teigland
Target Milestone: ---   
Target Release: ---   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard: AcceptedFreezeException
Fixed In Version: sanlock-3.2.1-2.fc21 Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2014-09-11 02:44:07 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Bug Depends On:    
Bug Blocks: 1043122    

Description Daniel Berrangé 2014-08-28 11:17:31 UTC
Description of problem:
libvirt on Fedora 21 / rawhide has broken dependencies due to missing sanlock packages

[quote]
  libvirt has broken dependencies in the F-21 tree:
  On i386:
        libvirt-lock-sanlock-1.2.7-2.fc21.i686 requires sanlock >= 0:2.4
        libvirt-lock-sanlock-1.2.7-2.fc21.i686 requires libsanlock_client.so.1
  On armhfp:
	libvirt-lock-sanlock-1.2.7-2.fc21.armv7hl requires sanlock >= 0:2.4
        libvirt-lock-sanlock-1.2.7-2.fc21.armv7hl requires libsanlock_client.so.1
  Please resolve this as soon as possible.
[/quote]

This is caused by the recent change to sanlock

  commit d5d7f86f2a4d34048654f57ca2fca79f3556aec8
  Author: David Teigland <teigland@redhat.com>
  Date:   Mon Aug 18 13:54:40 2014 -0500

    Update to sanlock-3.2.0

which added a bogus architecture restriction

   ExclusiveArch:  x86_64 ppc64 aarch64

previously the architecture restriction was only applied on RHEL builds which is acceptable.

Fedora packages though are required to be present on all architectures. If there is a problem requiring ExcludeArch/ExclusiveArch, then it must have a documented bug describing the problem with the intent that it be resolved

https://fedoraproject.org/wiki/Packaging:Guidelines#Architecture_Support

  "Each architecture listed in ExcludeArch needs to have a bug
   filed in bugzilla, describing the reason that the package
   does not compile/build/work on that architecture. The bug
   number should then be placed in a comment, next to the
   corresponding ExcludeArch line"

I have tested a scratch build of sanlock and it successfully builds on all Fedora architectures so please remove this ExclusiveArch.

  http://koji.fedoraproject.org/koji/taskinfo?taskID=7474066

Version-Release number of selected component (if applicable):
sanlock-3.2.1-1.fc21

Comment 1 Dan Horák 2014-08-28 11:34:04 UTC
yes, please remove the ExclusiveArch, with my secondary arch hat on, it would break libvirt on s390(x) and ppc64le at least

Comment 2 Fedora Update System 2014-08-28 12:26:52 UTC
sanlock-3.2.1-2.fc21 has been submitted as an update for Fedora 21.
https://admin.fedoraproject.org/updates/sanlock-3.2.1-2.fc21

Comment 3 Fedora Update System 2014-08-28 16:44:12 UTC
Package sanlock-3.2.1-2.fc21:
* should fix your issue,
* was pushed to the Fedora 21 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing sanlock-3.2.1-2.fc21'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2014-9895/sanlock-3.2.1-2.fc21
then log in and leave karma (feedback).

Comment 4 Cole Robinson 2014-09-05 15:25:34 UTC
Proposing as alpha freeze exception: without this sanlock update, libvirt has broken deps on i686 and arm.

Comment 5 Adam Williamson 2014-09-10 18:12:31 UTC
Discussed at 2014-09-10 freeze exception review meeting: http://meetbot.fedoraproject.org/fedora-blocker-review/2014-09-10/f21-blocker-review.2014-09-10-16.07.log.txt . Accepted as a freeze exception issue - we don't really need this for the release, but it'll stop people getting nagmails and shouldn't endanger composes at all.

Comment 6 Fedora Update System 2014-09-11 02:44:07 UTC
sanlock-3.2.1-2.fc21 has been pushed to the Fedora 21 stable repository.  If problems still persist, please make note of it in this bug report.