Bug 1149588

Summary: (squid): xstrdup: tried to dup a NULL pointer!
Product: Red Hat Enterprise Linux 6 Reporter: Yoshifumi Kinoshita <ykinoshi>
Component: squidAssignee: Luboš Uhliarik ✈ <luhliari>
Status: CLOSED ERRATA QA Contact: Ondřej Pták <optak>
Severity: unspecified Docs Contact:
Priority: unspecified    
Version: 6.4CC: dkutalek, optak, psimerda, thozza, wburrows
Target Milestone: rcKeywords: Patch
Target Release: ---   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: squid-3.1.10-32.el6 Doc Type: Bug Fix
Doc Text:
Prior to this update, squid in some cases terminated unexpectedly with the following error message: xstrdup: tried to dup a NULL pointer! This update fixes the incorrect error handling that caused this problem. As a result, the described error no longer causes squid to crash.
Story Points: ---
Clone Of: Environment:
Last Closed: 2015-07-22 06:26:27 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Bug Depends On:    
Bug Blocks: 1075802    
Attachments:
Description Flags
patch
none
patch none

Comment 6 Pavel Šimerda (pavlix) 2014-12-16 16:13:18 UTC
Created attachment 969627 [details]
patch

Haven't found any prior patch, so I just decided to pass "Unknown error" when error is NULL.

Comment 7 Pavel Šimerda (pavlix) 2014-12-16 16:14:55 UTC
Created attachment 969629 [details]
patch

Comment 10 Ondřej Pták 2015-06-10 13:54:10 UTC
I have no idea how to reproduce this, but patch looks good, it should solve this problem (xstrdup won't get NULL).
There was no problem in regression testing.

Comment 12 errata-xmlrpc 2015-07-22 06:26:27 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2015-1314.html