Bug 1149588 - (squid): xstrdup: tried to dup a NULL pointer!
Summary: (squid): xstrdup: tried to dup a NULL pointer!
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: squid
Version: 6.4
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: rc
: ---
Assignee: Luboš Uhliarik ✈
QA Contact: Ondřej Pták
URL:
Whiteboard:
Depends On:
Blocks: 1075802
TreeView+ depends on / blocked
 
Reported: 2014-10-06 07:33 UTC by Yoshifumi Kinoshita
Modified: 2019-07-11 08:13 UTC (History)
5 users (show)

Fixed In Version: squid-3.1.10-32.el6
Doc Type: Bug Fix
Doc Text:
Prior to this update, squid in some cases terminated unexpectedly with the following error message: xstrdup: tried to dup a NULL pointer! This update fixes the incorrect error handling that caused this problem. As a result, the described error no longer causes squid to crash.
Clone Of:
Environment:
Last Closed: 2015-07-22 06:26:27 UTC


Attachments (Terms of Use)
patch (610 bytes, patch)
2014-12-16 16:13 UTC, Pavel Šimerda (pavlix)
no flags Details | Diff
patch (610 bytes, patch)
2014-12-16 16:14 UTC, Pavel Šimerda (pavlix)
no flags Details | Diff


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2015:1314 normal SHIPPED_LIVE squid bug fix and enhancement update 2015-07-20 17:53:27 UTC

Comment 6 Pavel Šimerda (pavlix) 2014-12-16 16:13:18 UTC
Created attachment 969627 [details]
patch

Haven't found any prior patch, so I just decided to pass "Unknown error" when error is NULL.

Comment 7 Pavel Šimerda (pavlix) 2014-12-16 16:14:55 UTC
Created attachment 969629 [details]
patch

Comment 10 Ondřej Pták 2015-06-10 13:54:10 UTC
I have no idea how to reproduce this, but patch looks good, it should solve this problem (xstrdup won't get NULL).
There was no problem in regression testing.

Comment 12 errata-xmlrpc 2015-07-22 06:26:27 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2015-1314.html


Note You need to log in before you can comment on or make changes to this bug.