Bug 1154940

Summary: qemu-img fail with error writing bmap to vdi format disk image
Product: Red Hat Enterprise Linux 7 Reporter: Sibiao Luo <sluo>
Component: qemu-kvmAssignee: Max Reitz <mreitz>
Status: CLOSED DUPLICATE QA Contact: Virtualization Bugs <virt-bugs>
Severity: medium Docs Contact:
Priority: medium    
Version: 7.1CC: chayang, famz, juzhang, kwolf, michen, mreitz, pbonzini, qzhang, rbalakri, virt-maint, xfu
Target Milestone: rc   
Target Release: ---   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2014-11-03 13:53:33 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description Sibiao Luo 2014-10-21 05:09:16 UTC
Description of problem:
qemu-img fail with error writing bmap to vdi format disk image using qemu-kvm-1.5.3-75.el7.x86_64, but the image has been created successfully and flooding with 'ERROR: block index 0 also used by 0' when check the image.
BTW, the qemu-kvm-rhev-2.1.2-4.el7 did not hit such issue.

Version-Release number of selected component (if applicable):
host info:
# uname -r && rpm -q qemu-kvm
3.10.0-123.9.2.el7.x86_64
qemu-kvm-1.5.3-75.el7.x86_64

How reproducible:
100%

Steps to Reproduce:
# qemu-img create -f vdi data-disk.vdi 1000T
Formatting 'data-disk.vdi', fmt=vdi size=1099511627776000 static=off 
qemu-img: data-disk.vdi: Error writing bmap to data-disk.vdi

# qemu-img info data-disk.vdi
image: data-disk.vdi
file format: vdi
virtual size: 1000T (1099511627776000 bytes)
disk size: 4.0K
cluster_size: 1048576

# qemu-img check data-disk.vdi
ERROR: block index 0 also used by 0
ERROR: block index 0 also used by 0
ERROR: block index 0 also used by 0
ERROR: block index 0 also used by 0
...

Actual results:

Expected results:
It can create vdi format disk image successfully.

Additional info:

Comment 1 Kevin Wolf 2014-11-03 13:53:33 UTC

*** This bug has been marked as a duplicate of bug 1154937 ***