Bug 1154937 - qemu-img fail to open the big vdi format disk image with 'Invalid argument' error
Summary: qemu-img fail to open the big vdi format disk image with 'Invalid argument' e...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: qemu-kvm-rhev
Version: 7.1
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: rc
: ---
Assignee: Max Reitz
QA Contact: Virtualization Bugs
URL:
Whiteboard:
: 1154940 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-10-21 04:59 UTC by Sibiao Luo
Modified: 2015-12-04 16:19 UTC (History)
12 users (show)

Fixed In Version: qemu 2.2.0
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-12-04 16:19:27 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2015:2546 normal SHIPPED_LIVE qemu-kvm-rhev bug fix and enhancement update 2015-12-04 21:11:56 UTC

Description Sibiao Luo 2014-10-21 04:59:16 UTC
Description of problem:
qemu-img fail to open the big(1000T) vdi format disk image with 'Invalid argument' error after created.

Version-Release number of selected component (if applicable):
host info:
3.10.0-183.el7.x86_64
qemu-kvm-rhev-2.1.2-4.el7

How reproducible:
100%

Steps to Reproduce:
1.create a big vdi image via qemu-img.
# qemu-img create -f vdi data-disk.vdi 1000TFormatting 'data-disk.vdi', fmt=vdi size=1099511627776000 static=off 
2.use qemu-img to check the image info.
# qemu-img info data-disk.vdi 
qemu-img: Could not open 'data-disk.vdi': Could not open 'data-disk.vdi': Invalid argument

Actual results:

Expected results:
It should open the big(1000T) vdi format disk image without any error via qemu-img.

Additional info:
It did not hit it with qemu-kvm-rhev-1.5.3-60.el7ev.
# qemu-img create -f vdi data-disk.vdi 1000T
Formatting 'data-disk.vdi', fmt=vdi size=1099511627776000 static=off 
# qemu-img info data-disk.vdi 
image: data-disk.vdi
file format: vdi
virtual size: 1000T (1099511627776000 bytes)
disk size: 2.0G
cluster_size: 1048576

Comment 1 Kevin Wolf 2014-11-03 13:53:33 UTC
*** Bug 1154940 has been marked as a duplicate of this bug. ***

Comment 2 Max Reitz 2014-12-12 14:49:59 UTC
Fix committed as d20418ee514774626ac47a1ad0aa9149c7249cf0, will be fixed in qemu-kvm-rhev by rebase.

Comment 3 huiqingding 2015-03-27 02:29:47 UTC
Reproduce this bug using the following version:
qemu-kvm-rhev-2.1.2-23.el7.x86_64
kernel-3.10.0-232.el7.x86_64

Reproduce steps:
1.create a big vdi image via qemu-img.
# qemu-img create -f vdi data-disk.vdi 1000TFormatting 'data-disk.vdi', fmt=vdi size=1099511627776000 static=off 
2.use qemu-img to check the image info.
# qemu-img info data-disk.vdi 
qemu-img: Could not open 'data-disk.vdi': Could not open 'data-disk.vdi': Invalid argument

Comment 4 huiqingding 2015-03-27 02:36:05 UTC
Test this bug using the following version:
qemu-kvm-rhev-2.2.0-8.el7.x86_64
kernel-3.10.0-232.el7.x86_64

Test steps:
1.create a 1000T vdi image via qemu-img.
# qemu-img create -f vdi data-disk.vdi 1000T
Formatting 'data-disk.vdi', fmt=vdi size=1099511627776000 static=off 
qemu-img: data-disk.vdi: Unsupported VDI image size (size is 0x3e80000000000, max supported is 0x1fffff8000000)

2.create a 512T vdi image via qemu-img
# qemu-img create -f vdi data-disk.vdi 0x1fffff8000000
Formatting 'data-disk.vdi', fmt=vdi size=562949819203584 static=off 

3. use qemu-img to check the imge info
# qemu-img info data-disk.vdi 
image: data-disk.vdi
file format: vdi
virtual size: 512T (562949819203584 bytes)
disk size: 2.0G
cluster_size: 1048576

Test results:
qemu-img can create and check the maxsize 512T vdi image.

Based on the above results, I think this bug has been fixed.

Comment 9 errata-xmlrpc 2015-12-04 16:19:27 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2015-2546.html


Note You need to log in before you can comment on or make changes to this bug.