Bug 1161875

Summary: Calc damages formulas by removing sheet names
Product: [Fedora] Fedora Reporter: Fred New <fred.new2911>
Component: libreofficeAssignee: Eike Rathke <erack>
Status: CLOSED DUPLICATE QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: urgent Docs Contact:
Priority: unspecified    
Version: 20CC: caolanm, dtardon, erack, ltinkl, mstahl, sbergman
Target Milestone: ---   
Target Release: ---   
Hardware: x86_64   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2014-11-11 11:36:59 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description Fred New 2014-11-08 17:24:27 UTC
Description of problem:
I have a multi-sheet spreadsheet. Formulas referring to values on other sheets no longer show the sheet name. They show the correct value until I try to update the formula using F2, at which time it shows values from the current sheet.

Version-Release number of selected component (if applicable):
libreoffice-calc-4.2.7.2-2.fc20.x86_64

How reproducible:
Always

Steps to Reproduce:
1. Open a new calc spreadsheet
2. Set cells A1-A6 to 1-6
3. Create Sheet2 and set cells A1-A6 to =Sheet1.A1-Sheet1.A6
4. Create Sheet3 and cut cells A4-A6 of Sheet2 and paste them in Sheet3 somewhere.
5. Save and close the spreadsheet.
6. Open the spreadsheet and look at the 3 cells on Sheet2.

Actual results:
Cells A1-A3 of Sheet2 show Err:522 because the refer to themselves.

Expected results:
Cells A1-A3 of Sheet2 should still refer to cells A1-A3 of Sheet1.


Additional info:

Comment 1 Fred New 2014-11-08 22:38:43 UTC
Cut and paste appears to be doing the damage:

1. Open a new calc spreadsheet.
2. Set cells A1 and A2 to 1 and 2, respectively.
3. Create Sheet2 and set A1 to =Sheet1.A1.
4. On Sheet2 copy A1 to A2; it should hold the formula =Sheet1.A2.
5. Cut (Sheet2) A2 and paste it to B3.
6. Look at the contents of Sheet2.A1. There won't be any error showing, but the sheet name will be missing from the formula. The error will appear if you save the spreadsheet and open it.

Comment 2 Fred New 2014-11-09 07:24:12 UTC
I have also confirmed this error on a 32-bit Fedora 20 system. This error does not appear on a Windows 8 system with the latest Libre Office 4.3.3 version.

Comment 3 Fred New 2014-11-09 08:33:25 UTC
This bug also appears in the updates-testing version of Calc - libreoffice-calc-4.2.7.2-4.fc20.x86_64.

Comment 4 Eike Rathke 2014-11-11 11:36:59 UTC
Should be a duplicate of bug 1160924

*** This bug has been marked as a duplicate of bug 1160924 ***