Bug 1160924 - regression: cell move breaks cell references
Summary: regression: cell move breaks cell references
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: libreoffice
Version: 20
Hardware: x86_64
OS: Linux
unspecified
unspecified
Target Milestone: ---
Assignee: Eike Rathke
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 1161875 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-11-06 01:55 UTC by sixpack13
Modified: 2014-11-15 09:23 UTC (History)
8 users (show)

Fixed In Version: libreoffice-4.2.7.2-6.fc20
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-11-15 09:23:33 UTC
Type: Bug


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
FreeDesktop.org 82936 None None None Never

Description sixpack13 2014-11-06 01:55:40 UTC
Description of problem:

https://www.libreoffice.org/bugzilla/show_bug.cgi?id=85946


Version-Release number of selected component (if applicable):

libreoffice-calc-4.2.7.2-2.fc20.x86_64


How reproducible:   
see 
https://www.libreoffice.org/bugzilla/show_bug.cgi?id=85946

Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

Comment 1 Eike Rathke 2014-11-07 18:40:17 UTC
Patch fixing this in 4.2.7.2-6 yet unbuilt

Comment 2 sixpack13 2014-11-08 10:37:54 UTC
Okay. Thanks for quick support !!!

Comment 3 Eike Rathke 2014-11-11 11:36:59 UTC
*** Bug 1161875 has been marked as a duplicate of this bug. ***

Comment 4 Fedora Update System 2014-11-12 10:47:05 UTC
libreoffice-4.2.7.2-6.fc20 has been submitted as an update for Fedora 20.
https://admin.fedoraproject.org/updates/libreoffice-4.2.7.2-6.fc20

Comment 5 sixpack13 2014-11-12 14:24:11 UTC
tested 4.2.7.2-6

Bug is not fixed.

I now can produce "Err:523" with just hitting Crtl+Shift+F9 without moving any cell.

anyway thanks again !

Comment 6 sixpack13 2014-11-12 14:56:43 UTC
tested on Fedora 21, libreoffice-calc-4.3.2.2-5

just hitting Crtl+Shift+F9 without moving any cell produces "Err:523"

Comment 7 Eike Rathke 2014-11-12 17:46:22 UTC
What exactly was your test procedure? Getting Err:523 sounds like you loaded an already broken document and hit Shift+Ctrl+F9. The change can not fix broken documents.

If this is the case then please undo your -1 karma vote. Thank you.

Comment 8 sixpack13 2014-11-12 18:25:01 UTC
Arrrgghhh, yes I tested with a internal broken doc !, my bad.

-1 karma undone !!!!

Fedora 20 4.2.7.2-6 AND 
Fedora 21 4.3.2.2-5

are working now.
BUG fixed !

Thx.

Comment 9 Fedora Update System 2014-11-13 18:06:18 UTC
Package libreoffice-4.2.7.2-6.fc20:
* should fix your issue,
* was pushed to the Fedora 20 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing libreoffice-4.2.7.2-6.fc20'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2014-14799/libreoffice-4.2.7.2-6.fc20
then log in and leave karma (feedback).

Comment 10 Fedora Update System 2014-11-15 09:23:33 UTC
libreoffice-4.2.7.2-6.fc20 has been pushed to the Fedora 20 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.