Bug 1163579

Summary: GtkTreeView row can display only lines which do not exceed 5039 characters of length
Product: [Fedora] Fedora Reporter: Mark <spider>
Component: gtk3Assignee: Matthias Clasen <mclasen>
Status: CLOSED CURRENTRELEASE QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: high Docs Contact:
Priority: high    
Version: 21CC: abrt-devel-list, alexander.janssen, bhubbard, ccecchi, davidjeremias82, drindt, dvlasenk, jfilak, kparal, mclasen, mhabrnal, mikhail.v.gavrilov, mmilata, paul.destefano-redhat2, rds, rvokal, samtygier
Target Milestone: ---Keywords: Reopened
Target Release: ---   
Hardware: All   
OS: Unspecified   
URL: https://retrace.fedoraproject.org/faf/reports/bthash/189ece6123db6b8e03d0f0124347788317043d4d
Whiteboard: abrt_hash:10f2442470179bdee27fed08adfd3eb976648b11
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2015-04-09 00:55:09 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
Attachments:
Description Flags
File: backtrace
none
File: cgroup
none
File: core_backtrace
none
File: dso_list
none
File: environ
none
File: limits
none
File: maps
none
File: open_fds
none
File: proc_pid_status
none
File: var_log_messages
none
Occurs for me every time when I try send this report
none
A gtk application crashing due to too long line in GtkTreeView row none

Description Mark 2014-11-13 04:01:20 UTC
Description of problem:
attempted to lodge report bug for midori

Version-Release number of selected component:
libreport-gtk-2.3.0-2.fc21

Additional info:
reporter:       libreport-2.3.0
backtrace_rating: 4
cmdline:        report-gtk -- /var/tmp/abrt/ccpp-2014-11-13-14:09:54-1951
crash_function: _gdk_x11_display_error_event
executable:     /usr/bin/report-gtk
kernel:         3.17.1-302.fc21.i686
runlevel:       N 5
type:           CCpp
uid:            1000

Truncated backtrace:
Thread no. 1 (10 frames)
 #2 _gdk_x11_display_error_event at gdkdisplay-x11.c:2536
 #5 handle_error at xcb_io.c:213
 #6 handle_response at xcb_io.c:325
 #7 _XEventsQueued at xcb_io.c:364
 #8 XEventsQueued at Pending.c:43
 #9 _cairo_xlib_shm_surface_create.isra.12 at /lib/libcairo.so.2
 #10 _cairo_xlib_surface_create_shm at /lib/libcairo.so.2
 #11 _cairo_xlib_surface_create_similar_shm at /lib/libcairo.so.2
 #12 cairo_surface_create_similar_image at /lib/libcairo.so.2
 #13 gtk_css_shadow_value_start_drawing at gtkcssshadowvalue.c:334

Potential duplicate: bug 1113031

Comment 1 Mark 2014-11-13 04:01:25 UTC
Created attachment 956919 [details]
File: backtrace

Comment 2 Mark 2014-11-13 04:01:26 UTC
Created attachment 956920 [details]
File: cgroup

Comment 3 Mark 2014-11-13 04:01:28 UTC
Created attachment 956921 [details]
File: core_backtrace

Comment 4 Mark 2014-11-13 04:01:30 UTC
Created attachment 956922 [details]
File: dso_list

Comment 5 Mark 2014-11-13 04:01:32 UTC
Created attachment 956923 [details]
File: environ

Comment 6 Mark 2014-11-13 04:01:33 UTC
Created attachment 956924 [details]
File: limits

Comment 7 Mark 2014-11-13 04:01:35 UTC
Created attachment 956925 [details]
File: maps

Comment 8 Mark 2014-11-13 04:01:37 UTC
Created attachment 956926 [details]
File: open_fds

Comment 9 Mark 2014-11-13 04:01:38 UTC
Created attachment 956927 [details]
File: proc_pid_status

Comment 10 Mark 2014-11-13 04:01:40 UTC
Created attachment 956928 [details]
File: var_log_messages

Comment 11 Alexander W. Janssen 2014-12-26 07:51:01 UTC
Another user experienced a similar problem:

Trying to report a crash about this same crash which occured after reporting another bug.
Ladies and gentlemen, we have an inception here.
I just reported this bug manually, see #1177333 - maybe this time I'm able to send a full collection of data.
I just used abrt-cli, maybe this one will actually work. If yes, I'll mark #1177333 as duplicate to this one.

reporter:       libreport-2.3.0
backtrace_rating: 4
cmdline:        report-gtk -- /var/tmp/abrt/ccpp-2014-12-26-08:22:38-3407
crash_function: _gdk_x11_display_error_event
executable:     /usr/bin/report-gtk
kernel:         3.17.7-300.fc21.x86_64
package:        libreport-gtk-2.3.0-5.fc21
reason:         report-gtk killed by SIGTRAP
runlevel:       N 5
type:           CCpp
uid:            1000

Comment 12 Alexander W. Janssen 2014-12-26 07:52:41 UTC
*** Bug 1177333 has been marked as a duplicate of this bug. ***

Comment 13 Sam Tygier 2015-01-05 14:02:03 UTC
Another user experienced a similar problem:

ABRT gui crashes after filling in the "How did this problem happen..." page. (I am having to report this via abrt-cli)

I am using Fedora 21 with MATE desktop.

reporter:       libreport-2.3.0
backtrace_rating: 4
cmdline:        report-gtk -- /var/tmp/abrt/ccpp-2015-01-05-13:49:22-1654
crash_function: _gdk_x11_display_error_event
executable:     /usr/bin/report-gtk
kernel:         3.17.7-300.fc21.x86_64
package:        libreport-gtk-2.3.0-5.fc21
reason:         report-gtk killed by SIGTRAP
runlevel:       N 5
type:           CCpp
uid:            1000

Comment 14 Kamil Páral 2015-01-21 11:53:06 UTC
I hit this every time I want to report this gnome-shell crash:
https://retrace.fedoraproject.org/faf/reports/514537/

libreport crashes once I check "I don't know what caused this" and hit Forward.

Comment 15 Mikhail 2015-01-22 16:48:03 UTC
Created attachment 982954 [details]
Occurs for me every time when I try send this report

Comment 16 Jakub Filak 2015-01-23 05:48:07 UTC
I just filed this bug:
https://bugzilla.redhat.com/show_bug.cgi?id=1185157

So the crash must be related to the highlighting of potentially sensitive data.

Comment 17 Kamil Páral 2015-01-23 09:22:42 UTC
Two days ago I was trying to debug this with Company from #gtk+ on gimpnet. I sent him the whole abrt directory, but report-gtk didn't crash for him. Can the sensitive data detection differ on different machines / under different users?

Comment 18 Jakub Filak 2015-01-23 11:44:45 UTC
(In reply to Kamil Páral from comment #17)
Yes, it can. You have to run "report-gtk -e report_Bugzilla -- /var/tmp/abrt/$DIR" to skip the steps which taint the data. With that command line, I can reproduce the crash with your problem directory on F21. I am going to try to reproduce it on Rawhide.

Comment 19 Jakub Filak 2015-01-23 17:29:46 UTC
Created attachment 983479 [details]
A gtk application crashing due to too long line in GtkTreeView row

Run ./example.c and you will see. 5039 is the maximum possible characters per single line.

Comment 20 Jakub Filak 2015-01-23 17:32:53 UTC
I believe this is a bug in GTK.

Comment 21 Kamil Páral 2015-01-23 17:39:43 UTC
Crashes for me as well:

$ bash example.c 

(example:22413): Gdk-ERROR **: The program 'example' received an X Window System error.
This probably reflects a bug in the program.
The error was 'BadAlloc (insufficient resources for operation)'.
  (Details: serial 242 error_code 11 request_code 130 (MIT-SHM) minor_code 5)
  (Note to programmers: normally, X errors are reported asynchronously;
   that is, you will receive the error a while after causing it.
   To debug your program, run it with the GDK_SYNCHRONIZE environment
   variable to change this behavior. You can then get a meaningful
   backtrace from your debugger if you break on the gdk_x_error() function.)
example.c: line 56: 22413 Trace/breakpoint trap   (core dumped) ./example

Comment 22 Kamil Páral 2015-01-23 18:00:59 UTC
Running the example or report-gtk with this envvar makes the app not crash:

$ GTK_DEBUG=no-pixel-cache report-gtk -e report_Bugzilla -- /var/tmp/abrt/$DIR

Comment 23 Radek Vokál 2015-02-08 08:32:33 UTC
+1, I can't report bug in Nemo due to this bug

Comment 24 Jakub Filak 2015-02-10 11:55:10 UTC
Dear users, I wanted to work around this issue by forcing GtkTreeView to wrap long lines, but it seems to be harder than one might think. I have to find a more reliable way how to fix this crash on libreport's side ... I apologise for any inconvenience this might have caused you.

Comment 25 Matthias Clasen 2015-02-10 13:35:12 UTC
I have to admit that I don't see support for >5000 character lines as a priority. That is not a useful UI, regardless whether we crash or not. Just break your lines.

Comment 26 Jakub Filak 2015-02-10 13:55:58 UTC
Thanks Matthias! What is the best way to wrap lines in GtkTreeView rows? I found several tutorials but all of those were suggesting adding about 100 lines of code. Setting "Wrap size" & "Wrap mode" to some values in glade does not work.

Comment 27 Kamil Páral 2015-02-10 14:04:17 UTC
Company said he already pushed a fix for this bug into gtk. But I still don't know in which gtk version the fix should appear and how long it will take.

Comment 28 Kamil Páral 2015-02-10 14:10:45 UTC
So, it should be in 3.15.5.

Comment 29 Kamil Páral 2015-02-12 07:35:28 UTC
I guess this is the update for F21:
https://admin.fedoraproject.org/updates/gtk3-3.14.8-2.fc21

Comment 30 Kamil Páral 2015-02-12 07:42:19 UTC
(In reply to Kamil Páral from comment #29)
> I guess this is the update for F21:
> https://admin.fedoraproject.org/updates/gtk3-3.14.8-2.fc21

It does not say it fixes this bug and the example.c file still crashes for me, so I assume the fix has not been pushed to F21 yet. Reopening. Matthias, can you clarify? Thanks.

Comment 31 Matthias Clasen 2015-02-13 13:07:57 UTC
The fix is 7eecb16404b9fdcd1377e1a159f5e94f079e24b7, which is in 3.15.5. It has not been backported to 3.14 (yet)

Comment 32 Matthias Clasen 2015-04-09 00:55:09 UTC
the fix was included in 3.14.9