Bug 1169001

Summary: AttributeError: 'NoneType' object has no attribute 'path'
Product: [Fedora] Fedora Reporter: r0bs0n <robson.lombardi>
Component: anacondaAssignee: Anaconda Maintenance Team <anaconda-maint-list>
Status: CLOSED DUPLICATE QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: unspecified Docs Contact:
Priority: unspecified    
Version: 21CC: anaconda-maint-list, awilliam, cp361, dshea, g.kaviyarasu, jcallaha, jonathan, mail, mirekspanko, robson.lombardi, vanmeeuwen+fedora
Target Milestone: ---   
Target Release: ---   
Hardware: x86_64   
OS: Unspecified   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2014-12-16 16:55:09 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Attachments:
Description Flags
File: anaconda-tb
none
File: anaconda.log
none
File: environ
none
File: journalctl
none
File: lsblk_output
none
File: nmcli_dev_list
none
File: os_info
none
File: program.log
none
File: storage.log
none
File: ifcfg.log none

Description r0bs0n 2014-11-28 18:57:25 UTC
Description of problem:
1. Start Fedora-Live-Workstation-x86_64-21-1 from USB;
2. Click in "Install to Hard Drive";
3. Crash.

Version-Release number of selected component:
anaconda-core-21.48.18-1.fc21.x86_64

The following was filed automatically by anaconda:
anaconda 21.48.18-1 exception report
Traceback (most recent call first):
  File "/usr/lib64/python2.7/site-packages/pyanaconda/packaging/livepayload.py", line 75, in setup
    if not stat.S_ISBLK(os.stat(osimg.path)[stat.ST_MODE]):
  File "/usr/lib64/python2.7/site-packages/pyanaconda/packaging/__init__.py", line 1236, in _runThread
    payload.setup(storage, instClass)
  File "/usr/lib64/python2.7/threading.py", line 766, in run
    self.__target(*self.__args, **self.__kwargs)
  File "/usr/lib64/python2.7/site-packages/pyanaconda/threads.py", line 227, in run
    threading.Thread.run(self, *args, **kwargs)
AttributeError: 'NoneType' object has no attribute 'path'

Additional info:
cmdline:        /usr/bin/python  /sbin/anaconda --liveinst --method=livecd:///dev/mapper/live-base
cmdline_file:   BOOT_IMAGE=/isolinux/vmlinuz0 root=live:LABEL=Fedora-Live-WS-x86_64-21-1 ro rd.live.image quiet rhgb
executable:     /sbin/anaconda
hashmarkername: anaconda
kernel:         3.17.4-301.fc21.x86_64
other involved packages: python-libs-2.7.8-7.fc21.x86_64
product:        Fedora"
release:        Fedora release 21 (Twenty One)
type:           anaconda
version:        Fedora

Comment 1 r0bs0n 2014-11-28 18:57:31 UTC
Created attachment 962554 [details]
File: anaconda-tb

Comment 2 r0bs0n 2014-11-28 18:57:33 UTC
Created attachment 962555 [details]
File: anaconda.log

Comment 3 r0bs0n 2014-11-28 18:57:34 UTC
Created attachment 962556 [details]
File: environ

Comment 4 r0bs0n 2014-11-28 18:57:37 UTC
Created attachment 962557 [details]
File: journalctl

Comment 5 r0bs0n 2014-11-28 18:57:39 UTC
Created attachment 962558 [details]
File: lsblk_output

Comment 6 r0bs0n 2014-11-28 18:57:40 UTC
Created attachment 962559 [details]
File: nmcli_dev_list

Comment 7 r0bs0n 2014-11-28 18:57:41 UTC
Created attachment 962560 [details]
File: os_info

Comment 8 r0bs0n 2014-11-28 18:57:44 UTC
Created attachment 962561 [details]
File: program.log

Comment 9 r0bs0n 2014-11-28 18:57:50 UTC
Created attachment 962562 [details]
File: storage.log

Comment 10 r0bs0n 2014-11-28 18:57:52 UTC
Created attachment 962563 [details]
File: ifcfg.log

Comment 11 Scott G. 2014-11-30 20:21:41 UTC
Another user experienced a similar problem:

Booted up Fedora Installer, then selected "Install to Hard Drive."

cmdline:        /usr/bin/python  /sbin/anaconda --liveinst --method=livecd:///dev/mapper/live-base
cmdline_file:   BOOT_IMAGE=vmlinuz0 initrd=initrd0.img root=live:CDLABEL=Fedora-Live-Workstation-x86_64-2 rootfstype=auto ro rd.live.image quiet  rhgb rd.luks=0 rd.md=0 rd.dm=0 
hashmarkername: anaconda
kernel:         3.17.1-302.fc21.x86_64
other involved packages: python-libs-2.7.8-4.1.fc21.x86_64
package:        anaconda-core-21.48.13-1.fc21.x86_64
packaging.log:  
product:        Fedora"
reason:         AttributeError: 'NoneType' object has no attribute 'path'
release:        Fedora release 21 (Twenty One)
version:        Fedora

Comment 12 Mirek Špaňko 2014-12-11 03:35:14 UTC
Another user experienced a similar problem:

Running installer in Virtualbox 4.3.18.

cmdline:        /usr/bin/python  /sbin/anaconda --liveinst --method=livecd:///dev/mapper/live-base
cmdline_file:   BOOT_IMAGE=vmlinuz0 initrd=initrd0.img root=live:CDLABEL=Fedora-Live-WS-i686-21-5 rootfstype=auto ro rd.live.image quiet  rhgb rd.luks=0 rd.md=0 rd.dm=0 
hashmarkername: anaconda
kernel:         3.17.4-301.fc21.i686
other involved packages: python-libs-2.7.8-7.fc21.i686
package:        anaconda-core-21.48.21-1.fc21.i686
packaging.log:  
product:        Fedora"
reason:         AttributeError: 'NoneType' object has no attribute 'path'
release:        Fedora release 21 (Twenty One)
version:        Fedora

Comment 13 jcallaha 2014-12-13 18:39:31 UTC
Another user experienced a similar problem:

Description:
When trying to run the installation tool, and loading the language page, I am presented with the reported error.

Product:
Fedora 21 LXDE i686

How reproducable:
3/3 attempts produce error

Steps:
1. Load the live USB into the desktop environment.
2. Run the installation tool
3. View any errors

Actual results:
Recieve fatal error message

Expected results:
Installation progresses as usual

Additional info:
I was able to successfully install on another laptop just 30 minutes prior to this error. I believe the problem lies in the specific hardware of this laptop.

cmdline:        /usr/bin/python  /sbin/anaconda --liveinst --method=livecd:///dev/mapper/live-base
cmdline_file:   BOOT_IMAGE=vmlinuz0 initrd=initrd0.img root=live:CDLABEL=Fedora-Live-LXDE-i686-21-5 rootfstype=auto ro rd.live.image quiet  rhgb rd.luks=0 rd.md=0 rd.dm=0 
hashmarkername: anaconda
kernel:         3.17.4-301.fc21.i686
other involved packages: python-libs-2.7.8-7.fc21.i686
package:        anaconda-core-21.48.21-1.fc21.i686
packaging.log:  
product:        Fedora"
reason:         AttributeError: 'NoneType' object has no attribute 'path'
release:        Fedora release 21 (Twenty One)
version:        Fedora

Comment 14 David Shea 2014-12-16 16:55:09 UTC
This appears to be part of the unicode encode/decode issues had during the RC phase and should be fixed in the final release.

*** This bug has been marked as a duplicate of bug 1169019 ***

Comment 15 Adam Williamson 2014-12-17 05:07:41 UTC
David: at least the last reporter was using the final images - you can tell because the live images do actually have the RC number in the filename / volume label:

CDLABEL=Fedora-Live-LXDE-i686-21-5

the first reporter clearly had an earlier build - RC1, it looks like - but at least Mirek and jcallaha had Final (RC5).

jcallaha, can you attach the full logs for your case? At least journal output, /tmp/anaconda.log , /tmp/program.log and /tmp/storage.log after reproducing the error. Thanks!

Comment 16 Adam Williamson 2014-12-17 17:02:54 UTC
Clearing abrt_hash to try and get fresh reports, we don't think these bugs are actually all dupes of the unicode encoding issue, but we're also not sure the recent results are the same as the original report of this bug.

Comment 17 Vojtech Trefny 2014-12-26 22:12:09 UTC
*** Bug 1177273 has been marked as a duplicate of this bug. ***