Bug 1177273 - AttributeError: 'NoneType' object has no attribute 'path'
Summary: AttributeError: 'NoneType' object has no attribute 'path'
Keywords:
Status: CLOSED DUPLICATE of bug 1169001
Alias: None
Product: Fedora
Classification: Fedora
Component: anaconda
Version: 21
Hardware: x86_64
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Anaconda Maintenance Team
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: abrt_hash:981f0fa38576d70f2281fb9b9b2...
: 1206098 (view as bug list)
Depends On:
Blocks: 1221774
TreeView+ depends on / blocked
 
Reported: 2014-12-25 15:31 UTC by cp361
Modified: 2015-06-17 21:42 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-12-26 22:12:09 UTC
Type: ---


Attachments (Terms of Use)
File: anaconda-tb (312.25 KB, text/plain)
2014-12-25 15:31 UTC, cp361
no flags Details
File: anaconda.log (13.38 KB, text/plain)
2014-12-25 15:31 UTC, cp361
no flags Details
File: environ (614 bytes, text/plain)
2014-12-25 15:31 UTC, cp361
no flags Details
File: journalctl (160.45 KB, text/plain)
2014-12-25 15:31 UTC, cp361
no flags Details
File: lsblk_output (2.68 KB, text/plain)
2014-12-25 15:31 UTC, cp361
no flags Details
File: nmcli_dev_list (1.47 KB, text/plain)
2014-12-25 15:31 UTC, cp361
no flags Details
File: os_info (377 bytes, text/plain)
2014-12-25 15:31 UTC, cp361
no flags Details
File: program.log (11.18 KB, text/plain)
2014-12-25 15:31 UTC, cp361
no flags Details
File: storage.log (111.42 KB, text/plain)
2014-12-25 15:31 UTC, cp361
no flags Details
File: ifcfg.log (4.99 KB, text/plain)
2014-12-25 15:31 UTC, cp361
no flags Details

Description cp361 2014-12-25 15:31:08 UTC
Description of problem:
attempting to install from iso 
system comes up and I clisk on 'install to hard drive
and it comes up right away I can't install

Version-Release number of selected component:
anaconda-core-21.48.21-1.fc21.x86_64

The following was filed automatically by anaconda:
anaconda 21.48.21-1 exception report
Traceback (most recent call first):
  File "/usr/lib64/python2.7/site-packages/pyanaconda/packaging/livepayload.py", line 75, in setup
    if not stat.S_ISBLK(os.stat(osimg.path)[stat.ST_MODE]):
  File "/usr/lib64/python2.7/site-packages/pyanaconda/packaging/__init__.py", line 1236, in _runThread
    payload.setup(storage, instClass)
  File "/usr/lib64/python2.7/threading.py", line 766, in run
    self.__target(*self.__args, **self.__kwargs)
  File "/usr/lib64/python2.7/site-packages/pyanaconda/threads.py", line 227, in run
    threading.Thread.run(self, *args, **kwargs)
AttributeError: 'NoneType' object has no attribute 'path'

Additional info:
cmdline:        /usr/bin/python  /sbin/anaconda --liveinst --method=livecd:///dev/mapper/live-base
cmdline_file:   BOOT_IMAGE=vmlinuz0 initrd=initrd0.img root=live:CDLABEL=Fedora-Live-WS-x86_64-21-5 rootfstype=auto ro rd.live.image quiet  rhgb rd.luks=0 rd.md=0 rd.dm=0 
executable:     /sbin/anaconda
hashmarkername: anaconda
kernel:         3.17.4-301.fc21.x86_64
other involved packages: python-libs-2.7.8-7.fc21.x86_64
product:        Fedora"
release:        Fedora release 21 (Twenty One)
type:           anaconda
version:        Fedora

Comment 1 cp361 2014-12-25 15:31:11 UTC
Created attachment 973032 [details]
File: anaconda-tb

Comment 2 cp361 2014-12-25 15:31:11 UTC
Created attachment 973033 [details]
File: anaconda.log

Comment 3 cp361 2014-12-25 15:31:12 UTC
Created attachment 973034 [details]
File: environ

Comment 4 cp361 2014-12-25 15:31:13 UTC
Created attachment 973035 [details]
File: journalctl

Comment 5 cp361 2014-12-25 15:31:14 UTC
Created attachment 973036 [details]
File: lsblk_output

Comment 6 cp361 2014-12-25 15:31:15 UTC
Created attachment 973037 [details]
File: nmcli_dev_list

Comment 7 cp361 2014-12-25 15:31:16 UTC
Created attachment 973038 [details]
File: os_info

Comment 8 cp361 2014-12-25 15:31:17 UTC
Created attachment 973039 [details]
File: program.log

Comment 9 cp361 2014-12-25 15:31:18 UTC
Created attachment 973040 [details]
File: storage.log

Comment 10 cp361 2014-12-25 15:31:19 UTC
Created attachment 973041 [details]
File: ifcfg.log

Comment 11 cp361 2014-12-25 15:34:00 UTC
Another user experienced a similar problem:

attempting to perform an install

cmdline:        /usr/bin/python  /sbin/anaconda --liveinst --method=livecd:///dev/mapper/live-base
cmdline_file:   BOOT_IMAGE=vmlinuz0 initrd=initrd0.img root=live:CDLABEL=Fedora-Live-WS-x86_64-21-5 rootfstype=auto ro rd.live.image quiet  rhgb rd.luks=0 rd.md=0 rd.dm=0 
hashmarkername: anaconda
kernel:         3.17.4-301.fc21.x86_64
other involved packages: python-libs-2.7.8-7.fc21.x86_64
package:        anaconda-core-21.48.21-1.fc21.x86_64
packaging.log:  
product:        Fedora"
reason:         AttributeError: 'NoneType' object has no attribute 'path'
release:        Fedora release 21 (Twenty One)
version:        Fedora

Comment 12 Vojtech Trefny 2014-12-26 22:12:09 UTC

*** This bug has been marked as a duplicate of bug 1169001 ***

Comment 13 David Shea 2015-06-17 21:42:51 UTC
*** Bug 1206098 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.