Bug 1178481

Summary: Hedgewars won't build on arm
Product: [Fedora] Fedora Reporter: Bruno Wolff III <bruno>
Component: hedgewarsAssignee: Bruno Wolff III <bruno>
Status: CLOSED RAWHIDE QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: unspecified Docs Contact:
Priority: unspecified    
Version: rawhideCC: bruno, costamagnagianfranco, hdegoede
Target Milestone: ---   
Target Release: ---   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2015-01-10 18:47:32 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
Bug Depends On:    
Bug Blocks: 245418    

Description Bruno Wolff III 2015-01-04 08:27:18 UTC
Description of problem:
The arm build fails with:
[ 15%] uRender.pas(988,5) Fatal: Internal error 200310121
The full build log is at:
https://kojipkgs.fedoraproject.org//work/tasks/504/8520504/build.log

I don't want to stick with hedgewars 0.9.18, since people need to run the same version and people are using 0.9.21 now. So for now, I am going to disable the arm builds. I am not in a good position to figure out what is causing this.

Comment 1 Bruno Wolff III 2015-01-04 18:28:28 UTC
I got some help with this in comment 42 of bug 969399 (https://bugzilla.redhat.com/show_bug.cgi?id=969399#c43):
 Gianfranco 2015-01-04 12:06:24 CST

Hi Bruno, I had two different build issues on arm, the patches are there
https://sources.debian.net/src/hedgewars/0.9.21-3/debian/patches/0001-Fix-arm-build-failures.patch/

https://sources.debian.net/src/hedgewars/0.9.21-3/debian/patches/0001-Use-ghc-return-value-instead-of-looking-for-the-stde.patch/

(the second is because ghc writes on stderr when different llvm is detected)

Comment 2 Gianfranco 2015-01-05 17:18:15 UTC
ust FYI everything has been merged in upstream/master (one fix is still under review)
I will ask to release a 0.9.21.1 with all the fixes :)