Bug 969399 - hedgewars-0.9.21.1 is available
Summary: hedgewars-0.9.21.1 is available
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: hedgewars
Version: rawhide
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Bruno Wolff III
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 1177944 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2013-05-31 11:14 UTC by Upstream Release Monitoring
Modified: 2015-02-17 16:18 UTC (History)
10 users (show)

Fixed In Version: hedgewars-0.9.21.1-1.fc20
Doc Type: Enhancement
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-01-20 21:02:01 UTC


Attachments (Terms of Use)
Debugging output (2.79 KB, text/plain)
2015-01-05 03:59 UTC, Bruno Wolff III
no flags Details

Description Upstream Release Monitoring 2013-05-31 11:14:28 UTC
Latest upstream release: 0.9.19
Current version in Fedora Rawhide: 0.9.18
URL: http://download.gna.org/hedgewars/

Please consult the package updates policy before you issue an update to a stable branch: https://fedoraproject.org/wiki/Updates_Policy

More information about the service that created this bug can be found at:
https://fedoraproject.org/wiki/Upstream_release_monitoring

Comment 1 Bruno Wolff III 2013-06-02 15:23:00 UTC
I am starting to work on this. If anyone else is looking at this be aware that they did a source archive rebuild with a lower version number that isn't pointed to anywhere, but is in the download files directory. This rebuild includes some new commits from the source repository.

Comment 2 Upstream Release Monitoring 2013-06-03 12:33:58 UTC
Latest upstream release: 0.9.19.1
Current version in Fedora Rawhide: 0.9.18
URL: http://download.gna.org/hedgewars/

Please consult the package updates policy before you issue an update to a stable branch: https://fedoraproject.org/wiki/Updates_Policy

More information about the service that created this bug can be found at:
https://fedoraproject.org/wiki/Upstream_release_monitoring

Comment 3 Bruno Wolff III 2013-06-03 14:53:01 UTC
A new 0.9.19.1 was spun. So that will probably be the one we want for the update.

Comment 4 Gianfranco 2013-06-06 14:08:16 UTC
No Bruno, they fixed so much in 0.9.19 branch after the .1 release, there is a .2 they gave directly to me, they didn't upload yet

it is better to grab it from here
https://code.google.com/p/hedgewars/source/list?name=0.9.19
and make package it, or to grab from my orig.tar.gz
https://code.launchpad.net/~costamagnagianfranco/+archive/costamagnagianfranco-ppa/+files/hedgewars_0.9.19.2.orig.tar.bz2

my is two commits behind of the 0.9.19 branch, I didn't repackage it because of
 two really little changes in the .19 branch

Comment 5 Bruno Wolff III 2013-06-06 14:28:07 UTC
Thanks for the heads up. I'll just wait for the .2 release to be available before I actually put out a new package.

Comment 6 Bruno Wolff III 2013-06-11 12:45:41 UTC
I haven't seen 0.9.19.2 source show up yet on the official download page nor have I seen a later tag. It's been a week since the respin of 0.9.19.1, so I am planning to use 0.9.19.1 as I get time to work on packaging it. I can do an update later when there is a new release.

Comment 7 Gianfranco 2013-06-11 14:02:31 UTC
They gave .3 to me just with dropbox
https://dl.dropboxusercontent.com/u/24468/hedgewars-src-0.9.19.3.tar.bz2

anyway ju can just build the archive yourself with this branch
https://code.google.com/p/hedgewars/source/list?name=0.9.19
and calling cpackvars.cmake

Comment 8 Bruno Wolff III 2013-06-11 15:20:19 UTC
They still haven't tagged a 0.9.19.3. The only tag is 0.9.19-release. I can still use the latest release to work out changes to the lua patch and by the time I get that straightened out there may be a new official release.

Comment 9 Gianfranco 2013-06-11 15:32:32 UTC
I don't think they will tag any 0.9.19.3, you just need to grab the latest .19 branch

Comment 10 Upstream Release Monitoring 2013-06-19 17:59:35 UTC
Latest upstream release: 0.9.19.3
Current version/release in Fedora Rawhide: 0.9.18-7.fc20
URL: http://download.gna.org/hedgewars/

Please consult the package updates policy before you issue an update to a stable branch: https://fedoraproject.org/wiki/Updates_Policy

More information about the service that created this bug can be found at:
https://fedoraproject.org/wiki/Upstream_release_monitoring

Comment 11 Bruno Wolff III 2013-06-23 06:20:36 UTC
0.9.19 requires physfs 2.1.0 and we only have 2.0.3. So this is going to wait until that physfs gets updated. This also will make it harder to backport 0.9.19 to released versions of Fedora.

Comment 12 Bruno Wolff III 2013-06-23 06:37:49 UTC
And even better news, physfs 2.1.0 hasn't actually been released yet.

Comment 13 Gianfranco 2013-06-23 07:19:39 UTC
Sorry Bruno, why don't just use the embedded library inside hedgewars?

Comment 14 Bruno Wolff III 2013-06-23 15:12:16 UTC
Because bundled libraries are prohibited in Fedora. (Though usually they are old versions, not unreleased ones.) I'm not going to push the physfs maintainer to push out a development release, especially to older releases of Fedora. I am also not to sure that I have a good argument for a bundling exception from FESCO.

When I get time I might try to figure out how hard it would be to get it to work around things to work with 2.0.3. But what little time I have left this weekend is going to be trying to get 0.9.18 to build again with the new version of ghc.

Comment 15 Upstream Release Monitoring 2013-12-26 12:43:16 UTC
Latest upstream release: 0.9.20
Current version/release in Fedora Rawhide: 0.9.18-11.fc21
URL: http://download.gna.org/hedgewars/

Please consult the package updates policy before you issue an update to a stable branch: https://fedoraproject.org/wiki/Updates_Policy

More information about the service that created this bug can be found at:
https://fedoraproject.org/wiki/Upstream_release_monitoring

Comment 16 Upstream Release Monitoring 2014-01-01 19:56:30 UTC
Latest upstream release: 0.9.20.3
Current version/release in Fedora Rawhide: 0.9.18-11.fc21
URL: http://download.gna.org/hedgewars/

Please consult the package updates policy before you issue an update to a stable branch: https://fedoraproject.org/wiki/Updates_Policy

More information about the service that created this bug can be found at:
https://fedoraproject.org/wiki/Upstream_release_monitoring

Comment 17 Upstream Release Monitoring 2014-01-04 09:36:06 UTC
Latest upstream release: 0.9.20.4
Current version/release in Fedora Rawhide: 0.9.18-11.fc21
URL: http://download.gna.org/hedgewars/

Please consult the package updates policy before you issue an update to a stable branch: https://fedoraproject.org/wiki/Updates_Policy

More information about the service that created this bug can be found at:
https://fedoraproject.org/wiki/Upstream_release_monitoring

Comment 18 Upstream Release Monitoring 2014-01-09 09:36:17 UTC
Latest upstream release: 0.9.20.5
Current version/release in Fedora Rawhide: 0.9.18-11.fc21
URL: http://download.gna.org/hedgewars/

Please consult the package updates policy before you issue an update to a stable branch: https://fedoraproject.org/wiki/Updates_Policy

More information about the service that created this bug can be found at:
https://fedoraproject.org/wiki/Upstream_release_monitoring

Comment 19 Brallan Jesús Aguilar Rivera 2014-01-12 08:54:07 UTC
Hello, I hope you can solve this frustrating problem. I think that they would not release new updates with packages under development.

Comment 20 Gianfranco 2014-01-12 12:01:16 UTC
I think using 2.0.3 and patching it can be really easy, since hedgewars uses only three function of the development libray (not available in 2.0.3)
http://code.google.com/p/hedgewars/issues/detail?id=765&thanks=765&ts=1389527977

can you guys please work on it?

Comment 21 Bruno Wolff III 2014-01-12 13:45:20 UTC
It's not clear what we want to do here. It might be worth encouraging the physfs project to make a real 2.1 release. (Even then there could be significant work getting the 2.1 into Fedora if it isn't backwards compatible.)
We could look into packaging both the 2.0.3 and 2.1 (prelease) versions. This again would be significant work, but it could be done.
The Fedora physfs maintainer would be a good person to discuss the previous two options with.
We could look at what is new in 2.1 that is being used in Hedgewars (which you have done some research on) and try to do a minimal patch to include just those extra functions and use 2.0.3 for the rest.
We could wait until 2.1 is available in Fedora or until hedgewars provides a conditional build that works with 2.0.3. (This is what I have been doing.)
We could ask for permission to bundle 2.1. (I don't like this. I think we'd be better off making 2.0.3 and 2.1 available at the same time for all of Fedora.)

I don't think I personally will have time to try to do a wrapper (or recreate the 2.1 functions) needed soon. There is other Fedora stuff that is higher priority for me. But if someone else did most of the leg work on this I could help get those changes incorporated into Fedora in a timely manner.

Comment 22 Gianfranco 2014-01-16 11:11:20 UTC
Hi Bruno, the wrapper is here!
http://code.google.com/p/hedgewars/source/detail?r=3858d99476f5

Can you please help in testing it?

I really would like to upload this on debian too

Comment 23 Gianfranco 2014-01-16 12:04:43 UTC
NOTE: this version doesn't work with symlinks, in debian we symlink fonts and this doesn't work, please follow up on irc or on the issues

Comment 24 Gianfranco 2014-01-17 22:11:40 UTC
In the last few commits they added a new CMake Variable, now you can use system fonts, saving a bunch of space when building hedgewars
this commit is a good start, but the previous and next gives you a complete patch.
https://code.google.com/p/hedgewars/source/detail?r=8455993a7a1b51b38a84693817966180c0c2fded

Comment 25 Gianfranco 2014-01-20 13:16:17 UTC
You can cherry pick those two patches
http://anonscm.debian.org/gitweb/?p=collab-maint/hedgewars.git;a=blob;f=debian/patches/using_system_fonts.patch;h=d218444e2530a7a3629752277309932c4429cacc;hb=36da3f112540150b1e3c451615db91fccb9bfb9a
http://anonscm.debian.org/gitweb/?p=collab-maint/hedgewars.git;a=blob;f=debian/patches/using_system_physfs.patch;h=de0763339abc319601c86d24665244e28a4f7667;hb=36da3f112540150b1e3c451615db91fccb9bfb9a

and you will be able to use system physfs and system fonts
with something like this

-DCMAKE_INSTALL_PREFIX=/usr/lib/hedgewars -DDATA_INSTALL_DIR=/usr/share/games/hedgewars -DCMAKE_BUILD_TYPE=RELEASE -DPHYSFS_SYSTEM=ON -DFONTS_DIRS='/usr/share/fonts/truetype/wqy;/usr/share/fonts/truetype/dejavu'

Comment 26 Gianfranco 2014-03-03 18:49:14 UTC
ping!

Comment 27 Bruno Wolff III 2014-03-03 18:59:53 UTC
Pong.

It's on my list, but I still haven't carved out a block of time to work on this yet.

Comment 28 Gianfranco 2014-03-03 19:03:16 UTC
Unfortunately I really would like to help, but I don't know how to contribute, moreover I'm not good at fedora packaging scripts... :(

Comment 29 Bruno Wolff III 2014-03-03 19:11:13 UTC
You have helped. Without digging up the stuff for using the old phyfs library, I wouldn't even be thinking of upgrading hedgewars right now. The information just didn't get to me at a good time. But the next significant (more than a couple hours) fedora  packaging work I do will be hedgewars.

Comment 30 Ignacio Casal Quinteiro (nacho) 2014-04-30 15:41:25 UTC
any news on this?

Comment 31 Brallan Jesús Aguilar Rivera 2014-04-30 15:50:11 UTC
(In reply to Ignacio Casal Quinteiro (nacho) from comment #30)
> any news on this?

The last time I asked, the assigned replied me that developers are working on getting a newer hedgewars to Fedora.

Comment 32 Bruno Wolff III 2014-04-30 15:51:47 UTC
I grabbed the latest source and started doing some of the work a few weeks ago, but have had distractions the last few weekends. I need to fix up some old patches and test the new ones yet. So it's several hours of concentrated work assuming nothing major crops up. I should start making progress again soon.

Comment 33 fussel 2014-05-10 19:25:05 UTC
What is the status of the package? I am trying to play the game with some friends for about 3 month, and have to boot Windows, to play hedgewars, because 0.9.18 is not compatible with 0.9.20-5.

Comment 34 Brallan Jesús Aguilar Rivera 2014-08-22 08:32:34 UTC
Hello. Is there any news?

Comment 35 Ignacio Casal Quinteiro (nacho) 2014-12-10 10:11:24 UTC
ping

Comment 36 Geowany Galdino 2014-12-29 21:12:59 UTC
Hi guys! I've had success in building from sources. We won a Christmas gift from hedgewars developers, the version 0.9.21 (http://hedgewars.org/node/5897). The steps are:

1. Download the sources. I prefer download a torrent (and share it):

http://hedgewars.org/download/hedgewars-src-0.9.21.tar.bz2.torrent


2. Hence, to build we need to install some dependencies:

# yum install make automake gcc gcc-c++ mingw64-qt-qmake qt-devel SDL-devel SDL_net-devel SDL_mixer-devel SDL_image-devel SDL_ttf-devel fpc lua-devel physfs-devel libpng-devel ffmpeg-devel freeglut-devel

3. With the tarball downloaded and copyed  in /usr/local/src/ was enough unpack it:

# tar -jxvf hedgewars-src-0.9.21.tar.bz2

4. Sign in directory:

# cd hedgewars-src-0.9.21/

5. Use cmake:

# cmake -DNOSERVER=1

If errors occur, use the following command (tip from user "sheepluva" at channel #hedgewars@irc.freenode.org), 'cause fedora only has an unsupported version of lua:

# cmake -DNOSERVER=1 -DLUA_SYSTEM=0

6. Compile, install and enjoy this great game!

# make install

Happy 2015 to all !!!

Comment 37 Bruno Wolff III 2014-12-31 15:52:17 UTC
I'm going to have time to tak another look at this over the next few days.

Comment 38 Bruno Wolff III 2014-12-31 15:52:47 UTC
*** Bug 1177944 has been marked as a duplicate of this bug. ***

Comment 39 Bruno Wolff III 2015-01-03 19:18:32 UTC
It looks like I'll probably be able to get 0.9.21 to build. The libphysfs issue seems to be fixed. Working around not having bytestring-show didn't take much tweaking. I'm up to seeing if I can get the lua 5.2 patch working again. The compile options still have to be fixed up but that is pretty minor. There are also a couple of new files that get installed. And of course it needs to be tested to make sure it works in addition to building.

Comment 40 Bruno Wolff III 2015-01-03 20:09:38 UTC
We have a lua 5.1 compatibility library that looks like it will save me from having to redo the lua 5.2 patch. Assuming that really works (the server does build), things are looking pretty good for getting 0.9.21 out this weekend.

Comment 41 Bruno Wolff III 2015-01-04 17:23:54 UTC
I have a rawhide build now. arm was excluded because it didn't build there. The game server seems to work. The game itself can't start a game on the one machine I have tested it on. I am not sure if this is video card related or some problem with the build.

Comment 42 Gianfranco 2015-01-04 18:06:24 UTC
Hi Bruno, I had two different build issues on arm, the patches are there
https://sources.debian.net/src/hedgewars/0.9.21-3/debian/patches/0001-Fix-arm-build-failures.patch/

https://sources.debian.net/src/hedgewars/0.9.21-3/debian/patches/0001-Use-ghc-return-value-instead-of-looking-for-the-stde.patch/

(the second is because ghc writes on stderr when different llvm is detected)

Comment 43 Bruno Wolff III 2015-01-04 18:23:41 UTC
Thanks.
The first one looks like what I am seeing now. I'll look at including the second as well as I will probably hit it too.
I'll note this in the arm failure bug.
My higher priority right now is figuring out why I am getting an exit code 217 when trying to play a game. I suspect lua is fubared because there is some weirdness in lua-compat-devel. I want to try to confirm that.

Comment 44 Gianfranco 2015-01-04 18:31:00 UTC
Hi Bruno, the second patch is "debian/arm" specific, because ghc was built with an llvm version, and that version got upgraded without a rebuild.

However the patch is good and already merged upstream.

For the lua stuff I don't really know, are you in contact with upstream developers? they might have some hints.

https://github.com/hedgewars/hw/pull/27

https://github.com/hedgewars/hw/pull/26

cheers,

G.

Comment 45 Bruno Wolff III 2015-01-04 19:52:53 UTC
It looks like there might have been a lua problem with mixing 5.1 and 5.2. The check for include path didn't have lua-5.1 as a possible suffix. I'll be testing this shortly.

Comment 46 Bruno Wolff III 2015-01-04 20:22:04 UTC
I don't think lua is the cause of the issue I am seeing now, though I think I have fixed a potential problem there.
I am seeing: 
Object::disconnect: Unexpected null parameter
QCoreApplication::postEvent: Unexpected null receiver
everytime I start a game in the terminal window while still getting the exit code 217 error message in hedgewars.

Comment 47 Bruno Wolff III 2015-01-04 23:12:05 UTC
I tested this on f21 with a scratch build and had the same issue, though the exit code was 1 instead of 217. I'll see if I can test this on f20.

Comment 48 Bruno Wolff III 2015-01-05 03:59:36 UTC
Created attachment 976175 [details]
Debugging output

It looks like the problem is likely physfs blocking following the symbolic links for fonts. (Hedgewars normally includes its own fonts, but in Fedora we replace the copies with links to the fonts provided by font packages.)

Comment 49 Bruno Wolff III 2015-01-05 04:34:09 UTC
I confirmed that the symlinked font files are interacting badly with physfs. Placing a copy of the fonts where they had been replaced by symlinks, gets things to work.
Fixing this shouldn't be too bad.

Comment 50 Bruno Wolff III 2015-01-05 06:07:58 UTC
I have hedgewars building and working locally and have fired off another rawhide build that should work.
I'll fix the arm stuff soon and after that I build copies for f21 and f20 since people need the up to date version to play with most other people.

Comment 51 Gianfranco 2015-01-05 09:42:24 UTC
I wasn't aware of your  symlink of fonts.

In debian I fixed already this issue, can you please follow my path or describe yours?

Since I got most of the patches upstream my path can be the "best" one :)

this is the configure script

# our debian dejavu directory changed, so I use readlink for easier backports
DEJAVU_DIRECTORY := $(shell dirname `readlink -f /usr/share/fonts/truetype/ttf-dejavu/DejaVuSans-Bold.ttf`)


# this gets hedgewars working where there is no fpc available (e.g. arm64), needs clang and glew, EXPERIMENTAL!
ifeq ($(shell dpkg-query --status fpc |grep -o Package), Package)
 BUILD_ENGINE_C := NO
else
 BUILD_ENGINE_C := YES
endif

HEDGEWARS_OPTIONS= \
 -DCMAKE_INSTALL_PREFIX=/usr/lib/hedgewars \
 -DDATA_INSTALL_DIR=/usr/share/games/hedgewars \
 -DCMAKE_BUILD_TYPE=RELEASE -DPHYSFS_SYSTEM=ON \
 -DFONTS_DIRS='/usr/share/fonts/truetype/wqy;$(DEJAVU_DIRECTORY)' \
 -DNOVERSIONINFOUPDATE=1 \
 -DBUILD_ENGINE_C=$(BUILD_ENGINE_C)



to get it build on arm64 (if you don't have fpc) you might need to disable fstack-protector and to cherry-pick the font link lua patch.
https://sources.debian.net/src/hedgewars/0.9.21-3/debian/patches/disable-fstack-protector.patch/
https://sources.debian.net/src/hedgewars/0.9.21-3/debian/patches/0001-Fix-segfault-when-BUILD_ENGINE_C-ON-and-FONTS_DIR-is.patch/

Comment 52 Gianfranco 2015-01-05 09:52:32 UTC
BTW why do you remove fonts?
they shouldn't be installed if you pass the correct FONTS_DIRS, because of the code

if (MISSINGFONTFILES)
    install(FILES ${MISSINGFONTFILES} DESTINATION ${SHAREPATH}Data/Fonts)
endif()


do you have some missing fonts? so you shouldn't remove them, otherwise it will likely segfault...

Comment 53 Gianfranco 2015-01-05 12:31:58 UTC
oh another nitpick
https://github.com/hedgewars/hw/blob/master/share/hedgewars/Data/misc/hedgewars.desktop
https://github.com/hedgewars/hw/blob/master/share/hedgewars.appdata.xml

they are shipped in the source tree, can you please take from there instead of shipping your own files?

they seems to be a little outdated, and something is even wrong :)
e.g.
"<url type="homepage">http://http://hedgewars.org/</url>"

Comment 54 Bruno Wolff III 2015-01-05 15:10:18 UTC
I remove fonts as a safe guard. FONT_DIRS works correctly, so the removes do nothing. Probably what I should do is put in code that will make the build fail if any fonts show up rather than to try and remove two that I know about. (The danger is new ones getting added without me noticing.)

Yes, I can look at getting appdata from upstream.

Do you have the ability to test arm packages? Otherwise I can only see if things build or not.

I am seeing a problem with the volume adjustment not working. If that is still happening when the other stuff gets fixed, I'll file a Fedora bug for it for tracking.

Comment 55 Bruno Wolff III 2015-01-05 15:11:32 UTC
Oh, and thanks for doing the review. It is easy to miss things and having a second pair of eyes is helpful.

Comment 56 Gianfranco 2015-01-05 15:48:50 UTC
ok wonderful, I hope we can sync hedgewars more closely from debian and fedora, just to don't spare time anymore ;)

>I remove fonts as a safe guard. FONT_DIRS works correctly, so the removes do nothing. Probably what I should do is put in code that will make the build fail if any fonts show up rather than to try and remove two that I know about. (The danger is new ones getting added without me noticing.)

seems legit :)

>Do you have the ability to test arm packages? Otherwise I can only see if things build or not.

I remember I tested on rpi a while ago... it was working correctly, and I didn't get any arm bug reports so far...

>I am seeing a problem with the volume adjustment not working. If that is still happening when the other stuff gets fixed, I'll file a Fedora bug for it for tracking.

something new for me!

quick look to patches:

hedgewars-lua-search.patch --> now upstream'd
hedgewars-multilib.patch --> why do you need it?
hedgewars-no-bytestring.patch --> why do you still need it?
if you don't plan to add bytestring to fedora I might consider asking upstream to merge this one...

spec file:
ExcludeArch: ppc64 s390 s390x %{arm}

will you enable arm again then?


>%ifarch %{arm}
>%cmake -DMINIMAL_FLAGS=1 -DNOVIDEOREC=1 -DFONTS_DIRS="/usr/share/fonts/wqy-zenhei;/usr/share/fonts/dejavu" .
>%else
>%cmake -DMINIMAL_FLAGS=1 -DNOVIDEOREC=1 -DGHFLAGS=-dynamic -DFONTS_DIRS="/usr/share/fonts/wqy-zenhei;/usr/share/fonts/dejavu" .
>%endif

I don't get the MINIMAL_FLAGS and GHCFLAGS dynamic one...

>%{_libdir}/libphyslayer.so

what does this mean?

Comment 57 Bruno Wolff III 2015-01-05 16:30:12 UTC
The multilib patch is because on x86_64 /usr/lib is for 32 bit libraries and /usr/lib64 is for 64 bit libraries. physfslayer needs to go into /usr/lib64 .
$LIB_SUFFIX will either be empty or 64 depending on the arch.

I plan to re-enable arm shortly. Probably this week, maybe tonight.

%{_libdir}/libphyslayer.so just declares a file to be packaged. As far as I can tell physfslayer is a hedgewars specific helper library for physfs.

The correct bytestring package may eventually get added to Fedora. I don't think it is blocked, just that no one has spent time on it yet. So I don't think we want to upstream that one yet.

The MINIMAL_FLAGS cuts back on the compilation flags set by hedgewars so that they don't override ones standard for Fedora without a good reason. The -dynamic option is for dynamic linking of ghc modules. I wouldn't upstream that. -dynamic isn't real mainstream for ghc yet (or at least the last time I checked).

Comment 58 Gianfranco 2015-01-05 17:27:18 UTC
>The multilib patch is because on x86_64 /usr/lib is for 32 bit libraries and >/usr/lib64 is for 64 bit libraries. physfslayer needs to go into /usr/lib64 .
>$LIB_SUFFIX will either be empty or 64 depending on the arch.

this is different in debian... I mean, if that library is meant to be used only by hedgewars it should be in /usr/lib/hedgewars/lib

ls /usr/lib/hedgewars/lib/lib*
/usr/lib/hedgewars/lib/libavwrapper.so	/usr/lib/hedgewars/lib/libphyslayer.so

ldd /usr/lib/hedgewars/bin/hedgewars
	libphyslayer.so => /usr/lib/hedgewars/bin/../lib/libphyslayer.so (0x00007fca29435000)


so no other programs gets wrongly linked against it :)

but "de gustibus" ;)

>%{_libdir}/libphyslayer.so just declares a file to be packaged. As far as I >can tell physfslayer is a hedgewars specific helper library for physfs.

yes I noticed it after posting, I was confused because we also have avwrapper (BTW can't still it be packaged?)

>The correct bytestring package may eventually get added to Fedora. I don't >think it is blocked, just that no one has spent time on it yet. So I don't >think we want to upstream that one yet.

ack thanks

>The MINIMAL_FLAGS cuts back on the compilation flags set by hedgewars so that >they don't override ones standard for Fedora without a good reason.

I don't think they override anything... at least I don't see in my logs
https://buildd.debian.org/status/fetch.php?pkg=hedgewars&arch=amd64&ver=0.9.21-3&stamp=1419958917

>The -dynamic option is for dynamic linking of ghc modules. I wouldn't upstream >that. -dynamic isn't real mainstream for ghc yet (or at least the last time I >checked).

ok, so I won't take that one for debian :)

thanks!

Comment 59 Gianfranco 2015-01-06 21:33:30 UTC
http://download.gna.org/hedgewars/hedgewars-src-0.9.21.1.tar.bz2

Just FYI, there is a new tarball with the arm/ghc/lib fixes :)

Comment 60 Upstream Release Monitoring 2015-01-09 08:47:54 UTC
Latest upstream release: 0.9.21.1
Current version/release in Fedora Rawhide: 0.9.21-3.fc22
URL: http://download.gna.org/hedgewars/

Please consult the package updates policy before you issue an update to a stable branch: https://fedoraproject.org/wiki/Updates_Policy


More information about the service that created this bug can be found at:
https://fedoraproject.org/wiki/Upstream_release_monitoring Soon this service will be implemented by a new system: https://release-monitoring.org/
It will require to manage monitored projects via a new web interface. Please make yourself familiar with the new system to ease the transition.

Comment 61 Bruno Wolff III 2015-01-10 06:29:18 UTC
I have a build of 0.9.21.1 for rawhide now. It is supposed to take care of everything I was planning to address at this time. I need to do some testing tomorrow. If things look good, I'll do f21 and f20 builds.

Comment 62 Fedora Update System 2015-01-10 19:36:09 UTC
hedgewars-0.9.21.1-1.fc21 has been submitted as an update for Fedora 21.
https://admin.fedoraproject.org/updates/hedgewars-0.9.21.1-1.fc21

Comment 63 Fedora Update System 2015-01-10 19:36:58 UTC
hedgewars-0.9.21.1-1.fc20 has been submitted as an update for Fedora 20.
https://admin.fedoraproject.org/updates/hedgewars-0.9.21.1-1.fc20

Comment 64 Fedora Update System 2015-01-11 10:57:06 UTC
Package hedgewars-0.9.21.1-1.fc21:
* should fix your issue,
* was pushed to the Fedora 21 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing hedgewars-0.9.21.1-1.fc21'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2015-0558/hedgewars-0.9.21.1-1.fc21
then log in and leave karma (feedback).

Comment 65 Fedora Update System 2015-01-20 21:02:01 UTC
hedgewars-0.9.21.1-1.fc21 has been pushed to the Fedora 21 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 66 Fedora Update System 2015-01-20 21:06:49 UTC
hedgewars-0.9.21.1-1.fc20 has been pushed to the Fedora 20 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 67 Upstream Release Monitoring 2015-02-17 16:18:59 UTC
bruno's hedgewars-0.9.21.1-3.fc23 completed http://koji.fedoraproject.org/koji/buildinfo?buildID=612166


Note You need to log in before you can comment on or make changes to this bug.