Bug 1196088

Summary: FTBFS: No Package found for libkdeedu-devel >= 14.12.2 when building kalzium
Product: [Fedora] Fedora Reporter: Dominik 'Rathann' Mierzejewski <dominik>
Component: kalziumAssignee: Than Ngo <than>
Status: CLOSED RAWHIDE QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: unspecified Docs Contact:
Priority: unspecified    
Version: rawhideCC: jreznik, kevin, ltinkl, rdieter, rnovacek, than
Target Milestone: ---   
Target Release: ---   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2015-06-16 13:41:35 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Bug Depends On: 1195025    
Bug Blocks:    

Description Dominik 'Rathann' Mierzejewski 2015-02-25 09:45:01 UTC
Description of problem:
kalzium fails to build due to BR on a non-existent libkdeedu-devel version.

Version-Release number of selected component (if applicable):
14.12.2-1.fc23

How reproducible:
Always.

Steps to Reproduce:
1. Try rebuilding current git master

Actual results:
No Package found for libkdeedu-devel >= 14.12.2

Expected results:
Should build successfully.

Additional info:
Once that BR is relaxed, the build fails with:
/bin/ld: modwrap.o: relocation R_X86_64_32 against `.rodata.str1.1' can not be used when making a shared object; recompile with -fPIC
modwrap.o: error adding symbols: Bad value
collect2: error: ld returned 1 exit status

Comment 1 Rex Dieter 2015-02-25 17:25:20 UTC
That object is generated by ocaml,

[ 50%] Generating modwrap.o
cd src && /usr/bin/ocamlopt -I /usr/lib64/ocaml/facile -c /builddir/build/BUILD/kalzium-14.12.2/src/solver/modwrap.c -o /builddir/build/BUILD/kalzium-14.12.2/x86_64-redhat-linux-gnu/src/modwrap.o

tentatively marking depending on ocaml bug #1195025 (which is similar, but not exactly the same).

Comment 2 Than Ngo 2015-02-26 21:05:13 UTC
i'm working on this.

Comment 3 Rex Dieter 2015-06-16 13:41:35 UTC
kalzium has built fine for awhile now, closing