Bug 1195025 - Ocaml libasmrun.a needs to be compiled with -fPIC
Summary: Ocaml libasmrun.a needs to be compiled with -fPIC
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: ocaml
Version: rawhide
Hardware: x86_64
OS: Linux
unspecified
medium
Target Milestone: ---
Assignee: Richard W.M. Jones
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks: 1196088
TreeView+ depends on / blocked
 
Reported: 2015-02-22 04:27 UTC by Jerry James
Modified: 2015-06-16 12:56 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-06-16 12:56:59 UTC
Type: Bug


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
OCaml 6693 0 None None None Never

Description Jerry James 2015-02-22 04:27:17 UTC
Description of problem:
See my latest attempt to build why3:

http://koji.fedoraproject.org/koji/buildinfo?buildID=613997

Version-Release number of selected component (if applicable):
ocaml-4.02.1-1.fc23.x86_64

How reproducible:
Only tried once.

Steps to Reproduce:
1. Attempt to build why3 in Rawhide
2.
3.

Actual results:
Linking  bin/why3.opt
/usr/bin/ld: /usr/lib64/ocaml/libasmrun.a(startup.o): relocation R_X86_64_32 against `.rodata.str1.1' can not be used when making a shared object; recompile with -fPIC
/usr/lib64/ocaml/libasmrun.a: error adding symbols: Bad value
collect2: error: ld returned 1 exit status
File "caml_startup", line 1:
Error: Error during linking
Makefile:451: recipe for target 'bin/why3.opt' failed
make: *** [bin/why3.opt] Error 2

Expected results:
Successful link.

Additional info:

Comment 1 Rex Dieter 2015-02-25 17:27:21 UTC
Similar (but not exactly the same), getting kalzium FTBFS due to:

[ 50%] Generating modwrap.o
cd src && /usr/bin/ocamlopt -I /usr/lib64/ocaml/facile -c /builddir/build/BUILD/kalzium-14.12.2/src/solver/modwrap.c -o /builddir/build/BUILD/kalzium-14.12.2/x86_64-redhat-linux-gnu/src/modwrap.o

and subsequently trying to link it into an executable:

/bin/ld: modwrap.o: relocation R_X86_64_32 against `.rodata.str1.1' can not be used when making a shared object; recompile with -fPIC
modwrap.o: error adding symbols: Bad value
collect2: error: ld returned 1 exit status

Comment 2 Richard W.M. Jones 2015-02-25 17:37:58 UTC
See also:
http://caml.inria.fr/mantis/view.php?id=6693

Comment 3 Richard W.M. Jones 2015-06-16 12:56:59 UTC
This will be fixed in OCaml 4.02.2+rc1 which I'm going to
upload shortly-ish to Rawhide.


Note You need to log in before you can comment on or make changes to this bug.