Bug 1201229

Summary: cloud-init does not do the resize
Product: [Fedora] Fedora Reporter: Attila Fazekas <afazekas>
Component: cloud-initAssignee: Garrett Holmstrom <gholms>
Status: CLOSED DUPLICATE QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: unspecified Docs Contact:
Priority: unspecified    
Version: 22CC: apevec, danofsatx, gholms, Jan.van.Eldik, mattdm, p, robatino, shardy, s
Target Milestone: ---   
Target Release: ---   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2015-03-16 16:51:29 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Bug Depends On:    
Bug Blocks: 1043125    

Description Attila Fazekas 2015-03-12 11:23:04 UTC
Description of problem:
After booting the cloud image the file system is not resized, even if it explicitly specified in the cloud config.

resize_rootfs: noblock
resize_rootfs: true

$ df -h
/dev/vda1       2.9G  444M  2.3G  17% /

The flavor m1.large (4) with 80GB disk.


Version-Release number of selected component (if applicable):
cloud-init-0.7.6-3.fc22.x86_64
Fedora-Cloud-Base-22_Alpha-20150305.x86_64


Expected results:
/dev/vda1 partition and filesystem is resized to the maximum available space.

Additional info:
The qcow2 file was converted to compat=0.10 version because the host is running el6, but it does not expected to cause this issue.

Comment 1 Garrett Holmstrom 2015-03-12 17:47:49 UTC
Which image and cloud did you encounter this with?

Comment 2 Garrett Holmstrom 2015-03-12 17:54:17 UTC
This could very well be caused by bug 1197894, which already blocks F22 beta.

Comment 3 Dan Mossor [danofsatx] 2015-03-16 16:51:29 UTC

*** This bug has been marked as a duplicate of bug 1197894 ***