Bug 1197894 - growpart: sfdisk dropped --show-pt-geometry option
Summary: growpart: sfdisk dropped --show-pt-geometry option
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: cloud-utils
Version: 22
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Juerg Haefliger
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: AcceptedBlocker https://fedoraproject...
: 1201229 (view as bug list)
Depends On:
Blocks: F22BetaBlocker
TreeView+ depends on / blocked
 
Reported: 2015-03-02 21:57 UTC by Dusty Mabe
Modified: 2015-04-17 02:29 UTC (History)
8 users (show)

Fixed In Version: cloud-utils-0.27-13.fc22
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-04-17 02:29:21 UTC


Attachments (Terms of Use)

Description Dusty Mabe 2015-03-02 21:57:09 UTC
Description of problem:
growpart uses a now unsupported option to sfdisk. This option is  --show-pt-geometry which was removed in the rewrite of sfdisk [1]. This can be observed when booting the Fedora 22 TC7 Cloud Base image [2]. cloud-init fails (look at journalctl output). The error can be recreated from the command line:

[root@t7 ~]# growpart --dry-run /dev/vda 1                                                                                                                                                                    
failed [sfd_geom:1] sfdisk /dev/vda --show-pt-geometry
sfdisk: unrecognized option '--show-pt-geometry'

[1] - https://github.com/karelzak/util-linux/commit/1881390de25df8587b8fc281c451796f7d032dd3#diff-31d5cc325380dbdafe64d0e019846f12R20
[2] - https://kojipkgs.fedoraproject.org//work/tasks/7429/9097429/Fedora-Cloud-Base-20150227-22_Alpha_TC7.x86_64.qcow2


Version-Release number of selected component (if applicable):
cloud-utils-growpart-0.27-12.fc22.noarch


How reproducible:
Always


Steps to Reproduce:
See description

Comment 1 Dusty Mabe 2015-03-02 22:01:26 UTC
Adding kzak@redhat.com and including his comments from mailing list:

http://marc.info/?l=util-linux-ng&m=142532625928148&w=2

 The question is why growpart need information about geometry, always
 when you need to work with geometry then you're doing something very
 wrong.

 It seems like an attempt to copy disk PT in CHS compatible way. It's 
 unnecessary. It should be enough to use --dump and then restore
 without CHS options on command line.

Comment 2 Fedora Blocker Bugs Application 2015-03-03 17:16:27 UTC
Proposed as a Blocker for 22-beta by Fedora user roshi using the blocker tracking app because:

 This bug causes growroot to not work resulting in unused space in the volume which violates the following beta criterion: "Release blocking cloud images must be able to automatically utilize all available space on a supported volume."

Comment 3 Adam Williamson 2015-03-05 16:17:25 UTC
clear +1 Beta blocker. If Alpha winds up slipping and we get a fix, could be Alpha NTH too.

Comment 4 Adam Williamson 2015-03-09 16:26:16 UTC
Discussed at 2015-03-09 blocker review meeting: http://meetbot.fedoraproject.org/fedora-blocker-review/2015-03-09/f22-blocker-review.2015-03-09-16.05.log.txt . Accepted as a blocker per criterion cited in comment #2.

Comment 5 Dan Mossor [danofsatx] 2015-03-16 16:51:29 UTC
*** Bug 1201229 has been marked as a duplicate of this bug. ***

Comment 6 Fedora Update System 2015-03-26 08:15:59 UTC
cloud-utils-0.27-13.fc22 has been submitted as an update for Fedora 22.
https://admin.fedoraproject.org/updates/cloud-utils-0.27-13.fc22

Comment 7 Fedora Update System 2015-03-29 04:30:16 UTC
Package cloud-utils-0.27-13.fc22:
* should fix your issue,
* was pushed to the Fedora 22 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing cloud-utils-0.27-13.fc22'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2015-4820/cloud-utils-0.27-13.fc22
then log in and leave karma (feedback).

Comment 8 Adam Williamson 2015-04-01 23:45:04 UTC
Beta TC6 should have been built with the fix for this (I included it in the TC6 compose request). Can you please check TC6 and see if it's fixed? Thanks!

Comment 9 Dusty Mabe 2015-04-02 03:11:14 UTC
(In reply to awilliam@redhat.com from comment #8)
> Beta TC6 should have been built with the fix for this (I included it in the
> TC6 compose request). Can you please check TC6 and see if it's fixed? Thanks!

I'll try to check this tomorrow.

Comment 10 Dusty Mabe 2015-04-02 21:47:08 UTC
Looks like TC6 failed for cloud base http://koji.fedoraproject.org/koji/taskinfo?taskID=9376828. roshi has said that TC7 is going tonight so I will test that when it comes out. I don't have access to my openstack instance right now so I'll be testing on AWS.

Comment 11 Dusty Mabe 2015-04-07 04:14:51 UTC
Looks like this works fine for TC8 [1]:

util.py[DEBUG]: Running command ['growpart', '--dry-run', '/dev/vda', '1'] with allowed return codes [0] (shell=False, capture=True)
util.py[DEBUG]: Running command ['growpart', '/dev/vda', '1'] with allowed return codes [0] (shell=False, capture=True)
util.py[DEBUG]: resize_devices took 1.664 seconds
cc_growpart.py[INFO]: '/' resized: changed (/dev/vda, 1) from 3145728000 to 21473787904


[1] - https://kojipkgs.fedoraproject.org//work/tasks/8282/9418282/Fedora-Cloud-Base-22_Beta_TC8-20150405.x86_64.qcow2

Comment 12 Adam Williamson 2015-04-14 00:45:56 UTC
The fix for this bug specifically was verified by multiple testers in TC8/RC1.

Comment 13 Fedora Update System 2015-04-17 02:29:21 UTC
cloud-utils-0.27-13.fc22 has been pushed to the Fedora 22 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.