Bug 120175

Summary: Menu icons won't theme
Product: [Fedora] Fedora Reporter: Jeff Moe (jebba) <moe>
Component: system-config-keyboardAssignee: Brent Fox <bfox>
Status: CLOSED RAWHIDE QA Contact:
Severity: medium Docs Contact:
Priority: medium    
Version: rawhide   
Target Milestone: ---   
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2004-04-08 14:56:38 EDT Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Bug Depends On:    
Bug Blocks: 119991    

Description Jeff Moe (jebba) 2004-04-06 12:39:48 EDT
Icons in the menu do not change when the theme is changed. This
is true even if the theme has an icon of the correct name.

The cause of this is that in
/usr/share/applications/system-config-keyboard.desktop
the Icon= line has the absolute path to the icon instead of just the
icon name.

Icon=/usr/share/system-config-bind/system-config-keyboard.png
When it should have:
Icon=system-config-keyboard.png

The icon should be put in the hicolor theme, per freedesktop.org.
/usr/share/icons/hicolor/48x48/apps/
Comment 1 Brent Fox 2004-04-08 14:56:38 EDT
Fixed in system-config-keyboard-1.2.1-2 in Rawhide.