Bug 119991 - Menu icons won't theme
Summary: Menu icons won't theme
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: redhat-menus   
(Show other bugs)
Version: rawhide
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Matthias Clasen
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On: 120170 120171 120172 120173 120174 120175 120176 120177 120178 120179 120181 120183 120184 120185 120186 120187 146486
Blocks: FC4Target
TreeView+ depends on / blocked
 
Reported: 2004-04-04 20:35 UTC by Jeff Moe (jebba)
Modified: 2007-11-30 22:10 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-04-19 15:45:07 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Jeff Moe (jebba) 2004-04-04 20:35:05 UTC
Many icons in the menu do not change when the theme is changed. This
is true even if the theme has an icon of the correct name.

The cause of this is that in /usr/share/applications/foo.desktop the
Icon= line has the absolute path to the icon instead of just the icon
name.

For example, redhat-config-keyboard has:
Icon=/usr/share/redhat-config-keyboard/pixmaps/keyboard.png
When it should have:
Icon=keyboard.png

This is true with menus under RedHat 9, Fedora Core 1, and my hunch is
that it's true in FC2t2, but I haven't confirmed it yet.

The icons are set in the applications' .desktop files, not in
redhat-menus. I can open up trouble tickets for each individual
package, if needed.

To find the names of the broken packages, run:
rpm -qf `grep Icon=/ /usr/share/applications/* | cut -f 1 -d ":"`

Comment 1 Jeff Moe (jebba) 2004-04-04 21:00:32 UTC
Someone in #fedora-devel confirmed this is true in FC2t2. The broken
pacakges on their system:
mtr-gtk-0.54-4
xsane-0.92-7
xsane-0.92-9
system-config-bind-2.0.2-3.1
system-config-bind-2.0.2-4
system-config-date-1.7.2-1
system-config-date-1.7.3-1
system-config-display-1.0.11-1
system-config-keyboard-1.2.1-1.1
system-config-kickstart-2.5.8-1
system-config-kickstart-2.5.9-1
system-config-language-1.1.5-1.1
system-config-nfs-1.2.3-1
system-config-rootpassword-1.1.3-1.1
system-config-samba-1.2.7-1
system-config-samba-1.2.9-1
system-config-securitylevel-1.3.8-1
system-config-securitylevel-1.3.9-1
system-config-services-0.8.8-2
system-config-soundcard-1.2.7-3
system-config-users-1.2.9-1.1
system-config-users-1.2.11-1
system-logviewer-0.9.6-1

Comment 2 Jones Lee 2004-04-04 23:37:15 UTC
Yeah, I got same, hope this fix soon.

Comment 3 Bill Nottingham 2004-04-06 16:09:39 UTC
Can you open a bug against each package, and mark that it blocks this bug?


Comment 4 Jeff Moe (jebba) 2004-04-06 16:59:18 UTC
Bugzilla'd 'em all and set them to block.

Comment 5 Colin Charles 2004-05-06 06:14:47 UTC
Performing the rpm -qf command listed above with the current Rawhide
tree, I notice only tuxracer=0.61-26 complaining, rather than all the
other packages listed. 

Comment 6 Bryan W Clark 2004-11-16 07:29:56 UTC
This is all complete except it is blocking on sys-config-bind.  I've
emailed Jason about this and since the tool is undergoing a major
rewrite he doesn't expect to finish the icon themeing problem anytime
soon.  I'm removing this from the current blocker lists and bumping to
FC4 tracker.

Comment 7 Jeff Moe (jebba) 2005-01-28 19:43:34 UTC
The current list on my box for fc3 is:
setools-gui-1.4.1-5
gimp-2.2.2-0.fc3.3 #146486
nabi-0.14-3
pydict-0.3.0-7
tuxracer-0.61-28
setools-gui-1.4.1-5
setools-gui-1.4.1-5
system-config-netboot-0.1.8-1
xcdroast-0.98a15-8


Comment 8 Matthias Clasen 2005-04-19 15:45:07 UTC
system-config-bind appears fixed in Rawhide.


Note You need to log in before you can comment on or make changes to this bug.