Bug 1202356

Summary: rebase noVNC to 0.5.1
Product: [oVirt] ovirt-engine Reporter: John Pierce <john.r.pierce>
Component: Frontend.WebAdminAssignee: Michal Skrivanek <michal.skrivanek>
Status: CLOSED CURRENTRELEASE QA Contact: Jiri Belka <jbelka>
Severity: medium Docs Contact:
Priority: unspecified    
Version: ---CC: bctpe4hbiu, budic, bugs, ecohen, gklein, jbelka, lsurette, luf, mgoldboi, michal.skrivanek, nicolas, oourfali, rbalakri, sbonazzo, s.kieske, tjelinek, v.astafiev, yeylon
Target Milestone: ovirt-3.6.0-rcKeywords: Rebase, Regression
Target Release: 3.6.0Flags: rule-engine: ovirt-3.6.0+
rule-engine: blocker+
ylavi: planning_ack+
rule-engine: devel_ack+
rule-engine: testing_ack+
Hardware: x86_64   
OS: Linux   
Whiteboard: virt
Fixed In Version: Doc Type: Rebase: Bug Fixes and Enhancements
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2015-11-04 11:47:35 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: Virt RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Bug Depends On: 1264456    
Bug Blocks:    

Description John Pierce 2015-03-16 13:20:52 UTC
Description of problem:

The latest version upstream of noVNC is 0.5.1.  The current version in OSP, 0.4, is quite old at this point, and lacks several important bug fixes.

Additionally, as of 15-Mar-2015, the official CentOS 7 update repositories are pushing novnc.noarch 0.5.1-2.el7 update out to CentOS 7 servers. So after I ran a "yum update" on my oVirt self-hosted engine running CentOS 7 yesterday (on 15-Mar), I got errors when trying to launch the noVNC console for any of VMs.

Specifically, I received a JavaScript error popup in my web browser stating: "ReferenceError: WebUtil is not defined" and in FireBug, I noticed that I was getting a 404 error regarding a missing vnc.js include file from my ovirt engine. Indeed vnc.js was missing from the path: /usr/share/novnc/include/ on my ovirt engine and that's when I discovered the yum update of noVNC occurred and the new 0.5.1 package does not have a vnc.js file anymore.

Version-Release number of selected component (if applicable):
novnc.noarch 0.5.1-2.el7 on CentOS/RHEL 7

How reproducible:
Always as of 15-Mar-2015 when the upstream CentOS yum update repositories starting pushing noVNC 0.5.1.

Steps to Reproduce:
1. Do a yum update to your CentOS 7.0 oVirt engine which should pull down the latest novnc 0.5.1 package.
2. Try to open a noVNC console to any VM running on your oVirt engine.
3. Observe JavaScript error as no console shows up.

Actual results:
JavaScript popup error stating ReferenceError: WebUtil is not defined.

Expected results:
noVNC console should render.

Additional info:
For now, I downloaded novnc-0.4-7.el7.noarch rpm and downgraded to the version that works with this command: rpm -Uvh --oldpackage novnc-0.4-7.el7.noarch.rpm.

This workaround seems necessary until oVirt webadmin code is updated to accomodate noVNC 0.5.1.

Comment 1 Sandro Bonazzola 2015-05-14 15:47:28 UTC
Michal, noVNC is causing a (minor?) regression here, I suggest to re-target this to 3.5.4.

Comment 2 Michal Skrivanek 2015-05-14 16:01:54 UTC
Might be easier to push Conflicts: then
Fix won't happen any time soon, well, at least couple of weeks

Comment 3 Nicolas Ecarnot 2015-06-09 14:14:07 UTC
Confirming the issue...

Comment 5 Max Kovgan 2015-06-28 14:13:39 UTC
ovirt-3.6.0-3 release

Comment 6 Red Hat Bugzilla Rules Engine 2015-09-22 07:43:32 UTC
This bug report has Keywords: Regression or TestBlocker.
Since no regressions or test blockers are allowed between releases, it is also being identified as a blocker for this release. Please resolve ASAP.

Comment 7 Jiri Belka 2015-10-29 16:36:48 UTC
ok, novnc works

novnc-0.5.1-2.el6.noarch
rhevm-webadmin-portal-3.6.0.2-0.1.el6.noarch

Comment 8 Sandro Bonazzola 2015-11-04 11:47:35 UTC
oVirt 3.6.0 has been released on November 4th, 2015 and should fix this issue.
If problems still persist, please open a new BZ and reference this one.