Bug 1264456 - novnc and spice-html5 console do not work anymore
Summary: novnc and spice-html5 console do not work anymore
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine
Version: 3.6.0
Hardware: Unspecified
OS: Unspecified
medium
high
Target Milestone: ovirt-3.6.1
: 3.6.1
Assignee: jniederm
QA Contact: Jiri Belka
URL:
Whiteboard:
Depends On:
Blocks: 1202356
TreeView+ depends on / blocked
 
Reported: 2015-09-18 13:43 UTC by Jiri Belka
Modified: 2019-04-28 09:37 UTC (History)
11 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
The python-websockify 0.6 dependency package contained changes that resulted in novnc and spice-html5 consoles no longer being able to open. Fixed ovirt-websocket-proxy.py to work with python-websockify 0.6 so that the consoles now open as intended.
Clone Of:
Environment:
Last Closed: 2016-03-09 21:13:19 UTC
oVirt Team: Virt


Attachments (Terms of Use)
websocket proxy debug, probably useless (6.88 KB, text/plain)
2015-09-18 13:43 UTC, Jiri Belka
no flags Details


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2016:0376 normal SHIPPED_LIVE Red Hat Enterprise Virtualization Manager 3.6.0 2016-03-10 01:20:52 UTC
oVirt gerrit 32138 None None None 2016-01-19 16:24:53 UTC
oVirt gerrit 46440 None None None 2016-01-19 16:27:09 UTC

Description Jiri Belka 2015-09-18 13:43:19 UTC
Created attachment 1074922 [details]
websocket proxy debug, probably useless

Description of problem:

novnc and spice-html5 consoles do not work anymore. tested from FF 38, FF 31 (supported), FF 39.

- spice-html5:

  > FF39: incorrect connection data
  > FF31: error: unexpected protocol mismatch
    sometimes also an error about can't connect but only for first try (hard
    to reproduce)

- novnc
  > FF31: failed to connect to server (code: 1006)


Version-Release number of selected component (if applicable):
rhevm-3.6.0-0.15.master.el6.noarch
novnc-0.5.1-2.el6.noarch
spice-html5-0.1.6-2.el6.noarch
rhevm-websocket-proxy-3.6.0-0.15.master.el6.noarch

How reproducible:
100%

Steps to Reproduce:
1. start two vms, one with spice and the latter with vnc
2. open web consoles (spice-html5, novnc)
3.

Actual results:
html-based consoles do not work (although the tab get opened)

Expected results:
should work

Additional info:

Comment 1 Douglas Schilling Landgraf 2015-09-18 19:38:57 UTC
(In reply to Jiri Belka from comment #0)
> Created attachment 1074922 [details]
> websocket proxy debug, probably useless
> 
> Description of problem:
> 
> novnc and spice-html5 consoles do not work anymore. tested from FF 38, FF 31
> (supported), FF 39.
> 
> - spice-html5:
> 
>   > FF39: incorrect connection data
>   > FF31: error: unexpected protocol mismatch
>     sometimes also an error about can't connect but only for first try (hard
>     to reproduce)
> 
> - novnc
>   > FF31: failed to connect to server (code: 1006)
> 
> 
> Version-Release number of selected component (if applicable):
> rhevm-3.6.0-0.15.master.el6.noarch
> novnc-0.5.1-2.el6.noarch
> spice-html5-0.1.6-2.el6.noarch
> rhevm-websocket-proxy-3.6.0-0.15.master.el6.noarch
> 
> How reproducible:
> 100%
> 
> Steps to Reproduce:
> 1. start two vms, one with spice and the latter with vnc
> 2. open web consoles (spice-html5, novnc)
> 3.
> 
> Actual results:
> html-based consoles do not work (although the tab get opened)
> 
> Expected results:
> should work
> 
> Additional info:

Hi Jiri,

Is it happening in RHEL-H and RHEV-H? I am not sure if the component you opened the bug is related. Could you please share a little bit why you decided to open this report against ovirt-node-plugin-vdsm? 

Thanks!

Comment 2 Jiri Belka 2015-09-19 09:10:22 UTC
ad component - mistake ;) changing to webadmin

Comment 3 Tomas Jelinek 2015-09-21 07:34:11 UTC
Looks like some compatibility issues between websocket proxy and the web clients.

Comment 5 jniederm 2015-09-23 13:20:58 UTC
It works for me (engine commit 5ef7702). The commit fixing that (https://gerrit.ovirt.org/#/c/46440/) probably wasn't in previous build. Next build (probably created today, 23.9.) should contain that.

Comment 6 Michal Skrivanek 2015-10-21 11:46:31 UTC
(In reply to jniederm from comment #5)
> It works for me (engine commit 5ef7702). The commit fixing that
> (https://gerrit.ovirt.org/#/c/46440/) probably wasn't in previous build.
> Next build (probably created today, 23.9.) should contain that.

the linked patch indicates it's fixed in build 14. This bug says tested on build 15
So is there anything else/more?

Comment 7 jniederm 2015-10-21 15:55:46 UTC
This bug was filed before (Sep 18) the patch (https://gerrit.ovirt.org/#/c/46440/) was merged (Sep 21). So nothing is missing.

Comment 9 Jiri Belka 2015-10-29 16:33:33 UTC
ok, rhevm-webadmin-portal-3.6.0.2-0.1.el6.noarch

i could open both spice-html5 and novnc consoles.

Comment 12 errata-xmlrpc 2016-03-09 21:13:19 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHEA-2016-0376.html


Note You need to log in before you can comment on or make changes to this bug.