Bug 1209223

Summary: Prevent selection of installation target device(s) containing incomplete RAID sets, LVM VGs, brtfs volumes etc.
Product: [Fedora] Fedora Reporter: Adam Williamson <awilliam>
Component: anacondaAssignee: David Lehman <dlehman>
Status: CLOSED NEXTRELEASE QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: high Docs Contact:
Priority: unspecified    
Version: 22CC: anaconda-maint-list, g.kaviyarasu, jonathan, mcsontos, satellitgo, vanmeeuwen+fedora
Target Milestone: ---   
Target Release: ---   
Hardware: All   
OS: Unspecified   
Whiteboard: AcceptedFreezeException
Fixed In Version: anaconda-23.6-1 Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2015-09-11 15:33:22 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Bug Depends On:    
Bug Blocks: 1043128    

Description Adam Williamson 2015-04-06 17:52:53 UTC
This bug exists to track blocker/FE status for this anaconda change:

https://github.com/rhinstaller/anaconda/pull/60

at present anaconda allows you to select, say, a single disk as an install target even if it's part of a multi-disk LVM VG or RAID set or btrfs volume.

The change prevents you doing that; if the disk is part of some kind of multi-disk thing it requires you to select all the related disks as 'targets' or none of them.

dlehman wanted this change to go into Beta for testing.

Comment 1 Adam Williamson 2015-04-06 17:53:58 UTC
Discussed at 2015-04-06 freeze exception review meeting: https://meetbot.fedoraproject.org/fedora-blocker-review/2015-04-06/f22-blocker-review.2015-04-06-16.00.log.txt . Accepted as a freeze exception issue on the basis that if we want to do this at all it'd make sense to get it in Beta.

(personal note: I'm a bit worried about that and think this is a fairly large change which may have unexpected consequences, but if it does I suppose we can take it back out as it's only FE).

Comment 2 David Shea 2015-04-15 14:15:36 UTC
*** Bug 1022811 has been marked as a duplicate of this bug. ***

Comment 3 David Shea 2015-04-15 14:15:39 UTC
*** Bug 1158533 has been marked as a duplicate of this bug. ***

Comment 4 David Lehman 2015-09-11 15:33:22 UTC
This is fixed in anaconda-23.6-1.