Bug 1158533 - selecting one disk from VG spanning over multiple disks causes troubles [NEEDINFO]
Summary: selecting one disk from VG spanning over multiple disks causes troubles
Keywords:
Status: CLOSED DUPLICATE of bug 1209223
Alias: None
Product: Fedora
Classification: Fedora
Component: anaconda
Version: 21
Hardware: x86_64
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Anaconda Maintenance Team
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: abrt_hash:402fec84f3c73861261419db5c1...
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-10-29 14:59 UTC by satellitgo
Modified: 2015-04-15 14:15 UTC (History)
15 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
: 1166598 (view as bug list)
Environment:
Last Closed: 2015-04-15 14:15:39 UTC
Type: ---
kparal: needinfo? (satellitgo)


Attachments (Terms of Use)
File: anaconda-tb (925.50 KB, text/plain)
2014-10-29 14:59 UTC, satellitgo
no flags Details
File: anaconda.log (18.95 KB, text/plain)
2014-10-29 14:59 UTC, satellitgo
no flags Details
File: environ (623 bytes, text/plain)
2014-10-29 14:59 UTC, satellitgo
no flags Details
File: journalctl (315.58 KB, text/plain)
2014-10-29 14:59 UTC, satellitgo
no flags Details
File: lsblk_output (3.46 KB, text/plain)
2014-10-29 14:59 UTC, satellitgo
no flags Details
File: nmcli_dev_list (2.55 KB, text/plain)
2014-10-29 14:59 UTC, satellitgo
no flags Details
File: os_info (377 bytes, text/plain)
2014-10-29 14:59 UTC, satellitgo
no flags Details
File: program.log (63.76 KB, text/plain)
2014-10-29 14:59 UTC, satellitgo
no flags Details
File: storage.log (465.62 KB, text/plain)
2014-10-29 14:59 UTC, satellitgo
no flags Details
File: ifcfg.log (5.18 KB, text/plain)
2014-10-29 14:59 UTC, satellitgo
no flags Details
reclaim space dialog when opened for the first time (103.99 KB, image/png)
2014-10-30 09:35 UTC, Petr Schindler
no flags Details
reclaim space dialog when opened for the second time with just first disk (187.99 KB, image/png)
2014-10-30 09:36 UTC, Petr Schindler
no flags Details
anaconda.log (130.02 KB, text/plain)
2014-10-30 14:03 UTC, Petr Schindler
no flags Details
traceback (3.11 MB, text/plain)
2014-10-30 14:05 UTC, Petr Schindler
no flags Details
program.log (278.21 KB, text/plain)
2014-10-30 14:14 UTC, Petr Schindler
no flags Details
storage.log (2.11 MB, text/plain)
2014-10-30 14:15 UTC, Petr Schindler
no flags Details
anaconda traceback (496.84 KB, text/plain)
2014-11-20 14:12 UTC, Jan Sedlák
no flags Details
storage.log (190.07 KB, text/plain)
2014-11-20 14:13 UTC, Jan Sedlák
no flags Details


Links
System ID Private Priority Status Summary Last Updated
Red Hat Bugzilla 449832 0 high CLOSED all relevant lvm2 vg* commands should allow UUID as input 2021-02-22 00:41:40 UTC
Red Hat Bugzilla 1022811 0 unspecified CLOSED Selecting one disk from multi-disk VG displays no information about the VG 2021-02-22 00:41:40 UTC
Red Hat Bugzilla 1158911 0 unspecified CLOSED FormatDestroyError: error wiping old signatures from /dev/sda2: 1 2021-02-22 00:41:40 UTC

Internal Links: 449832 1022811 1158911

Description satellitgo 2014-10-29 14:59:28 UTC
Description of problem:
LXDE install to USB HD (reclaim disks ) with 2 USB HD disks connected-1 selected

Version-Release number of selected component:
anaconda-core-21.48.13-1.fc21.x86_64

The following was filed automatically by anaconda:
anaconda 21.48.13-1 exception report
Traceback (most recent call first):
  File "/usr/lib/python2.7/site-packages/blivet/devicelibs/lvm.py", line 532, in lvactivate
    raise LVMError("lvactivate failed for %s: %s" % (lv_name, msg))
  File "/usr/lib/python2.7/site-packages/blivet/devices.py", line 3086, in _setup
    lvm.lvactivate(self.vg.name, self._name)
  File "/usr/lib/python2.7/site-packages/blivet/devices.py", line 856, in setup
    self._setup(orig=orig)
  File "/usr/lib/python2.7/site-packages/blivet/deviceaction.py", line 642, in execute
    self.device.setup(orig=True)
  File "/usr/lib/python2.7/site-packages/blivet/devicetree.py", line 361, in processActions
    action.execute(callbacks)
  File "/usr/lib/python2.7/site-packages/blivet/__init__.py", line 364, in doIt
    self.devicetree.processActions(callbacks)
  File "/usr/lib/python2.7/site-packages/blivet/__init__.py", line 216, in turnOnFilesystems
    storage.doIt(callbacks)
  File "/usr/lib64/python2.7/site-packages/pyanaconda/install.py", line 190, in doInstall
    turnOnFilesystems(storage, mountOnly=flags.flags.dirInstall, callbacks=callbacks_reg)
  File "/usr/lib64/python2.7/threading.py", line 766, in run
    self.__target(*self.__args, **self.__kwargs)
  File "/usr/lib64/python2.7/site-packages/pyanaconda/threads.py", line 227, in run
    threading.Thread.run(self, *args, **kwargs)
LVMError: lvactivate failed for home: running lvm lvchange -a y --config  devices { preferred_names=["^/dev/mapper/", "^/dev/md/", "^/dev/sd"] filter=["r|/sda1$|","r|/sda2$|","r|/sda3$|","r|/sda$|","r|/sdc1$|","r|/sdc2$|","r|/sdc$|"] }  fedora/home failed

Additional info:
cmdline:        /usr/bin/python  /sbin/anaconda --liveinst --method=livecd:///dev/mapper/live-base
cmdline_file:   BOOT_IMAGE=vmlinuz0 initrd=initrd0.img root=live:CDLABEL=Fedora-Live-LXDE-x86_64-21_Beta- rootfstype=auto ro rd.live.image quiet  rhgb rd.luks=0 rd.md=0 rd.dm=0 
executable:     /sbin/anaconda
hashmarkername: anaconda
kernel:         3.17.1-302.fc21.x86_64
other involved packages: python-blivet-0.61.8-1.fc21.noarch, python-libs-2.7.8-4.1.fc21.x86_64
product:        Fedora"
release:        Fedora release 21 (Twenty One)
type:           anaconda
version:        Fedora

Comment 1 satellitgo 2014-10-29 14:59:31 UTC
Created attachment 951817 [details]
File: anaconda-tb

Comment 2 satellitgo 2014-10-29 14:59:32 UTC
Created attachment 951818 [details]
File: anaconda.log

Comment 3 satellitgo 2014-10-29 14:59:32 UTC
Created attachment 951819 [details]
File: environ

Comment 4 satellitgo 2014-10-29 14:59:34 UTC
Created attachment 951820 [details]
File: journalctl

Comment 5 satellitgo 2014-10-29 14:59:35 UTC
Created attachment 951821 [details]
File: lsblk_output

Comment 6 satellitgo 2014-10-29 14:59:36 UTC
Created attachment 951822 [details]
File: nmcli_dev_list

Comment 7 satellitgo 2014-10-29 14:59:36 UTC
Created attachment 951823 [details]
File: os_info

Comment 8 satellitgo 2014-10-29 14:59:37 UTC
Created attachment 951824 [details]
File: program.log

Comment 9 satellitgo 2014-10-29 14:59:39 UTC
Created attachment 951825 [details]
File: storage.log

Comment 10 satellitgo 2014-10-29 14:59:40 UTC
Created attachment 951826 [details]
File: ifcfg.log

Comment 11 satellitgo 2014-10-29 15:03:37 UTC
this is second time I have seen this.
Looks like 2 USB HD's plugged in causes failure.

Comment 12 Fedora Blocker Bugs Application 2014-10-29 15:12:24 UTC
Proposed as a Freeze Exception for 21-final by Fedora user satellit using the blocker tracking app because:

 The installer must be able to complete an installation using all supported interfaces 
anaconda 21.48.13-1

Comment 13 satellitgo 2014-10-29 16:02:35 UTC
(In reply to Fedora Blocker Bugs Application from comment #12)
> Proposed as a Freeze Exception for 21-final by Fedora user satellit using
> the blocker tracking app because:
> 
>  The installer must be able to complete an installation using all supported
> interfaces 
> anaconda 21.48.13-1

Unplug 2nd USB HD and installs fine

Comment 14 Petr Schindler 2014-10-30 08:43:36 UTC
Another user experienced a similar problem:

I run installation. Only thing I did is: I chose both my disk for installation (with delete all) and then I changed my mind and went to installation destination again but this time I chose just one disk (with delete all). Then I started installation. This bug apeared during formating (I think).

cmdline:        /usr/bin/python  /sbin/anaconda --liveinst --method=livecd:///dev/mapper/live-base
cmdline_file:   initrd=initrd0.img root=live:UUID=5982-5591 rootfstype=vfat ro rd.live.image quiet  rhgb rd.luks=0 rd.md=0 rd.dm=0 nomodeset BOOT_IMAGE=vmlinuz0 
hashmarkername: anaconda
kernel:         3.17.1-302.fc21.x86_64
other involved packages: python-blivet-0.61.8-1.fc21.noarch, python-libs-2.7.8-4.1.fc21.x86_64
package:        anaconda-core-21.48.13-1.fc21.x86_64
packaging.log:  
product:        Fedora"
reason:         LVMError: lvactivate failed for swap: running lvm lvchange -a y --config  devices { preferred_names=["^/dev/mapper/", "^/dev/md/", "^/dev/sd"] filter=["r|/fedora_dhcp-29-208$|","r|/sdb1$|","r|/sdb$|"] }  fedora_dhcp-28-114/swap failed
release:        Fedora release 21 (Twenty One)
version:        Fedora

Comment 15 Petr Schindler 2014-10-30 09:34:45 UTC
So, here is what's going on on my computer.

I have two disks: On the first one there is the default installation of Fedora 21. sda1 is /boot and sda2 is LVM with root and swap.
On the second disk there is one LVM which is there from old installation of Fedora (original installation was on two disks with one big LVM. Then the new installation took place on the first disk and second disk was untouched by that).

When I go to installation destination for the first time I choose both disks and in reclaim space I click on delete all and confirm. There seems to be everything alright in reclaim space dialog (see first attached picture). Then when I change my mind I go to installation destination again. This time I choose only first disk and second one I leave unchecked. The reclaim space dialog is opened again, but this time there is one error. sda1 and sda2 are swapped. Anaconda shows that there is lvm on sda1 and /boot on sda2 (see second attached screenshot). After I click on delete all, confirm and I start the installation it fails.

Comment 16 Petr Schindler 2014-10-30 09:35:48 UTC
Created attachment 952037 [details]
reclaim space dialog when opened for the first time

Comment 17 Petr Schindler 2014-10-30 09:36:34 UTC
Created attachment 952039 [details]
reclaim space dialog when opened for the second time with just first disk

Comment 18 Petr Schindler 2014-10-30 09:39:24 UTC
I propose this as beta blocker as it violates the criterion: "When using the guided partitioning flow, the installer must be able to:
* Complete an installation using any combination of disk configuration options it allows the user to select 
* Remove existing storage volumes to free up space, at the user's direction"

Comment 19 Petr Schindler 2014-10-30 10:26:59 UTC
I tested this with another computer with two disks. And I wasn't able to reproduce this bug. The difference seems to be that on the pc where this bug happens is gpt table on /dev/sda but there is mbr on the second pc's /dev/sda.

Comment 20 Petr Schindler 2014-10-30 14:03:03 UTC
I reproduced this using virtual machine with two disks (both with mbr). Both have to be full so reclaim space dialog is used.

See https://pschindl.fedorapeople.org/bug1158533.ogv - mention the layout of the first disk during first and second reclaim space.

Comment 21 Petr Schindler 2014-10-30 14:03:40 UTC
Created attachment 952142 [details]
anaconda.log

Comment 22 Petr Schindler 2014-10-30 14:05:02 UTC
Created attachment 952143 [details]
traceback

Comment 23 Petr Schindler 2014-10-30 14:14:57 UTC
Created attachment 952146 [details]
program.log

Comment 24 Petr Schindler 2014-10-30 14:15:56 UTC
Created attachment 952147 [details]
storage.log

Comment 25 Jan Sedlák 2014-10-30 14:17:03 UTC
Another user experienced a similar problem:

Tried to install Fedora on system with two disks, each with two partitions. Selected both disks to install, selected "delete all" in reclaim dialog, changed my mind, unselected second disk, "delete all" in reclaim dialog and run installation.

addons:         com_redhat_kdump
cmdline:        /usr/bin/python  /sbin/anaconda
cmdline_file:   BOOT_IMAGE=vmlinuz initrd=initrd.img inst.stage2=hd:LABEL=Fedora-S-21_B-x86_64 quiet
hashmarkername: anaconda
kernel:         3.17.1-302.fc21.x86_64
package:        anaconda-21.48.13-1
product:        Fedora"
reason:         LVMError: lvactivate failed for root: running lvm lvchange -a y --config  devices { preferred_names=["^/dev/mapper/", "^/dev/md/", "^/dev/sd"] filter=["r|/vda1$|","r|/vda2$|","r|/vda$|"] }  fedora-server/root failed
release:        Cannot get release name.
version:        Fedora

Comment 26 Adam Williamson 2014-10-30 15:56:04 UTC
It would be very useful to know if anyone can reproduce this without the 'change my mind and do it differently' bit, My inclination is to vote -1 blocker on a bug which involves running through the spoke multiple times and changing your mind, at this point.

Comment 27 Kamil Páral 2014-10-30 16:50:49 UTC
AFAIK, it always involved running through the spoke multiple times. None of us reproduced in just a single pass.

Comment 28 Adam Williamson 2014-10-30 17:11:08 UTC
satellit said his case did not involve multiple runs, for the record. kparal, do you have the logs from your reproducers?

Comment 29 Adam Williamson 2014-10-30 17:41:40 UTC
Discussed at 2014-10-30 Go/No-Go meeting: http://meetbot.fedoraproject.org/fedora-meeting-2/2014-10-30/f21_beta_gono-go_meeting.2014-10-30-17.00.log.txt . Rejected as a blocker on the basis that the clear reproducer we have for this involves multiple runs through the spoke - we generally don't consider that kind of thing to block Beta, especially when it's a last-minute discovery (tending to indicate it's not very commonly encountered).

satellit says his case doesn't involve multiple trips, but disconnecting one disk makes it work, and it seems like it may be a known case where multiple connected disks have identically-named LVs, which is hard for anaconda to handle.

Comment 30 Kamil Páral 2014-11-03 14:31:22 UTC
(In reply to Adam Williamson (Red Hat) from comment #28)
> satellit said his case did not involve multiple runs, for the record.
> kparal, do you have the logs from your reproducers?

Petr Schindler already appended those in comments 21 - 24. Do you need anything else?

Re-proposing as Final blocker.

Comment 31 Kamil Páral 2014-11-05 16:44:40 UTC
Discussed at 2014-11-05 blocker review meeting [1]. Accepted as a blocker. This bug violates the beta criterion "Complete an installation using any combination of disk configuration options it allows the user to select" in the case you change your mind.

[1] http://meetbot.fedoraproject.org/fedora-blocker-review/2014-11-05/

Comment 32 Marian Csontos 2014-11-06 12:43:39 UTC
This is kind-of-duplicate of Bug 1022811.

Anaconda allows you to select one disk from VG spanning over multiple PVs which will cause all kind of troubles - e.g. duplicate VG names and other.

10:55:21,338 INFO program:   LVM2_PV_NAME=/dev/sdb2 LVM2_PV_UUID=OjAQnD-rPDX-6uJ9-wRIc-MoZ1-AdAW-vaQ3Tu LVM2_PE_START=1024.00 LVM2_VG_NAME=fedora LVM2_VG_UUID=hK0yhR-x185-w6cJ-8REZ-0fL7-9j9j-z5IodX LVM2_VG_SIZE=116703232.00 LVM2_VG_FREE=65536.00 LVM2_VG_EXTENT_SIZE=4096.00 LVM2_VG_EXTENT_COUNT=28492 LVM2_VG_FREE_COUNT=16 LVM2_PV_COUNT=1
10:55:21,338 INFO program:   LVM2_PV_NAME=/dev/sdc2 LVM2_PV_UUID=xVgWhI-d9Pu-2yps-nSTC-2mha-zc4U-jul7o9 LVM2_PE_START=1024.00 LVM2_VG_NAME=fedora LVM2_VG_UUID=GPlG97-ZoTO-pGKK-0kb3-J1Cf-y0f7-Ab0KcF LVM2_VG_SIZE=487870464.00 LVM2_VG_FREE=65536.00 LVM2_VG_EXTENT_SIZE=4096.00 LVM2_VG_EXTENT_COUNT=119109 LVM2_VG_FREE_COUNT=16 LVM2_PV_COUNT=1

Comment 33 Kamil Páral 2014-11-20 10:35:32 UTC
Hello anaconda devs, is there any progress on this? Thanks for info.

Comment 34 Jan Sedlák 2014-11-20 14:08:37 UTC
Another user experienced a similar problem:

Tried to reproduce bug 1158533 with one disk. Had one disk with two partitions - /boot (vda1) and / (vda2). Went to partitioning spoke, selected that disk for installation, clicked done, clicked "delete all" on reclaim space dialog. Then went to partitioning spoke again, unselected that disk and clicked "done". Finally, went to partitioning spoke again, selected that disk again and clicked "done". In reclaim space dialog, both partitions had swapped names (/boot was vda2 and / was vda1). When I started installation, this showed up.

addons:         com_redhat_kdump
cmdline:        /usr/bin/python  /sbin/anaconda
cmdline_file:   BOOT_IMAGE=vmlinuz initrd=initrd.img inst.stage2=hd:LABEL=Fedora-S-21_T2-x86_64 quiet
hashmarkername: anaconda
kernel:         3.17.2-300.fc21.x86_64
package:        anaconda-21.48.14-1
product:        Fedora"
reason:         LVMError: lvactivate failed for root: running lvm lvchange -a y --config  devices { preferred_names=["^/dev/mapper/", "^/dev/md/", "^/dev/sd"] }  fedora-server/root failed
release:        Cannot get release name.
version:        Fedora

Comment 35 Jan Sedlák 2014-11-20 14:12:12 UTC
Created attachment 959379 [details]
anaconda traceback

Comment 36 Jan Sedlák 2014-11-20 14:13:53 UTC
Created attachment 959380 [details]
storage.log

Comment 37 Jan Sedlák 2014-11-20 14:22:07 UTC
Another thing is that it seems that to reproduce this bug, LVM should be valid. I have booted same machine again, I have same partitioning on it, but parted doesn't display first partition as "/boot" and second partition as LVM. If I try select-unselect-select combo, partitions are again swapped in reclaim space dialog, but installation proceeds without problem.

Comment 38 Jan Sedlák 2014-11-20 14:40:53 UTC
(In reply to Marian Csontos from comment #32)
> Anaconda allows you to select one disk from VG spanning over multiple PVs
> which will cause all kind of troubles - e.g. duplicate VG names and other.

I don't know if there are more bugs that has caused this, but I had only one PV but this still happened to me.

Forgot to mention: vda1 was normal partition (with ext4 I think) and vda2 was LVM partition (showed actually as "fedora-server", not "/" in reclaim space dialog).

Comment 39 Marian Csontos 2014-11-20 16:05:23 UTC
I am not sure anaconda manipulates lvm.conf in any way, but I see lot of lines like this in lvm2 commands' output:

    13:59:54,504 INFO program:   WARNING: Ignoring duplicate config node: global (seeking global/metadata_read_only)

Could you submit /etc/lvm/lvm.conf please?

Looking further this looks intersting:

08:00:32,915 INFO program: Running... lvm lvchange -a y --config  devices { preferred_names=["^/dev/mapper/", "^/dev/md/", "^/dev/sd"] }  fedora-server/root
08:00:32,999 INFO program:   Volume group "fedora-server" not found
08:00:33,000 INFO program:   Skipping volume group fedora-server

I wonder what exactly is wipefs erasing LVM's PV doing here?

08:00:32,616 INFO program: Running... wipefs -f -a /dev/vda2
08:00:32,732 INFO program: /dev/vda2: 8 bytes were erased at offset 0x00000218 (LVM2_member): 4c 56 4d 32 20 30 30 31
08:00:32,733 DEBUG program: Return code: 0

Oh! It is trying to destroy /boot which is actually on /dev/vda1! BINGO Jan, you nailed it, except it is different bug than the original reported, but the same Petr Schindler reported.

Comment 40 Marian Csontos 2014-11-21 10:03:23 UTC
Here is the lvchange's output:

07:56:51,721 INFO program: Running... lvm lvchange -a y --config  devices { preferred_names=["^/dev/mapper/", "^/dev/md/", "^/dev/sd"] filter=["r|/sda1$|","r|/sda2$|","r|/sda3$|","r|/sda$|","r|/sdc1$|","r|/sdc2$|","r|/sdc$|"] }  fedora/home
07:56:51,760 INFO program:   No device found for PV xVgWhI-d9Pu-2yps-nSTC-2mha-zc4U-jul7o9.
07:56:51,761 INFO program:   Refusing activation of partial LV fedora/home.  Use '--activationmode partial' to override.
07:56:51,761 DEBUG program: Return code: 5

How to handle? I think there are three options:

When reusing an existing VG:
- always use all disks from the VG

When user wants to get rid of VG:
- need to use all disks too

When user wants to use a disk(s) from existing VG keeping the VG:
- Optionally: remove LVs
- Mandatory: use pvmove and vgreduce
- Question is why not reusing the existing VG? Perhaps user wants separate /boot partition on the disk or different configuration of RAID for this installation...

Also VG names in single system should not be duplicated (fedora names the VG fedora - possible unbootable system): it would be safer to either:

- filter used during installation should be propagated to installed system's lvm.conf
- scan disks for VG names

Comment 41 Kamil Páral 2014-11-21 14:23:29 UTC
Marian split this into two bugs - this one now only concerns the comment 0 use case, and bug 1166598 concerns Petr's and Jan's use case. Because only the latter use case was already accepted as a Final blocker, I leave bug 1166598 as accepted and I remove the decision from this bug, moving it back to the proposed state.

Comment 42 Adam Williamson 2014-11-24 17:51:17 UTC
Discussed at 2014-11-24 blocker review meeting: http://meetbot.fedoraproject.org/fedora-blocker-review/2014-11-24/f21-blocker-review.2014-11-24-17.01.log.txt .  Agreed to delay decision on this one as it's not entirely clear what the trigger for satellit's case is - the case that was split out into #1166598 is now well-understood, but no-one was entirely sure how to trigger satellit's case.

We will try to reproduce it ahead of the next blocker meeting on Wednesday so we can make a determination. First thing to try is a guided installation F20 or F21 with multiple disks, then try to install F21 again with the same disks connected but only one chosen as an install target.

Comment 43 Kamil Páral 2014-11-24 18:18:25 UTC
I tried to reproduce comment 0, this is what I did:

1. Installed F21 on two disks using guided part and LVM
2. Reinstalled F21 when selecting just the first disk, using guided part and deleting all contents from the reclaim dialog
and
1. Installed F21 on two disks using guided part and LVM
2. Reinstalled F21 when selecting just the second disk, using guided part and deleting all contents from the reclaim dialog

In both cases, everything worked correctly and the reinstalled system booted.

Comment 44 Kamil Páral 2014-11-24 18:33:46 UTC
I tried once again the same approach, this time using manual partitioning. Again everything worked. Please note that in the manual partitioning dialog, the existing (partial) LVM is grayed out and cannot be reused, only deleted. Which seems correct.

Comment 45 Kamil Páral 2014-11-25 09:46:17 UTC
satellit, can you please provide very detailed steps of how you triggered this issue? Thanks.

Comment 46 Vratislav Podzimek 2014-11-26 15:20:50 UTC
I'd just like to add information that while testing fix for bug #1166598 I've performed installations on one disk from a multi-disk VG without any issues.

Comment 47 Kamil Páral 2014-11-26 15:59:56 UTC
I tried also the use case of physically removing a disk:

1. Installed F21 on two disks using guided part and LVM
2. Physically removed one of the disks
3. Reinstalled F21 (deleted all previous contents)

I tried this for both the disks, and for guided and manual part (all combinations). Everything worked. Again, there was no option to reuse the LVM, just to delete it.

Comment 48 Scott Suehle 2014-11-26 19:41:55 UTC
Discussed in 2014-11-26 Blocker Review Meeting [1]. Voted as an RejectedBlocker. This bug doesn't seem to be reproducible and no new reports have come in confirming this bug.
 
[1] http://meetbot.fedoraproject.org/fedora-blocker-review/2014-11-26/

Comment 49 Marian Csontos 2014-11-27 12:27:14 UTC
It must be the LV spanning multiple disks so it becomes "partial".

Comment 50 Kamil Páral 2014-11-27 14:44:28 UTC
(In reply to Marian Csontos from comment #49)
> It must be the LV spanning multiple disks so it becomes "partial".

Not sure what this comment is related to. That's the layout I had when trying to reproduce this issue.

Comment 51 Adam Williamson 2014-11-27 23:46:37 UTC
Note *LV* not *VG*: Marian's suggesting the bug only happens if you have a single LV within the VG that *itself* spans multiple disks. Just to be super-sure, is that the config you tested with?

Comment 52 Kamil Páral 2014-11-28 09:01:23 UTC
Yes. My root partition was larger than any of the disks attached, so it must have spanned both of them.

Comment 53 Brian 2014-11-30 02:49:12 UTC
Another user experienced a similar problem:

1. booted from live cd
2. from live cd selected install to disk
3.  Deleted all disk partitions from previous Linux Mint install on hard disk.
4.  Received the message during the install.

cmdline:        /usr/bin/python  /sbin/anaconda --liveinst --method=livecd:///dev/mapper/live-base
cmdline_file:   BOOT_IMAGE=/isolinux/vmlinuz0 root=live:LABEL=Fedora-Live-Workstation-x86_64-2 ro rd.live.image quiet rhgb
hashmarkername: anaconda
kernel:         3.17.1-302.fc21.x86_64
other involved packages: python-blivet-0.61.8-1.fc21.noarch, python-libs-2.7.8-4.1.fc21.x86_64
package:        anaconda-core-21.48.13-1.fc21.x86_64
packaging.log:  
product:        Fedora"
reason:         LVMError: lvactivate failed for root: running lvm lvchange -a y --config  devices { preferred_names=["^/dev/mapper/", "^/dev/md/", "^/dev/sd"] }  mint-vg/root failed
release:        Fedora release 21 (Twenty One)
version:        Fedora

Comment 54 Brian 2014-11-30 02:57:20 UTC
Follow up re-running and it worked second time. Odd, assume something got cleaned up the first time.

Comment 55 Craig 2015-02-28 20:25:33 UTC
Another user experienced a similar problem:

tying to install fedora 21 on my laptop
i formated my harddrive , I think that might be the problem, but not sure.
Useing a live dvd for installation

cmdline:        /usr/bin/python  /sbin/anaconda --liveinst --method=livecd:///dev/mapper/live-base
cmdline_file:   BOOT_IMAGE=/isolinux/vmlinuz0 root=live:LABEL=Fedora-Live-WS-x86_64-21-5 ro rd.live.image quiet rhgb rd.live.check
hashmarkername: anaconda
kernel:         3.17.4-301.fc21.x86_64
other involved packages: python-blivet-0.61.13-1.fc21.noarch, python-libs-2.7.8-7.fc21.x86_64
package:        anaconda-core-21.48.21-1.fc21.x86_64
packaging.log:  
product:        Fedora"
reason:         LVMError: lvactivate failed for root: running lvm lvchange -a y --config  devices { preferred_names=["^/dev/mapper/", "^/dev/md/", "^/dev/sd"] }  fedora_localhost/root failed
release:        Fedora release 21 (Twenty One)
version:        Fedora

Comment 56 David Shea 2015-04-15 14:15:39 UTC

*** This bug has been marked as a duplicate of bug 1209223 ***


Note You need to log in before you can comment on or make changes to this bug.