Bug 1217901

Summary: abrt-cli should depend on abrt-dbus
Product: [Fedora] Fedora Reporter: Giulio 'juliuxpigface' <juliux.pigface>
Component: abrtAssignee: Matej Habrnal <mhabrnal>
Status: CLOSED CURRENTRELEASE QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: unspecified Docs Contact:
Priority: unspecified    
Version: 23CC: abrt-devel-list, dvlasenk, fzatlouk, iprikryl, jfilak, mhabrnal, michal.toman, mmilata
Target Milestone: ---   
Target Release: ---   
Hardware: i686   
OS: Linux   
Whiteboard:
Fixed In Version: abrt-2.6.1-1.fc23 Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2015-07-20 14:38:31 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description Giulio 'juliuxpigface' 2015-05-02 16:03:22 UTC
Description of problem:
Querying 'abrt-cli ls' on Fedora 22 LXDE spin (Final TC1) throws an exception.
This spin doesn't have 'abrt-dbus' installed by default. After installing that package, everything works.

Version-Release number of selected component (if applicable):
abrt-cli-2.5.1-2.fc22.i686

How reproducible:
Always

Steps to Reproduce:
1. Verify that 'abrt-dbus' isn't installed.
2. Launch 'abrt-cli' via terminal.

Actual results:
[root@localhost ~]# abrt-cli ls
Can't get problem list from abrt-dbus:
GDBus.Error:org.freedesktop.DBus.Error.ServiceUnknown: The name
org.freedesktop.problems was not provided by any .service files

(process:2069): GLib-CRITICAL **: g_ptr_array_sort_with_data:
assertion 'array != NULL' failed
Segmentation fault (core dumped)

Expected results:
The installation of 'abrt-cli' should also provide 'abrt-dbus' too.

Comment 1 FrantiĊĦek Zatloukal 2015-05-02 16:06:46 UTC
*** Bug 1217902 has been marked as a duplicate of this bug. ***

Comment 2 Matej Habrnal 2015-05-04 09:05:09 UTC
I've created a pull request which fixes the bug https://github.com/abrt/abrt/pull/960

Comment 3 Jan Kurik 2015-07-15 14:12:14 UTC
This bug appears to have been reported against 'rawhide' during the Fedora 23 development cycle.
Changing version to '23'.

(As we did not run this process for some time, it could affect also pre-Fedora 23 development
cycle bugs. We are very sorry. It will help us with cleanup during Fedora 23 End Of Life. Thank you.)

More information and reason for this action is here:
https://fedoraproject.org/wiki/BugZappers/HouseKeeping/Fedora23