Bug 121998

Summary: installer doesn't recognize monitor or video card in Inspiron 9100
Product: [Fedora] Fedora Reporter: jonathan baron <baron>
Component: xorg-x11Assignee: Mike A. Harris <mharris>
Status: CLOSED RAWHIDE QA Contact:
Severity: medium Docs Contact:
Priority: medium    
Version: rawhideCC: xgl-maint
Target Milestone: ---   
Target Release: ---   
Hardware: i386   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2004-09-09 04:20:39 EDT Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
Bug Depends On: 119789    
Bug Blocks: 114963, 123268, 130887    
Attachments:
Description Flags
The original setup log
none
The oldest Xorg log I have
none
The output of lspci as requested.
none
The current xorg.conf file, which works
none
The original file made by Fefora, which did not work
none
The computer - the best I can do none

Description jonathan baron 2004-04-29 12:52:50 EDT
Description of problem:
I tried to install Fedora core 2 test 3 on a new Dell Inspiron 9100
with a video card that calls itself "6 mb ddr ATI's Mobility Radeon
9700 AGP 8x.  The installer did not detect the video card or the
monitor.  (I still don't know exactly what the monitor is.)  On boot,
the computer crashed after saying "x not configured."  (It went by
very fast.)  The crash was such that I could not turn off the computer
except by unplugging it and removing the battery.  This hapened the
second time too.  The third time, I put in the installation disk and
went into rescue mode.  I did not get the crash.  X just wouldn't
start.  I ran X -configure, and then tried the file it produced,
but that one did not detect the mouse, so it wouldn't work either.
Finally, I took the mouse section from the first xorg.conf file
and added it to the one produced by X -configure, and then I could
boot.  But I still can't get it to recognize the video card, and
the monitor is 800x600, instead of 1600x1050.

Perhaps the video card problem is another bug.  But I'll just
mention that I have tried several different options, and it keeps
reverting to generic vesa.  (ATI Radeon 9700, ATI Radeon Mobility,
etc.)  Before I report that bug, I'm going to look more on the
installation disks.  But this bug is definitely a problem with
the installation sequence.
Comment 1 jonathan baron 2004-04-29 20:17:26 EDT
I should mention that I am willing to carry out further tests.
This is a new model high-end Dell laptop, and those who can
fix this problem may not have one handy.  I don't need to use
it for a few weeks, although I will push ahead and try to get
it to work unless someone tells me to wait.

I can also send various log files, if anyone wants them.
Comment 2 jonathan baron 2004-05-01 21:51:24 EDT
I seem to have gotten it working by fiddling with xorg.conf and
deleting XFree86.conf.  It seems that the radeon driver is
present, just not recognized.  A setting of 1400x1050 seems
to work, even though technically it should be 1680x1050.

The lines that differ from various attempts that did not work are
as follows, with my comments in CAPS.

Section "Monitor"
 ### Uncomment if you don't want to default to DDC:
        Identifier   "Monitor0"
        VendorName   "Monitor Vendor"
        ModelName    "LCD Panel 1400x1050"
 ### Uncomment if you don't want to default to DDC:
#       HorizSync    31.5 - 90.0 THESE LINES WERE UNCOMMENTED
#       VertRefresh  59.0 - 75.0  ORIGINALLY
        Option      "dpms"
EndSection
Section "Device"
        Identifier  "Videocard0"
        Driver      "radeon" I PUT THESE LINES IN BY HAND
        VendorName  "ATI Technologies Inc"
        BoardName   "ATI Radeon AGP"
EndSection
                                                                     
                      
Section "Screen"
        Identifier "Screen0"
        Device     "Videocard0"
        Monitor    "Monitor0"
        DefaultDepth     16
        SubSection "Display"
                Viewport   0 0
                Depth     16
                Modes    "1400x1050" "1280x1024" "1280x960" "1152x864"
 "1024x768" "800x600" "640x480" [LINE FOLDED]
        EndSubSection
EndSection

This is still a bug.  This should have worked from the start,
especially since the driver seems actually to be there.  This
took approximately 50 attempts at various combinations of things.
Comment 3 jonathan baron 2004-05-02 19:39:42 EDT
Actually, it doesn't quite "work."  The setting of 1400x1050
gives that setting, which is not 1680x1050.  Thus, everything
is just stretched out horizontally.  I'm going to see if I
can get an updated version of the driver.
Comment 4 Mike A. Harris 2004-05-05 18:54:16 EDT
Please attach your X server log file, and full config file as
individual uncompressed file attachments for troubleshooting.

The output of "lspci -vvn" will also be useful if it turns out that
the driver or pcitable require PCI ID updates or modifications.

Do you have a URL for the technical specs on this laptop handy?
It may be useful in getting the native panel resolution to work
without having the hardware.

Thanks in advance.
Comment 5 jonathan baron 2004-05-05 19:22:13 EDT
Created attachment 100020 [details]
The original setup log
Comment 6 jonathan baron 2004-05-05 19:24:05 EDT
Created attachment 100021 [details]
The oldest Xorg log I have
Comment 7 jonathan baron 2004-05-05 19:26:15 EDT
Created attachment 100022 [details]
The output of lspci as requested.
Comment 8 jonathan baron 2004-05-05 19:27:28 EDT
Created attachment 100023 [details]
The current xorg.conf file, which works
Comment 9 jonathan baron 2004-05-05 19:28:56 EDT
Created attachment 100024 [details]
The original file made by Fefora, which did not work
Comment 10 jonathan baron 2004-05-05 19:37:00 EDT
Created attachment 100025 [details]
The computer - the best I can do

I cannot find a page with the technical data.  I am
attaching the best one I have, which I cannot find again.
(Dell's web site is the worst ever.)  I have since
discovered a log more information about what it has and
will be happy to supply it.
Comment 11 Mike A. Harris 2004-05-06 00:36:58 EDT
Thanks for your information above.  I believe I've isolated at least
one of the problems to being missing PCI IDs in the hardware database,
of which is reported in another bug we're tracking also.  This will
be added either to the final Fedora Core 2 release, or to erratum
updates sometime after the initial release.

Right now the installer is defaulting to the "vesa" driver because
it does not recognize the hardware IDs, however once this is updated
the card should autodetect properly and be configured to use the
Radeon driver.

The Radeon driver PCI ID updates are being tracked in bug #119789,
which you may wish to add yourself to the CC list for instant
notification of when the updates are available.

I will mark this bug report as dependant on that one so they
can be tracked together also.

There's another bug concerning the monitor frequency lines being
commented out in the config file, which may be contributing to some
of the problems you're experiencing as well.  That is bug #120950 if
you wish to track it.

We'll use this bug report to track the hardware autodetect issue
for now, and if there are further problems once that is fixed and
tested, they can be filed in separate reports and tracked
individually.

Thanks again for the information.
Comment 12 Mike A. Harris 2004-05-06 00:39:56 EDT
One additional note I forgot to mention, is that the monitor would
not have been detected due to the video card not being detected.  Once
the video card is being detected properly, then the "radeon" driver
should be able to properly DDC probe your monitor and detect it as
well.  Once the video card detection is fixed, there are still a few
reasons why it might still fail to detect the monitor, but we can
explore those later if it is still a problem also.

Thanks again.
Comment 13 Mike A. Harris 2004-09-09 04:20:39 EDT
The current rawhide hwdata package should autodetect all supported
Radeon hardware correctly, and assign the "radeon" driver now.

Setting status to "RAWHIDE"