Bug 120950 - (uncomment-monitor) libxf86config writes the monitor specification commented out
libxf86config writes the monitor specification commented out
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: xorg-x11 (Show other bugs)
rawhide
All Linux
medium Severity high
: ---
: ---
Assigned To: X/OpenGL Maintenance List
: Reopened
: 108954 121717 121766 121946 122072 122341 122422 122439 122461 122573 122608 122627 122757 122770 122840 123099 123306 123361 (view as bug list)
Depends On:
Blocks: FC2Blocker
  Show dependency treegraph
 
Reported: 2004-04-15 11:56 EDT by Jeremy Katz
Modified: 2007-11-30 17:10 EST (History)
23 users (show)

See Also:
Fixed In Version: awhileago
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-11-12 11:46:00 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jeremy Katz 2004-04-15 11:56:02 EDT
programs/Xserver/hw/xfree86/parser/Monitor.c:675:                  
fprintf(cf," ### Uncomment if you don't want to default to DDC:\n");

This completely breaks the installer in cases where DDC probing
doesn't work (ie, KVMs) as I assume that what I write out is going to
be accepted.  Except that now it's getting written out commented out
(via pyxf86config -> libxf86config, hence why I cc'd alex)
Comment 1 Jeremy Katz 2004-04-15 12:24:09 EDT
Bad hacks are us... working around for test3...

Index: src//xserver.py
===================================================================
RCS file: /usr/local/CVS/rhpl/src/xserver.py,v
retrieving revision 1.11
diff -u -u -r1.11 xserver.py
--- src//xserver.py     13 Apr 2004 21:49:36 -0000      1.11
+++ src//xserver.py     15 Apr 2004 16:22:20 -0000
@@ -360,6 +360,21 @@
     
     xcfgdata.write(filename)
 
+    # BAD BAD BAD AWFUL HACK to work around #120950
+    f = open(filename, "r")
+    lines = f.readlines()
+    f.close()
+    buf = ""
+    for l in lines:
+        if l.startswith("#") and l.find("HorizSync") != -1:
+            l = l.replace("#", "")
+        if l.startswith("#") and l.find("VertRefresh") != -1:
+            l = l.replace("#", "")
+        buf += l
+    f = open(filename, "w")
+    f.write(buf)
+    f.close()
+
Comment 2 John Reiser 2004-04-28 14:43:34 EDT
Sony Multiscan 15sf doesn't even have DDC, so the extra effort of
specifying it by hand during install gets ignored silently, and
confuses the user.
Comment 3 Jeremy Katz 2004-05-03 15:10:24 EDT
*** Bug 122341 has been marked as a duplicate of this bug. ***
Comment 4 Mike A. Harris 2004-05-05 18:37:24 EDT
*** Bug 122573 has been marked as a duplicate of this bug. ***
Comment 5 Mike A. Harris 2004-05-05 18:41:16 EDT
More and more bug reports are showing up which are caused by this
problem.  I'm adding this bug to the Fedora Core 2 BLOCKER list,
and increasing priority.

This bug will be the master duplicate for this issue, with bug
alias "uncomment-monitor" for easier duplicate closure.
Comment 6 Mike A. Harris 2004-05-05 18:46:50 EDT
*** Bug 122439 has been marked as a duplicate of this bug. ***
Comment 7 Mike A. Harris 2004-05-07 01:43:46 EDT
*** Bug 122072 has been marked as a duplicate of this bug. ***
Comment 8 Mike A. Harris 2004-05-07 05:23:55 EDT
I've fixed this issue in 6.7.0-1 version of libxf86config, however
before it will be fixed in an end-user-visible manner, 3 additional
steps are required:

1) Once the 6.7.0-1 build is complete, pyxf86config needs to be
   recompiled, because it links statically to libxf86config.a
   (there's no shared version of this library).

2) Users must upgrade to both xorg-x11-6.7.0-1 or higher, and to
   the new pyxf86config once it's available.

3) system-config-display --reconfig *must* be ran, as the fixes
   are to the code which writes out the config file, so if no new
   config file is written out, users wont see the changes until they
   reconfigure.

The only way to automate step 3 to both avoid further users from
experiencing this problem, and also avoid further bug reports coming
in, would be to hack the xorg-x11 specfile rpm scripts to uncomment
the config file lines, but that has the downside of also uncommenting
these lines in config files which users have purposefully commented
them out themselves (there's no way to distinguish between the two).

New FC2 installations should work properly, and upgrades from
RHL 7.x/8.0/9 and FC1 should work properly.  Upgrades from FC2 test
releases which contained the libxf86config that wrote out the
commented lines, of which the user hasn't already uncommented the
lines, will require users to either uncomment them, or re-run
"system-config-display --reconfig"

This problem is the result of an XFree86 change to libxf86config,
which wrongly assumes that all display types support DDC, and that
all systems will have working DDC on all displays, and nothing
will ever interfere with that.  A rather utopian assumption, which
would be fantastic if it were true, but unfortunately it isn't.  ;o)

Sorry for any inconveniences to beta testers, and thanks for
testing!
Comment 9 Mike A. Harris 2004-05-07 07:01:55 EDT
*** Bug 122627 has been marked as a duplicate of this bug. ***
Comment 10 Douglas Furlong 2004-05-07 08:19:22 EDT
*** Bug 122422 has been marked as a duplicate of this bug. ***
Comment 11 Phil Anderson 2004-05-07 09:36:52 EDT
Mike - These bugs are all duplicates:
Bug 122461
Bug 121946
Bug 121717
Comment 12 Mike A. Harris 2004-05-07 09:42:10 EDT
Thanks Phil!
Comment 13 Mike A. Harris 2004-05-07 09:42:23 EDT
*** Bug 122461 has been marked as a duplicate of this bug. ***
Comment 14 Mike A. Harris 2004-05-07 09:43:29 EDT
*** Bug 121946 has been marked as a duplicate of this bug. ***
Comment 15 Mike A. Harris 2004-05-07 09:44:16 EDT
*** Bug 121717 has been marked as a duplicate of this bug. ***
Comment 16 Lawrence MacIntyre 2004-05-07 10:06:05 EDT
*** Bug 122627 has been marked as a duplicate of this bug. ***
Comment 17 Miloslav Trmac 2004-05-07 11:40:00 EDT
*** Bug 122608 has been marked as a duplicate of this bug. ***
Comment 18 Mike A. Harris 2004-05-08 01:53:55 EDT
*** Bug 121766 has been marked as a duplicate of this bug. ***
Comment 19 Mike A. Harris 2004-05-08 01:55:23 EDT
*** Bug 122757 has been marked as a duplicate of this bug. ***
Comment 20 Mike A. Harris 2004-05-08 02:02:55 EDT
*** Bug 122770 has been marked as a duplicate of this bug. ***
Comment 21 Mike A. Harris 2004-05-11 19:04:40 EDT
*** Bug 108954 has been marked as a duplicate of this bug. ***
Comment 22 Mike A. Harris 2004-05-14 12:55:47 EDT
*** Bug 123099 has been marked as a duplicate of this bug. ***
Comment 23 Jeremy Katz 2004-05-17 14:01:53 EDT
*** Bug 123361 has been marked as a duplicate of this bug. ***
Comment 24 Brent Fox 2004-05-17 14:13:30 EDT
*** Bug 123306 has been marked as a duplicate of this bug. ***
Comment 25 Brent Fox 2004-05-17 14:34:38 EDT
*** Bug 122840 has been marked as a duplicate of this bug. ***
Comment 26 Jonathan Smith 2004-05-30 14:50:34 EDT
So what happens when "upgrades from FC1" that "should work properly" 
do not? And, your system is crippled because this bug remained 
unfixed? And the numerous complaints about it were ignored and dumped 
into RESOLVED RAWHIDE?
Comment 27 Michael Shigorin 2007-11-10 06:28:57 EST
(In reply to comment #26)
> ...
Well, some just change distros.
Comment 28 Mike A. Harris 2007-11-10 15:23:34 EST
And some, reassign the bug owner, so they don't get any more emails from bugs
that have been closed for 3.5 years...  ;o)
Comment 29 Matěj Cepl 2007-11-12 11:32:35 EST
Jeremy, are you able to reproduce this with Fedora {7,8,Rawhide}?

Note You need to log in before you can comment on or make changes to this bug.