Bug 1220574

Summary: koji download-build missing dependency on yum
Product: [Fedora] Fedora Reporter: Rob Crittenden <rcritten>
Component: kojiAssignee: Dennis Gilmore <dennis>
Status: CLOSED DUPLICATE QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: unspecified Docs Contact:
Priority: unspecified    
Version: 22CC: dennis, juliux.pigface, mikem
Target Milestone: ---   
Target Release: ---   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2015-10-21 19:26:13 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description Rob Crittenden 2015-05-11 23:12:58 UTC
Description of problem:

koji is missing a dependency on yum so download-build fails with a traceback:

# koji download-build 629499
Traceback (most recent call last):
  File "/bin/koji", line 56, in <module>
    import yum.comps
ImportError: No module named yum.comps

# dnf install yum

# koji download-build 629499
ipsilon-authldap-0.6.0-1.fc22.noarch.rpm                    |  31 kB  00:00 !!! 
...
profit!

Version-Release number of selected component (if applicable):

koji-1.9.0-11.fc22.20150423git52a0188.noarch

Comment 1 Giulio 'juliuxpigface' 2015-10-21 19:26:13 UTC

*** This bug has been marked as a duplicate of bug 1230888 ***