Bug 1230888 - Koji installed on F22 is missing yum.comps python module from yum package
Summary: Koji installed on F22 is missing yum.comps python module from yum package
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: koji
Version: 23
Hardware: x86_64
OS: Linux
unspecified
unspecified
Target Milestone: ---
Assignee: Mike McLean
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 1220574 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2015-06-11 17:16 UTC by Jan Chaloupka
Modified: 2016-03-17 19:29 UTC (History)
9 users (show)

Fixed In Version: koji-1.10.1-1.fc23 koji-1.10.1-1.fc22 koji-1.10.1-3.el7 koji-1.10.1-3.el6
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-03-17 18:59:11 UTC


Attachments (Terms of Use)

Description Jan Chaloupka 2015-06-11 17:16:59 UTC
Description of problem:
When running F22 in a docker container and running 'koji latest-pkg rawhide docker' I get:

Traceback (most recent call last):
  File "/usr/bin/koji", line 56, in <module>
    import yum.comps
ImportError: No module named yum.comps

After I install yum, yum.comps is installed and koji command works as expected.

Version-Release number of selected component (if applicable):
dnf-1.0.0-1.fc22.noarch
koji-1.9.0-11.fc22.20150423git52a0188.noarch
docker-io-1.5.0-1.fc20.x86_64 (don't think docker version is relevant)

How reproducible:
Always

Steps to Reproduce:
# systemctl start docker
# docker run -it fedora:latest /bin/bash

Inside docker container run:
# dnf install koji -y
# koji latest-pkg rawhide docker

Actual results:
Traceback (most recent call last):
  File "/usr/bin/koji", line 56, in <module>
    import yum.comps
ImportError: No module named yum.comps

Expected results:
Build                                     Tag                   Built by
----------------------------------------  --------------------  ----------------
docker-1.7.0-17.gitdcff4e1.fc23           f23                   lsm5

Additional info:
Installing yum fixes this issue.

Comment 1 Jan Chaloupka 2015-06-11 17:18:23 UTC
Maybe dnf package should provide missing yum.comps module.

What do you think Michal?

Comment 2 Michal Luscon 2015-06-22 11:10:31 UTC
DNF uses its own comps implementation and therefore it's not a good idea to include some unrelated piece of code from YUM. The solution here is to mark yum as a koji dependency and port koji to dnf in long term.

Comment 3 Jan Chaloupka 2015-06-22 11:27:47 UTC
What about provide python-yum-comps subpackage of dnf? Or create a new package providing missing module? Which would be obsoleted once koji is updated or yum.comps replaced.

Comment 4 Jan Chaloupka 2015-06-22 11:29:33 UTC
> The solution here is to mark yum as a koji dependency
> and port koji to dnf in long term.

It would result having yum and dnf on the same system. Is not one of the targets of dnf to replace yum?

Comment 5 Michal Luscon 2015-06-23 09:32:12 UTC
Yes, the main goal is to replace YUM but not by treasuring some unmaintained fragments of YUM under DNF. Also, please be aware of YUM's incompatibility with Python 3 which IIRC is planed as default for F23. DNF team is open to assist with any issues that will arise during koji migration to DNF, but this proposal is no go for us.

Comment 6 Giulio 'juliuxpigface' 2015-10-21 19:26:13 UTC
*** Bug 1220574 has been marked as a duplicate of this bug. ***

Comment 7 Mathieu Bridon 2015-10-29 12:32:38 UTC
Still the same in F23.

Dennis, can you add the missing "Requires: yum" ?

Comment 8 Victor Costan 2015-11-13 20:39:45 UTC
Got hit by this too. I work around it using "dnf install fedora-packaging", but that feels ugly.

Comment 9 Micah Abbott 2015-11-14 15:53:52 UTC
Also hitting this in F23

Comment 10 Fedora Update System 2015-11-18 04:14:56 UTC
koji-1.10.1-1.fc23 has been submitted as an update to Fedora 23. https://bodhi.fedoraproject.org/updates/FEDORA-2015-65152c5896

Comment 11 Fedora Update System 2015-11-18 04:15:40 UTC
koji-1.10.1-1.fc22 has been submitted as an update to Fedora 22. https://bodhi.fedoraproject.org/updates/FEDORA-2015-82b7665427

Comment 12 Fedora Update System 2015-11-18 04:15:59 UTC
koji-1.10.1-1.el7 has been submitted as an update to Fedora EPEL 7. https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2015-d3a5f5be18

Comment 13 Fedora Update System 2015-11-18 04:16:45 UTC
koji-1.10.1-1.el6 has been submitted as an update to Fedora EPEL 6. https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2015-9afc1888c0

Comment 14 Fedora Update System 2015-11-19 14:52:20 UTC
koji-1.10.1-1.fc22 has been pushed to the Fedora 22 testing repository. If problems still persist, please make note of it in this bug report.
If you want to test the update, you can install it with
$ su -c 'dnf --enablerepo=updates-testing update koji'
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2015-82b7665427

Comment 15 Fedora Update System 2015-11-19 15:27:15 UTC
koji-1.10.1-1.fc23 has been pushed to the Fedora 23 testing repository. If problems still persist, please make note of it in this bug report.
If you want to test the update, you can install it with
$ su -c 'dnf --enablerepo=updates-testing update koji'
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2015-65152c5896

Comment 16 Fedora Update System 2015-11-19 16:55:50 UTC
koji-1.10.1-1.fc23 has been pushed to the Fedora 23 testing repository. If problems still persist, please make note of it in this bug report.
If you want to test the update, you can install it with
$ su -c 'dnf --enablerepo=updates-testing update koji'
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2015-65152c5896

Comment 17 Fedora Update System 2015-11-19 23:19:14 UTC
koji-1.10.1-1.el6 has been pushed to the Fedora EPEL 6 testing repository. If problems still persist, please make note of it in this bug report.
If you want to test the update, you can install it with
$ su -c 'yum --enablerepo=epel-testing update koji'
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2015-9afc1888c0

Comment 18 Fedora Update System 2015-11-19 23:49:47 UTC
koji-1.10.1-1.el7 has been pushed to the Fedora EPEL 7 testing repository. If problems still persist, please make note of it in this bug report.
If you want to test the update, you can install it with
$ su -c 'yum --enablerepo=epel-testing update koji'
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2015-d3a5f5be18

Comment 19 Fedora Update System 2015-11-26 20:58:33 UTC
koji-1.10.1-1.fc23 has been pushed to the Fedora 23 stable repository. If problems still persist, please make note of it in this bug report.

Comment 20 Fedora Update System 2015-12-28 23:55:41 UTC
koji-1.10.1-1.fc22 has been pushed to the Fedora 22 stable repository. If problems still persist, please make note of it in this bug report.

Comment 21 Fedora Update System 2016-03-01 23:54:54 UTC
koji-1.10.1-3.el7 has been submitted as an update to Fedora EPEL 7. https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2016-89a1a2a853

Comment 22 Fedora Update System 2016-03-01 23:55:14 UTC
koji-1.10.1-3.el6 has been submitted as an update to Fedora EPEL 6. https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2016-8ce765ff4f

Comment 23 Fedora Update System 2016-03-03 02:48:51 UTC
koji-1.10.1-3.el6 has been pushed to the Fedora EPEL 6 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2016-8ce765ff4f

Comment 24 Fedora Update System 2016-03-03 02:52:15 UTC
koji-1.10.1-3.el7 has been pushed to the Fedora EPEL 7 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2016-89a1a2a853

Comment 25 Fedora Admin XMLRPC Client 2016-03-10 14:45:43 UTC
This package has changed ownership in the Fedora Package Database.  Reassigning to the new owner of this component.

Comment 26 Fedora Update System 2016-03-17 18:59:06 UTC
koji-1.10.1-3.el7 has been pushed to the Fedora EPEL 7 stable repository. If problems still persist, please make note of it in this bug report.

Comment 27 Fedora Update System 2016-03-17 19:29:16 UTC
koji-1.10.1-3.el6 has been pushed to the Fedora EPEL 6 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.