Bug 1244558

Summary: Switch initial-setup to use python3
Product: [Fedora] Fedora Reporter: Peter Robinson <pbrobinson>
Component: initial-setupAssignee: Martin Kolman <mkolman>
Status: CLOSED CURRENTRELEASE QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: unspecified Docs Contact:
Priority: unspecified    
Version: rawhideCC: awilliam, mhroncok, mkolman, msivak, mstuchli, pschindl, robatino, sgraf, vpodzime
Target Milestone: ---Keywords: Reopened
Target Release: ---   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard: AcceptedBlocker
Fixed In Version: initial-setup-0.3.35-1.fc23 Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2015-11-04 11:35:40 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
Bug Depends On:    
Bug Blocks: 1014209, 1170817    

Description Peter Robinson 2015-07-20 01:26:18 UTC
In the current Fedora ARM minimal image one of the last remaining requirements that depends on python2 is the initial-setup tui. It depends on:

libreport-python
python
python(abi) = 2.7
python-di

Comment 1 Vratislav Podzimek 2015-07-20 07:31:15 UTC
Martine, could you please have a look at this? AFAICT, this should be just about modifying/fixing requires in .spec file.

Comment 2 Martin Kolman 2015-07-20 08:22:07 UTC
(In reply to Vratislav Podzimek from comment #1)
> Martine, could you please have a look at this? AFAICT, this should be just
> about modifying/fixing requires in .spec file.

Yes, more or less. But Rawhide was rather too broken lately for me to actually test the changes, that's why it has not yet been done.

Comment 3 Peter Robinson 2015-07-20 08:54:55 UTC
It's been relatively OK the last few weeks, I've moved now to the branched f23

Comment 4 Vratislav Podzimek 2015-07-20 09:37:32 UTC
*** Bug 1244557 has been marked as a duplicate of this bug. ***

Comment 5 Adam Williamson 2015-07-20 16:02:00 UTC
Alpha blocker rationale: i-s is required to create a user and/or root password for ARM images. Thus this violates "A working mechanism to create a user account must be clearly presented during installation and/or first boot of the installed system." for the ARM minimal images at least.

Comment 6 Petr Schindler 2015-07-20 17:05:33 UTC
Discussed at today's blocker review meeting [1].

This bug was accepted as Alpha blocker - This bug is a violation of the following Alpha criterion for ARM: "A working mechanism to create a user account must be clearly presented during installation and/or first boot of the installed system." Completing the port to Python3 will make i-s run and satisfy the criterion.

[1] http://meetbot.fedoraproject.org/fedora-blocker-review/2015-07-20/

Comment 7 Peter Robinson 2015-07-28 15:17:25 UTC
Martin: any status update on how you're getting on with this?

Comment 8 Martin Kolman 2015-07-28 18:09:53 UTC
(In reply to Peter Robinson from comment #7)
> Martin: any status update on how you're getting on with this?

I've finally managed to start working on this today, overall good progress, with a single major roadblock so far - the python-di[0] package. Initial Setup depends on it, but it is Python 2 only. So either python-di needs to be ported to Python 3 or Initial Setup changed so that it no longer depends on python-di.

[0] http://koji.fedoraproject.org/koji/packageinfo?packageID=15151

Comment 9 Miro Hrončok 2015-07-28 18:57:29 UTC
di is an inside project by Martin Sivák (CCed). It's codebase isn't very large and should be easy to port, unless it does some crazy things.

Ask Matěj Stuchlík (CCed), if you'll need some assistance from our team.

Comment 10 Martin Kolman 2015-07-29 15:44:46 UTC
(In reply to Miro Hrončok from comment #9)
> di is an inside project by Martin Sivák (CCed). It's codebase isn't very
> large and should be easy to port, unless it does some crazy things.
> 
> Ask Matěj Stuchlík (CCed), if you'll need some assistance from our team.

Well, it was only needed for tests that apparently never got implemented. So I've just removed it for now & we can add it back later when it is ported to Python 3 and we have some tests that use it.

Comment 11 Adam Williamson 2015-07-31 20:28:42 UTC
This appears to be addressed by initial-setup-0.3.35-1.fc23 , but there is no Bodhi update for it. Can we please get one? Thanks!

Comment 12 Fedora Update System 2015-07-31 20:32:31 UTC
initial-setup-0.3.35-1.fc23 has been submitted as an update for Fedora 23.
https://admin.fedoraproject.org/updates/initial-setup-0.3.35-1.fc23

Comment 13 Peter Robinson 2015-07-31 20:35:27 UTC
adam I just pushed it

Comment 14 Peter Robinson 2015-07-31 22:10:42 UTC
And while I can't put karma on my own bug I can confirm I can run initial-setup on an arm host

Comment 15 Fedora Update System 2015-08-01 17:41:48 UTC
Package initial-setup-0.3.35-1.fc23:
* should fix your issue,
* was pushed to the Fedora 23 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing initial-setup-0.3.35-1.fc23'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2015-12598/initial-setup-0.3.35-1.fc23
then log in and leave karma (feedback).

Comment 16 Fedora Update System 2015-08-06 06:01:47 UTC
initial-setup-0.3.35-1.fc23 has been pushed to the Fedora 23 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 17 Fedora Update System 2015-09-08 09:23:53 UTC
initial-setup-0.3.36-1.fc23 has been submitted as an update to Fedora 23. https://bodhi.fedoraproject.org/updates/FEDORA-2015-15307

Comment 18 Fedora Update System 2015-09-08 17:51:25 UTC
initial-setup-0.3.36-1.fc23 has been pushed to the Fedora 23 testing repository. If problems still persist, please make note of it in this bug report.\nIf you want to test the update, you can install it with \n su -c 'yum --enablerepo=updates-testing update initial-setup'. You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2015-15307

Comment 19 Stanislav Graf 2015-09-08 18:15:01 UTC
*** Bug 1244394 has been marked as a duplicate of this bug. ***